Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

Silver

How to configure inter vlan routing on 3750 series

I have 3750 series with GIBICs ports I want to create 10 vlans with its sub-net and enable all vlans to access internet.

Please help

---

Posted by WebUser Sayed Ahmad Sahim from Cisco Support Community App

4 REPLIES
New Member

Re: How to configure inter vlan routing on 3750 series

try this example

ip routing # enable your ip routing

create new vlans 2 - 10.

vlan 2

vlan 3

.........

and so forth.

then...

create SVI i used

interface Vlan2

ip address 10.2.0.1 255.255.0.0

interface Vlan3

ip address 10.3.0.1 255.255.0.0

... and so forth

and important your default route

ip route 0.0.0.0 0.0.0.0 10.0.0.137

Hall of Fame Super Gold

How to configure inter vlan routing on 3750 series

ip routing enable

VIP Purple

Re: How to configure inter vlan routing on 3750 series

Hi ,

Try this:

ip routing
!
interface FastEthernet....

switchport access vlan 10
switchport mode access
!
interface FastEthernet.....
switchport access vlan 20
switchport mode access

interface Vlan10
ip address 192.168.10.1 255.255.255.0
!
interface Vlan20
ip address 192.168.20.1 255.255.255.0

*****Note:

And on hosts just assign IP addresses and default gateways (to the corresponding interface VLANs) -> hosts in different VLANs can communicate.

Regards

Please rate if it helps.

Hall of Fame Super Silver

How to configure inter vlan routing on 3750 series

There have been several responses that describe enabling routing and configuring routing which enables the hosts on the VLANs to communicate with each other. One response included configuring a default route which would be very important in access to Internet. But so far no one has discussed the need to do address translation. If you are using private addressing on the VLANs then you need to do address translation so the inside hosts can access the public Internet. Unfortunately I do not believe that the 3750 does address translation. So you probably need to connect the 3750 to a router to enable Internet access.

HTH

Rick

3354
Views
0
Helpful
4
Replies
CreatePlease login to create content