Cisco Support Community
Community Member

How to configure interface Nexus 7000?


I am just trying to configure the ethernet interfaces on my Nexus 7010 48 port module. When I do a "show interface" I only see the management interface on the management module and not the 48 port module. When I run a "show hardware" I am able to see that the module is plugged in to slot 1 and the status is "ok." I thought the interfaces would just show up once I connected the module. Is this not correct? And then I could access the ports with "interface ethernet 1/x" for the ports on module 1.


Everyone's tags (2)

How to configure interface Nexus 7000?

Check out this document


Posted by WebUser Janet Doe from Cisco Support Community App

Community Member

How to configure interface Nexus 7000?

Looked in there already. Seemed like the command should just be "interface ethernet 1/1" to configure port 1 on the module in slot 1. However I get an invalid range error and when I run "show interface" I only see the management blade interfaces rather than the 48 ethernet interfaces on the module.

Community Member

How to configure interface Nexus 7000?

Any ideas?

Cisco Employee

How to configure interface Nexus 7000?

Hi Nathaniel,

Are you using non default VDC or RBAC on this switch. Can you attach show command output / show runn to check further.


Community Member

How to configure interface Nexus 7000?

Subhash, I believe I am using the default vdc on the switch.

show run shows:


Nexus-7000(config)# show running-config

!Command: show running-config

!Time: Tue Jul  9 19:21:30 2013

version 6.1(2)

poweroff xbar 4

poweroff xbar 5

hardware fabrics max 3

license grace-period

switchname Nexus-7000

system admin-vdc

vdc Nexus-7000 id 1

  cpu-share 5

  limit-resource vlan minimum 16 maximum 4094

  limit-resource monitor-session minimum 0 maximum 2

  limit-resource monitor-session-erspan-dst minimum 0 maximum 23

  limit-resource vrf minimum 2 maximum 4096

  limit-resource port-channel minimum 0 maximum 768

  limit-resource u4route-mem minimum 96 maximum 96

  limit-resource u6route-mem minimum 24 maximum 24

  limit-resource m4route-mem minimum 58 maximum 58

  limit-resource m6route-mem minimum 8 maximum 8

  limit-resource monitor-session-inband-src minimum 0 maximum 1

username admin password 5 $1$jyn3hULs$7iGtrdO2BwgjGOJIRHkN81  role network-admin

ip domain-lookup

copp profile strict

snmp-server user admin network-admin auth md5 0x3688458ab63c86695ec6a773488d138c

priv 0x3688458ab63c86695ec6a773488d138c localizedkey

rmon event 1 log trap public description FATAL(1) owner PMON@FATAL

rmon event 2 log trap public description CRITICAL(2) owner PMON@CRITICAL

rmon event 3 log trap public description ERROR(3) owner PMON@ERROR

rmon event 4 log trap public description WARNING(4) owner PMON@WARNING

rmon event 5 log trap public description INFORMATION(5) owner PMON@INFO

vrf context management

  ip route

vlan 1

interface mgmt0

  ip address

line console

line vty

boot kickstart bootflash:/n7000-s2-kickstart.6.1.2.bin sup-1

boot system bootflash:/n7000-s2-dk9.6.1.2.bin sup-1


show interface shows


Nexus-7000(config)# show interface

mgmt0 is up

admin state is up,

  Hardware: GigabitEthernet, address: 8478.ac57.3e2c (bia 8478.ac57.3e2c)

  Internet Address is

  MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec

  reliability 255/255, txload 1/255, rxload 1/255

  Encapsulation ARPA, medium is broadcast

  full-duplex, 1000 Mb/s

  Auto-Negotiation is turned on

  Auto-mdix is turned off

  EtherType is 0x0000

  1 minute input rate 1656 bits/sec, 1 packets/sec

  1 minute output rate 3048 bits/sec, 1 packets/sec


    55430 input packets 9389 unicast packets 7792 multicast packets

    38249 broadcast packets 5342508 bytes


    6401 output packets 6397 unicast packets 1 multicast packets

    3 broadcast packets 947681 bytes


It's as if the interfaces are not there. But with show hardware, I can see that the module is seen.

Module1  ok

  Module type is : 1/10 Gbps Ethernet Module

  0 submodules are present

  Model number is N7K-F248XP-25E

  H/W version is 1.0

  Part Number is 73-14976-02

  Part Revision is A0

  Manufacture Date is Year 17 Week 12

  Serial number is JAF1712BFCB


How to configure interface Nexus 7000?

Take a read of the post Nexus 7009 does not show the N7K-F248XP-25 modules ethernet ports n sh run.

The solution there appears to be the use of the system module-type command.


Community Member

How to configure interface Nexus 7000?

Thanks Steve. That seems to be very close to what I am looking for. We are running 6.1(2) right now but I see that it does not support the "system module-type" command. THat is only in 6.1(3). We are not able to get the upgrade yet due to SmartNet problems. Don't think there is a work around command on 6.1(2) that does the same thing...

How to configure interface Nexus 7000?

Do you have any other I/O modules in the same chassis, either the M1, M2 or F1 series I/O modules? Currently the F2 and F2E modules needs to be in their own VDC.

As per the section Integrating F2 Series Modules Into a Cisco Nexus 7000 Series System in the NX-OS 6.1 release notes:

  • An F2 Series module requires its own F2 Series module VDC. This VDC is restricted to the F2 Series module; M1 and F1 ports cannot be in the F2 Series module VDC. The default VDC can also be configured as an F2 Series module VDC.


Cisco Employee

Re: How to configure interface Nexus 7000?

Check output of 'show vdc membership' command. These interfaces will all appear
in VDC 0, which is reserved for unallocated interfaces:

vdc_id: 0 vdc_name: Unallocated interfaces:

Ethernet15/1          Ethernet15/2          Ethernet15/3
Ethernet15/4          Ethernet15/5          Ethernet15/6
Ethernet15/7          Ethernet15/8          Ethernet15/9

This needs to be allocated to your current VDC id 1. Refer below link for more information.

Allocating interfaces to a VDC:
If still it doesn't work, then you will need to create a separate VDC, configure that VDC to support the F2 module, and then allocate the appropriate interfaces to that new VDC.



Community Member

How to configure interface Nexus 7000?

Thank you very much guys. I was not able to add the ethernet ports to vdc1 since the admin vdc was not specified to handle f2 (and could not be set to handle it with limit-resources). Instead, I created another vdc and was able to allocate the interfaces and configure them.

Many thanks to both of you for your help!

Community Member

HI Skapadi, Thanks...I was

HI Skapadi,


Thanks...I was also stucked  on same issue, given link helped me...Thank you so long..

CreatePlease to create content