Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

How to configure PPPoE on CISCO 831 with my ISP

Hello there,

For some reason I messed up my home router and now I only have a CISCO 831 available and I would like to configure PPPoE on it and to use it as my home router from now on.

The question is that I don't know how to configure it, I found some useful links on the internet but everytime I tried to follow the steps, at some point, my router didn't had some of the options on the command line.

I, most likely, have a dynamic IP from my ISP and I use a username and a password to connect to internet.

Here is the start-up config that I have so far but don't know how to make it work, what should I do more to make it work over internet?

Using 971 out of 131072 bytes

!

version 12.4

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname Home831

!

boot-start-marker

boot-end-marker

!

enable password XXXXXXXXXXX

!

no aaa new-model

!

resource policy

!

ip subnet-zero

!

!

ip cef

vpdn enable

!

!

!

!

!

!

!

!

!

bba-group pppoe global

!

!

interface Ethernet0

no ip address

shutdown

!

interface Ethernet1

no ip address

shutdown

duplex auto

!

interface Ethernet2

no ip address

shutdown

!

interface FastEthernet1

duplex auto

speed auto

!

interface FastEthernet2

duplex auto

speed auto

!

interface FastEthernet3

duplex auto

speed auto

!

interface FastEthernet4

duplex auto

speed auto

!

ip classless

ip http server

no ip http secure-server

!

!

!

control-plane

!

!

line con 0

password XXXXXXXXXXX

logging synchronous

login

no modem enable

line aux 0

line vty 0 4

password cisco

logging synchronous

login

!

scheduler max-task-time 5000

end

In case you need more info, please ask.

Cristian

  • LAN Switching and Routing
2 REPLIES
VIP Purple

How to configure PPPoE on CISCO 831 with my ISP

New Member

How to configure PPPoE on CISCO 831 with my ISP

Hello,

I did that, followed the post, configured as follows but still cannot connect:

version 12.2

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname 831

!

logging queue-limit 100

!

ip subnet-zero

ip dhcp excluded-address 192.168.1.1

!

ip dhcp pool LOCALPOOL

import all

network 192.168.1.0 255.255.255.0

default-router 192.168.1.1

!

ip audit notify log

ip audit po max-events 100

no ftp-server write-enable

!

interface Ethernet0

description Inside private interface

ip address 192.168.1.1 255.255.255.0

ip nat inside

hold-queue 100 out

!

interface Ethernet1

description Connection to DSL Modem ISP

no ip address

ip tcp adjust-mss 1452

load-interval 30

pppoe enable

pppoe-client dial-pool-number 1

no cdp enable

!

interface Dialer1

ip address negotiated

ip mtu 1492

ip nat outside

encapsulation ppp

dialer pool 1

dialer-group 1

no cdp enable

ppp authentication chap pap callin

ppp pap sent-username "my username without qotas" password 0 "my password without qotas"

!

ip nat inside source list 1 interface Dialer1 overload

ip classless

ip http server

no ip http secure-server

!

access-list 1 permit 192.168.1.0 0.0.0.255

!

ip route 0.0.0.0 0.0.0.0 Dialer1

dialer-list 1 protocol ip permit

!

line con 0

no modem enable

stopbits 1

line aux 0

stopbits 1

line vty 0 4

login

!

scheduler max-task-time 5000

!

end

What is wrong? Can you please tell me what I have to do more?

Thanks Cristian

220
Views
0
Helpful
2
Replies