Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k

How to configure VRF Lite on 6509 with OSPF and BGP ?

Hi,

I would like to know how have I to configure my switches for VRF-Lite with OSPF and BGP ?

In fact, our LAN switches 6509 must be configured with VRF-Lite. The routing protocol on the LAN is OSPF. I don't have problem for this (I have already done this before).

The problem is that our 6509 are connected to router using BGP protocol.

There are no VRF configured on the BGP routers and it's not possible to do this.

How have I to configure my 6509 in order to have OSPF and BGP working together in one VRF environment on the 6509 ?

So, I only need to redistribute BGP protocol in only one VRF which are OSPF enabled.

I tested with these commands on the 6509 (the BGP router 10.1.1.2 is connected with the vlan 7 on the 6509 switches) :

ip vrf Site1

rd 1:1

ip vrf Site2

rd 2:2

interface Vlan7

description *** to BGP router ***

ip vrf forwarding Site1

ip address 10.1.1.1 255.255.255.240

end

router bgp 400

no bgp default ipv4-unicast

bgp log-neighbor-changes

bgp router-id 2.2.2.2

bgp log-neighbor-changes

address-family ipv4 vrf Site1

network 10.1.1.0 mask 255.255.255.240

neighbor 10.1.1.2 remote-as 400

neighbor 10.1.1.2 activate

exit-address-family

exit

Thank you by advance and happy new year.

1 REPLY

Re: How to configure VRF Lite on 6509 with OSPF and BGP ?

Here is the network design

630
Views
0
Helpful
1
Replies
CreatePlease to create content