Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

how to connect two switches

I have to switches one in L3 an the other in L2. Several vlans on the network.

Should i use a trunk connection between them or a etherchannel o port channel?

what is the best way and when to use this options?

thanks in advance for your answer.

1 ACCEPTED SOLUTION

Accepted Solutions
New Member

how to connect two switches

Yes,
If you have only one interface for uplink, you need to configure it as a trunk (If you have multiple VLAN’s in your environment).

Something like this (is a minimal config):

!
interface GigabitEthernet1/0/24
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 10,20,30,40,50
switchport mode trunk
!


Samuel Petrescu

6 REPLIES
New Member

how to connect two switches

Usually I use etherchaneel configured as a trunk.
For example, if interfaces GigabitEthernet1/0/20 – GigabitEthernet1/0/24 are used to interconnect the switches:

!
interface range GigabitEthernet1/0/20 - 24
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 10,20,30,40,90,99
switchport mode trunk
channel-group 1 mode active
!


New Member

how to connect two switches

Samuel, thanks for your reply.

If there is only one interface to interconnect the switches I can't use EtherChannel or PortChannel, am I right?

The only solution is to configure that port in trunk mode, is that right?

thanks!

how to connect two switches

Hello,

1) Better to always have an etherchannel, this helps you to be redundant on Layer 1.

2) Configure all your Layer 3 VLAN on the L3 switches

3) Configure the trunk interface as suggested By Samuel on both sides

4) Configure your L2 switch in VTP client mode initially to let VTP propagate the VLAN information to your switch & then hardcode it to VTP transparent.

Thanks

Vivek

New Member

how to connect two switches

Vivek thanks for your reply.

I believe that switches 300 series doesn't have VTP. So I can't use it and should configure all switches.

thanks!

New Member

how to connect two switches

Yes,
If you have only one interface for uplink, you need to configure it as a trunk (If you have multiple VLAN’s in your environment).

Something like this (is a minimal config):

!
interface GigabitEthernet1/0/24
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 10,20,30,40,50
switchport mode trunk
!


Samuel Petrescu

New Member

how to connect two switches

Vivek and Samuel thanks for your help!

525
Views
0
Helpful
6
Replies