Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

how to control bandwidth at individual interface in cisco 4948?

Hi,

I have cisco 4948 switch and I want to control in and out bandwidth of individual interface in Cisco 4948. I try to search cisco site and I am out of luck. I tried with class-map configuration and it can only control to only one interface. Once I add another interface the configure bandwidth does not work. Here is my config

class-map match-all Client-pc

match any

class-map match-all Any-traffic

match any

!

!

policy-map 2Mb

class Any-traffic

police 2 mbps 256 kbyte conform-action transmit exceed-action drop

policy-map 1Mb

class Any-traffic

police 1 mbps 128 kbyte conform-action transmit exceed-action drop

policy-map 1Mb_client

class Client-pc

police 1.5 mbps 32 kbyte conform-action transmit exceed-action drop

policy-map 2Mb_client

class Client-pc

police 2 mbps 32 kbyte conform-action transmit exceed-action drop

!

interface GigabitEthernet1/4

description server

switchport access vlan 2

switchport mode access

duplex full

no cdp enable

spanning-tree portfast

spanning-tree bpduguard enable

service-policy input 1Mb

service-policy output 2Mb

end

1 ACCEPTED SOLUTION

Accepted Solutions

Re: how to control bandwidth at individual interface in cisco 49

Here's a working config (note this is for a 3550 though).

class-map match-all c_Outbound

match access-group 101

class-map match-all c_MarkDSCP

match access-group 102

class-map match-all c_Inbound

match ip dscp 60

!

!

policy-map p_Outbound

class c_Outbound

police 1528000 8000 exceed-action drop

policy-map p_MarkDSCP

class c_MarkDSCP

set dscp 60

policy-map p_Inbound

class c_Inbound

police 1528000 8000 exceed-action drop

!

interface FastEthernet0/11

switchport access vlan 110

switchport mode access

service-policy input p_MarkDSCP

spanning-tree portfast

!

interface FastEthernet0/12

switchport access vlan 12

switchport mode access

service-policy input p_Outbound

service-policy output p_Inbound

spanning-tree portfast

access-list 101 permit ip host 112.81.61.79 any

access-list 102 permit ip any host 112.81.61.79

7 REPLIES

Re: how to control bandwidth at individual interface in cisco 49

Here's a working config (note this is for a 3550 though).

class-map match-all c_Outbound

match access-group 101

class-map match-all c_MarkDSCP

match access-group 102

class-map match-all c_Inbound

match ip dscp 60

!

!

policy-map p_Outbound

class c_Outbound

police 1528000 8000 exceed-action drop

policy-map p_MarkDSCP

class c_MarkDSCP

set dscp 60

policy-map p_Inbound

class c_Inbound

police 1528000 8000 exceed-action drop

!

interface FastEthernet0/11

switchport access vlan 110

switchport mode access

service-policy input p_MarkDSCP

spanning-tree portfast

!

interface FastEthernet0/12

switchport access vlan 12

switchport mode access

service-policy input p_Outbound

service-policy output p_Inbound

spanning-tree portfast

access-list 101 permit ip host 112.81.61.79 any

access-list 102 permit ip any host 112.81.61.79

Community Member

Re: how to control bandwidth at individual interface in cisco 49

Thanks for the prompt reply collin. I will try with access-list and will post the result here.

Cheers

Community Member

Re: how to control bandwidth at individual interface in cisco 49

I tried with your solution. It can control, but I found that inbound and outbound bandwidth rate with police does not reflect the actual bandwidth going in and out. Is that normal?

Thanks in advance for your help.

Regards,

Re: how to control bandwidth at individual interface in cisco 49

No, it should police the traffic. I don't have a whole lot of experience on the 4948's, their queuing is probably different.

Community Member

Re: how to control bandwidth at individual interface in cisco 49

Thanks Collin, after I increase the burst rate it reflects the in and out that I control.

Regards,

Re: how to control bandwidth at individual interface in cisco 49

Great, what did you set it too (so I can change my doc)?

Community Member

Re: how to control bandwidth at individual interface in cisco 49

Hi Collin,

I raise the burst rate to 512KB. Here is my policy setting.

policy-map srv_in

class srv_in

police 4096000 bps 512000 byte conform-action transmit exceed-action drop

policy-map srv_out

class c_in

police 2048000 bps 512000 byte conform-action transmit exceed-action drop

Looks like burst rate setting speaks a lot. I tried with Passmark advance network test. If I use fixed data block size with the above setting I got the bandwidth that I set. But not exact though. Very close. If I use variable data size, the bandwidth result get higher.

Regards,

2283
Views
4
Helpful
7
Replies
CreatePlease to create content