Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

How to create subinterface on a 3560

I am trying to create subinterfaces on a 3560 switch on gi0/1 interface..Can some please help? thank you !!!

current ios is flash:c3560-advipservicesk9-mz.122-44.SE2.bin"

I want to be able to create the following:

interface GigabitEthernet0/1.20

interface GigabitEthernet0/1.30

interface GigabitEthernet0/1.40

etc etc

I have used the no switchport on the gi0/1 interface as well and it keeps rejecting the command

Switch(config)#int gigabitEthernet 0/1?
.  :  <1-2>

Switch(config)#int gigabitEthernet 0/1.

Switch(config)#int gigabitEthernet 0/1.20
                    ^
% Invalid input detected at '^' marker.

Switch(config)#

Switch#sh run
Building configuration...

Current configuration : 1330 bytes
!
version 12.2
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Switch
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
system mtu routing 1500
ip subnet-zero
ip routing
!
!
!
!
!        
!
!
!
!
spanning-tree mode pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
!
!
!
interface FastEthernet0/1
!
interface FastEthernet0/2
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!        
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface GigabitEthernet0/1
description **** Create sub interfaces ***
!
interface GigabitEthernet0/2
!
interface Vlan1
no ip address
shutdown
!        
ip classless
ip http server
ip http secure-server
!
!
!
control-plane
!
!
line con 0
line vty 5 15
!
end

Switch#

4 REPLIES
VIP Super Bronze

Re: How to create subinterface on a 3560

Hi,

Unfortunately, you can not create sub-interface on 3560s or 3750s.

HTH

Reza

New Member

Re: How to create subinterface on a 3560

Thank you for the information..appreciate the help..it seems there are options

to do so with the IOS..but it just does not take..thanks

Hall of Fame Super Blue

Re: How to create subinterface on a 3560

You don't need to create subinterfaces on a L3 switch. Instead make the port a trunk port and then create a L3 SVI for each vlan you want to route eg.

int gi0/1

switchport trunk encapsulation dot1q

switchport mode trunk

int vlan 10

ip address 192.168.5.1 255.255.255.0

int vlan 11

ip address 192.168.6.1 255.255.255.0

etc. for each vlan. So where you would create a subinterface with an IP addressc create a L3 SVI as above.

Jon

New Member

Re: How to create subinterface on a 3560

Thanks for your help..appreciate everyones feedback and quick responce..thanks again!!!

12436
Views
10
Helpful
4
Replies
CreatePlease to create content