Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Community Member

How to Create Trunk Between Cisco Catalyst-3560-CX Series Switch & HP Procurve 2510-48 Switch

Hello Everyone,

Would you'll please look into this query and help me out.

I want to configure trunk between Cisco Catalyst-3560-CX Series Switch (Layer 3 Switch) which has 12 Gigabit ethernet ports & HP Procurve 2510-48 Switch (Layer 2 Switch) which has 48 Fast ethernet ports. Both are manageable switch. However cisco is Gigabit ethernet and HP is Fast ethernet. I have 6 VLANs on cisco switch. I want to create trunk between Cisco and HP switch. I dont want to create VLANs on HP switch. I just want to trunk between them without creating VLANs on HP switch. How to verify if trunk is working fine after configuration.

Please let me know what to configure on both the switches. Please share the configurations on both the switches and i"ll let you'll know if it works or not.

10 REPLIES
VIP Purple

Hi

Hi

Can give you the Cisco side someone who knows HP can answer that bit ,although I did see this in Google you could try

https://community.spiceworks.com/topic/153622-how-to-configure-trunk-port-between-hp-and-cisco-switches

Cisco

The allowed line is optional to lock down your vlans


interface GigabitEthernet0/47
 description xxxxxxxxxx
 switchport trunk allowed vlan x,x,x,x
 switchport mode trunk

To check if trunk is working use

show in trunk

Community Member

I made the following

I made the following configurations on Cisco Switch and HP Switch

CISCO SWITCH

Switch-1>en
Switch-1#config t
Enter configuration commands, one per line. End with CNTL/Z.
Switch-1(config)#int g0/14
Switch-1(config-if)#switchport trunk native vlan 1
Switch-1(config-if)#switchport mode trunk
Switch-1(config-if)#switchport nonegotiate
Switch-1(config-if)#no shut
Switch-1(config)# no cdp enable

However this command "Switch-1(config-if)#switchport trunk encapsulation dot1q" is not working/invalid on this switch. As when i see trunk info by using "sh int trunk" i get below details. So encapsulation dot1q is enabled by default when you enable trunk.

Switch-1#sh int trunk

Port                           Mode    Encapsulation    Status          Native vlan
Gi0/14                         on           802.1q           trunking             1

Port                           Vlans allowed on trunk
Gi0/14                       1-4094

Port                           Vlans allowed and active in management domain
Gi0/14                       1,100-105

Port                            Vlans in spanning tree forwarding state and not pruned
Gi0/14                        1,100-105

HP SWITCH

ProCurve Switch 2510-48# config t
ProCurve Switch 2510-48(config)# int 14
ProCurve Switch 2510-48(eth-14)# enable
ProCurve Switch 2510-48(eth-14)# trunk 14 trk1
ProCurve Switch 2510-48(eth-14)# exit
ProCurve Switch 2510-48(config)# vlan 100
ProCurve Switch 2510-48(vlan-100)# tagged trk1
ProCurve Switch 2510-48(vlan-100)# exit
ProCurve Switch 2510-48(config)# vlan 101
ProCurve Switch 2510-48(vlan-101)# tagged trk1
ProCurve Switch 2510-48(vlan-101)# exit
ProCurve Switch 2510-48(config)# vlan 102
ProCurve Switch 2510-48(vlan-102)# tagged trk1
ProCurve Switch 2510-48(vlan-102)# exit
ProCurve Switch 2510-48(config)# vlan 103
ProCurve Switch 2510-48(vlan-103)# tagged trk1
ProCurve Switch 2510-48(vlan-103)# exit
ProCurve Switch 2510-48(config)# vlan 104
ProCurve Switch 2510-48(vlan-104)# tagged trk1
ProCurve Switch 2510-48(vlan-104)# exit
ProCurve Switch 2510-48(config)# vlan 105
ProCurve Switch 2510-48(vlan-105)# tagged trk1
ProCurve Switch 2510-48(vlan-105)# exit
ProCurve Switch 2510-48(config)# no cdp enable all


When i see trunk info, i get the following

ProCurve Switch 2510-48# sh trunk

Load Balancing

Port | Name              Type |           Group         Type
---- + -------------------------------- --------- + ----- -----
14 |                   10/100TX |            Trk1           Trunk

When i see VLAN info, i get the following info

ProCurve Switch 2510-48# sh vlan

Status and Counters - VLAN Information

Maximum VLANs to support : 8
Primary VLAN : DEFAULT_VLAN
Management VLAN :

VLAN ID       Name                            Status     Voice
------- --------------------                      ------------     -----
1             DEFAULT_VLAN               Port-based No
100           VLAN100                         Port-based No
101           VLAN101                         Port-based No
102           VLAN102                         Port-based No
103           VLAN103                         Port-based No
104           VLAN104                         Port-based No
105           VLAN105                         Port-based No

VIP Purple

cisco side is fine , trunk is

cisco side is fine , trunk is up and operational and allowing 6 vlans , through

you only need the encapsulation command on certain platforms that's why I provided it just in case

Community Member

Encapsulation dot1q is

Encapsulation dot1q is enabled by default on cisco switch when trunk port is enabled.

With the given above configuration i can reach to gateway only on cisco switch side not beyond the HP switch, and from HP switch side i cannot even ping Gateway.

What can i do now?

VIP Purple

have you setup default

have you setup default gateway and vlans etc on the HP switch

Community Member

Nope. I havent setup default

Nope. I havent setup default Gateway on HP switch but i havent even configured default gateway on cisco switch but it can still ping to gateway from host but not to host which is connected to HP switch. I dont want to create VLANs on HP switch as it was created on cisco switch.

VIP Purple

well your vlans are there

well your vlans are there they must have added automatically as the extract you posted shows vlans from the HP side

every layer 2 switch should have a default gateway for return traffic

if its acting layer 3 you set a default route instead

Community Member

I am getting following output

I am getting following output on cisco switche, what can i do now so that the trunk will start working

 

Switch-1#sh ip int brief

Interface              IP-Address             OK? Method Status                Protocol

Vlan1                      10.10.0.1             YES NVRAM  up                    up

Vlan100                    10.10.1.1           YES NVRAM  up                    up

Vlan101                    10.10.2.1           YES NVRAM  up                    up

Vlan102                    10.10.3.1           YES NVRAM  up                    up

Vlan103                    10.10.4.1           YES NVRAM  up                    up

Vlan104                    10.10.5.1           YES NVRAM  up                    up

Vlan105                    10.10.6.1           YES NVRAM  up                    up

GigabitEthernet0/1    unassigned       YES unset  down                  down

GigabitEthernet0/2    unassigned       YES unset  down                  down

GigabitEthernet0/3    unassigned       YES unset  down                  down

GigabitEthernet0/4    unassigned       YES unset  down                  down

GigabitEthernet0/5    unassigned       YES unset  down                  down

GigabitEthernet0/6    unassigned       YES unset  down                  down

GigabitEthernet0/7    unassigned       YES unset  up                       up

GigabitEthernet0/8    unassigned       YES unset  down                  down

GigabitEthernet0/9    unassigned       YES unset  down                  down

GigabitEthernet0/10    unassigned     YES unset  down                 down

GigabitEthernet0/11    unassigned     YES unset  down                 down

GigabitEthernet0/12    unassigned     YES unset  down                 down

GigabitEthernet0/13    unassigned     YES unset  down                 down

GigabitEthernet0/14    unassigned     YES unset  up                      up

GigabitEthernet0/15    unassigned     YES unset  down                  down

GigabitEthernet0/16    unassigned     YES unset  down                  down

 

 

Switch-1#show int gi0/14

GigabitEthernet0/14 is up, line protocol is up (connected)

  Hardware is Gigabit Ethernet, address is 0056.2bc9.2a0e (bia 0056.2bc9.2a0e)

  MTU 1500 bytes, BW 100000 Kbit/sec, DLY 100 usec,

    reliability 255/255, txload 1/255, rxload 1/255

  Encapsulation ARPA, loopback not set

  Keepalive not set

  Full-duplex, 100Mb/s, media type is 10/100/1000BaseTX

  input flow-control is off, output flow-control is unsupported

  ARP type: ARPA, ARP Timeout 04:00:00

  Last input never, output 00:00:00, output hang never

  Last clearing of "show interface" counters never

  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

  Queueing strategy: fifo

  Output queue: 0/40 (size/max)

  5 minute input rate 0 bits/sec, 0 packets/sec

  5 minute output rate 2000 bits/sec, 3 packets/sec

    93 packets input, 15974 bytes, 0 no buffer

    Received 93 broadcasts (84 multicasts)

    0 runts, 0 giants, 0 throttles

    0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored

    0 watchdog, 84 multicast, 0 pause input

    0 input packets with dribble condition detected

    1494 packets output, 122772 bytes, 0 underruns

    0 output errors, 0 collisions, 1 interface resets

    0 unknown protocol drops

    0 babbles, 0 late collision, 0 deferred

    0 lost carrier, 0 no carrier, 0 pause output

    0 output buffer failures, 0 output buffers swapped out

Community Member

I made the following changes

I made the following changes to the configuration on cisco switch and obtained this outputs -

But still no luck, as the trunk is not working

Switch-1(config)#int g0/14
Switch-1(config-if)#switchport trunk native vlan 1
Switch-1(config-if)#switchport mode trunk
Switch-1(config-if)#switchport nonegotiate
Switch-1(config-if)#speed auto
Switch-1(config-if)#duplex full
Switch-1(config-if)#flowcontrol receive on
Switch-1(config-if)#no cdp enable
Switch-1(config-if)#channel-group 1 mode on
Switch-1(config-if)#channel-group 1 mode active
Switch-1(config-if)#exit
---------------------------------------------------------------------------------------------------------------

Switch-1#sh vlan brief

VLAN Name Status Ports
---- -------------------------------- --------- -------------------------------
1 default active Gi0/1, Gi0/2, Gi0/3, Gi0/4
Gi0/11, Gi0/12, Gi0/13, Gi0/14
Gi0/15, Gi0/16
100 Senior Mgmt active Gi0/5
101 ConferenceRoom active Gi0/6
102 MICM Users Admin active Gi0/7
103 Classrooms active Gi0/8
104 ETTI College active Gi0/9
105 ComputerLab active Gi0/10
1002 fddi-default act/unsup
1003 trcrf-default act/unsup
1004 fddinet-default act/unsup
1005 trbrf-default act/unsup

---------------------------------------------------------------------------------------------------------------
Switch-1#show log

Syslog logging: enabled (0 messages dropped, 1 messages rate-limited, 0 flushes, 0 overruns, xml disabled, filtering disabled)

No Active Message Discriminator.



No Inactive Message Discriminator.


Console logging: level debugging, 60 messages logged, xml disabled,
filtering disabled
Monitor logging: level debugging, 0 messages logged, xml disabled,
filtering disabled
Buffer logging: level debugging, 60 messages logged, xml disabled,
filtering disabled
Exception Logging: size (4096 bytes)
Count and timestamp logging messages: disabled
File logging: disabled
Persistent logging: disabled

No active filter modules.

Trap logging: level informational, 62 message lines logged
Logging Source-Interface: VRF Name:

Log Buffer (4096 bytes):
17 10:46:49.681: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/14, changed state to up
Feb 17 10:47:18.685: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan1, changed state to up
Feb 17 10:47:18.685: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan100, changed state to up
Feb 17 10:47:18.688: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan101, changed state to up
Feb 17 10:47:18.709: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan102, changed state to up
Feb 17 10:47:18.709: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan103, changed state to up
Feb 17 10:47:18.709: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan104, changed state to up
Feb 17 10:47:18.713: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan105, changed state to up
Feb 17 10:48:15.364: %SYS-5-CONFIG_I: Configured from console by console
Feb 17 10:50:26.387: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan1, changed state to down
Feb 17 10:50:26.390: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan100, changed state to down
Feb 17 10:50:26.390: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan101, changed state to down
Feb 17 10:50:26.390: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan102, changed state to down
Feb 17 10:50:26.394: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan103, changed state to down
Feb 17 10:50:26.394: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan104, changed state to down
Feb 17 10:50:26.394: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan105, changed state to down
Feb 17 10:50:27.372: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/14, changed state to down
Feb 17 10:50:29.389: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/14, changed state to up
Feb 17 10:50:58.033: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan1, changed state to up
Feb 17 10:50:58.036: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan100, changed state to up
Feb 17 10:50:58.036: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan101, changed state to up
Feb 17 10:50:58.036: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan102, changed state to up
Feb 17 10:50:58.040: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan103, changed state to up
Feb 17 10:50:58.040: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan104, changed state to up
Feb 17 10:50:58.043: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan105, changed state to up
Feb 17 10:51:39.095: %SYS-5-CONFIG_I: Configured from console by console
Feb 17 10:52:43.876: %EC-5-CANNOT_BUNDLE2: Gi0/14 is not compatible with Po1 and will be suspended (flow control receive of Gi0/14 is on, Po1 is off)
Feb 17 10:52:43.887: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan1, changed state to down
Feb 17 10:52:43.887: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan100, changed state to down
Feb 17 10:52:43.890: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan101, changed state to down
Feb 17 10:52:43.890: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan102, changed state to down
Feb 17 10:52:43.890: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan103, changed state to down
Feb 17 10:52:43.890: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan104, changed state to down
Feb 17 10:52:43.894: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan105, changed state to down
Feb 17 10:52:44.869: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/14, changed state to down
Feb 17 10:53:33.292: %EC-5-CANNOT_BUNDLE2: Gi0/14 is not compatible with Po1 and will be suspended (flow control receive of Gi0/14 is on, Po1 is off)
Feb 17 10:54:07.717: %EC-5-CANNOT_BUNDLE2: Gi0/14 is not compatible with Po1 and will be suspended (flow control receive of Gi0/14 is on, Po1 is off)
Feb 17 10:54:09.391: %EC-5-CANNOT_BUNDLE2: Gi0/14 is not compatible with Po1 and will be suspended (flow control receive of Gi0/14 is on, Po1 is off)
Feb 17 10:54:37.517: %SYS-5-CONFIG_I: Configured from console by console
Feb 17 10:56:39.281: %SYS-5-CONFIG_I: Configured from console by console
Switch-1#

Cisco Employee

For cisco 3560 please follow

For cisco 3560 please follow this Guide:

http://www.cisco.com/c/en/us/td/docs/switches/lan/catalyst3560/software/release/12-2_52_se/configuration/guide/3560scg/swpvlan.html

For HP please refer to the following links:

https://community.hpe.com/t5/Switches-Hubs-and-Modems/Connecting-HP-Procurve-to-Cisco-3560/td-p/4300209

http://whp-hou4.cold.extweb.hp.com/pub/networking/software/2510-MgmtCfg-July2007-59914761.pdf

656
Views
0
Helpful
10
Replies
CreatePlease to create content