Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

How to join a domain on different subnet???

Basically I have a server that is connected to a router and that router is also connected to a workstation. Server is on 192.168.2.0/24 and workstation is on 192.168.10.0/24. On the router I've configure as follow:

Router A:

interface fa0/0 (connected to server)

ip address 192.168.2.1 255.255.255.0

no shut

interface fa1/0 (connected to workstation)

ip address 192.168.10.1 255.255.255.0

no shut

router ospf 1

network 192.168.2.0 0.0.0.255 area 0

network 192.168.10.0 0.0.0.255 area 0

The server and the workstation can ping each other, but I can't use the workstation to join the server domain. When I use another workstation that is on the same subnet as the server, I'm able to join the same domain as the server. What else do I need to configure for my workstation and server to join the same domain?

7 REPLIES

Re: How to join a domain on different subnet???

what dns servers do you use on workstation? you have to use dns servers that hosts zone for your active directory (perhaps the ad server itself?) or server that is able to resolve dns name of you ad domain

then try to join a domain by dns name: example.local ( and not the netbios name EXAMPLE)

if that wouldn't help please send the error message and double check the traffic is not filtered when passing from one subnet to another

New Member

Re: How to join a domain on different subnet???

My server 2008 is running dns:

-DNS Manager

-Forward Lookup Zones

     -data.server.com

-Reverse Lookup Zones

     -2.168.192.in-addr.arpa

How do I configure the DNS so that the workstation will recognize it?

When I try to join the domain on my workstation it pop up as " An Active Directory Domain Controller (AD DC) for the domain "DATA.SERVER.COM" could not be contacted".

p.s. server and workstation can still ping each other.

Cisco Employee

Re: How to join a domain on different subnet???

Hi

What DNS server is configured now on your workstation (go to CMD.EXE and run ipconfig /all)? Can you change that to same DNS ip which is used by server (make sure that workstation can ping that first). Once you have the new DNS server set up then you can ty again.

Nik,

New Member

Re: How to join a domain on different subnet???

On my workstation I put dns: 192.168.2.2 same as the server that I'm trying to join. How can you configure DNS so that I can join the same domain on different subnet? Can you give me an example of how to set up DNS so that I can join domain? Can you configure DNS and join a domain in a different subnet so that I could see the configuration that you did? Thanks

Re: How to join a domain on different subnet???

You try configure the command ip forward-protocol udp domain on your router to get your problem resolved.

Thanks

Vivek

Bronze

How to join a domain on different subnet???

I think that yuo should create sites on the server and add the site to the domain. Usualy a site is a subnet in MS server world.

Also to join a domain, the computer account must be created in AD before you join to domain.

Look in AD in Computer OU if you see an account for your computer, if not create one and try to join the computer to the domain.

Hope this helps

Eugen

How to join a domain on different subnet???

You shouldn't create additional site to achieve this goal.

The computer account is created when computer is joining the domain - you don't have to create it in advance.

Step by step:

- verify you have entered server IP address on computer network connections-connection name-IPv4 configuration-DNS IP address

- on computer verify (ping the domain name) that you can resolve domain name (by DNS domain name, not netbios domain name);

Can you resolve domain name from computer?

You can find the DNS domain name in Active Directory Users and Computers snap in. Some examples of the DNS domain names: example.local, example.int, example.com

12121
Views
0
Helpful
7
Replies
CreatePlease to create content