Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

how to make condition natting if an icmp ping failed ??

hi ,

assume i have pc with ip 1.1.1.1

note that pc can reach internet with ip 1.1.1.1

connected with  router as below :

pc----------------router-------------------switch----------------internet

on router , i want to set condition ,

if ping  on 8.8.8.8 failed  from router , i want  router to nat the ip 1.1.1.1 to ip 2.2.2.2

how to do that ??????

regards

9 REPLIES
VIP Super Bronze

how to make condition natting if an icmp ping failed ??

Hi,

1.1.1.1 and 2.2.2.2 are both public IP segments.  Usually NAT is done for private IP segments. 

Here is good doc to read on conditional NAT:

http://www.cisco.com/en/US/docs/security/asa/asa82/configuration/guide/nat_static.html#wp1074755

HTT

New Member

how to make condition natting if an icmp ping failed ??

hi , im just getting ips 1.1.1.1 2.2.2.2 as an exapmles ,

i just ask about conditional nat ,

thanks alot , i will read it and   discuss with u

regards

New Member

how to make condition natting if an icmp ping failed ??

im looking about creating ip sla  and  define  icmp echo time out , and when this condition occurs i want to perform the natting ,

i searched but ddint find any about my goal !

regards

Re: how to make condition natting if an icmp ping failed ??

Hi.
Is the out interface the same even if ping would fail?
Let me know

Regards
Carlo

Sent from Cisco Technical Support iPhone App

Please rate all helpful posts "The more you help the more you learn"
New Member

Re: how to make condition natting if an icmp ping failed ??

hi ,

to make more explanation ,

i have two isp gateways using bgp protocol ,

here is simple topology

lan network=======routerx========switch=======gateway router1==========isp1

                                                                                                 |

                                                                                                 |

                                                                                                 |

                                                                                              isp2

now on lan network i have assume i have  two subnets

subnet 1  advertised to isp1 assume 1.1.1.0/24

subnet 2  advertised to sip2      2.2.2.0/24

note that on

gateway router1

im performing  route map so that subnet 1  go to isp1  and subnet 2  go to isp2

===============================================

now  lets go to my issue ,

assume that isp1 failed , or  " ping from src ip of 1.1.1.1 to 8.8.8.8" failed !!!!

i want some hosts of subnet 1.1.1.0/24 to  go internet from isp2 ,

this is my clear issue

i mean that off my work will be on routerx

how connect  nating with ip sla ??? 

regards

Re: how to make condition natting if an icmp ping failed ??

Hi.

You can try to work with next-hop availability based on ip sla.

Please give a look to this doc

https://supportforums.cisco.com/docs/DOC-8313

HTH

Regards.

Carlo

Please rate all helpful posts

"The more you help the more you learn"

Please rate all helpful posts "The more you help the more you learn"
New Member

Re: how to make condition natting if an icmp ping failed ??

hi  ,

i know about  route map  and its integration with next hop availability but i need natting in this case .

each subnet is only advertied to  its isp ,

regards

Re: how to make condition natting if an icmp ping failed ??

Hi.
If you read that doc you can apply nat based on next hop reachability even using ip sla.
If the first route map does not satisfy the condition , because of track object down, you can apply nat based on second route map configuring
ip nat pool ISP-B 2.2.2.2 2.2.2.2 netmask 255.255.255.252

ip nat inside source route-map ispb pool ISP-B overload.

HTH
Regards

Carlo

Sent from Cisco Technical Support iPhone App

Please rate all helpful posts "The more you help the more you learn"
New Member

Re: how to make condition natting if an icmp ping failed ??

hi all ,

plz pay attention to my config and tell me why it always  doing nat ??!!!

i mean it always doing nat  whatever the track was up or down ,

here is my config below :

lan====>ip nat inside=routerx==>ip nat outside======switch=======gateway router1==========isp1

                                                                                                 |

                                                                                                 |

                                                                                                 |

                                                                                              isp2

ip nat pool tod x.x.111.1 x.x.111.30 netmask 255.255.255.224

ip nat inside source route-map natprtg pool tod

ip access-list extended natprtg

permit ip host zzzzz any

======================================================

Gateway7600#sh route-map

route-map natprtg, permit, sequence 10

  Match clauses:

    ip address (access-lists): natprtg

  Set clauses:

    ip next-hop verify-availability 172.30.40.1 50 track 5  [up]

  Policy routing matches: 86750 packets, 11236147 bytes

========================================================

sh ip nat translations===> natting  found

now when track is down :

Gateway7600#sh route-map

route-map natprtg, permit, sequence 10

  Match clauses:

    ip address (access-lists): natprtg

  Set clauses:

    ip next-hop verify-availability 172.30.40.1 50 track 5  [down]

  Policy routing matches: 86750 packets, 11236147 bytes

when i type show ip nat trans  natting still found !!!!???????/

why ??????/

272
Views
0
Helpful
9
Replies