Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

How to prioritize traffic?

We need to give TCP 3389 & 3399 priority over all other traffic between a Cisco 1941 and 2951.

What is needed to do this?

6 REPLIES

How to prioritize traffic?

You'll need to configure qos on both of your routers. Apply the policy outbound on both interfaces.

access-list 101 permit tcp any any eq 3389

access-list 101 permit tcp any any eq 3399

class-map match-any Policy

match access-group 101

policy-map Policy

class Policy

priority percent 10

int fa0/0 (wan interface)

service-policy output Policy

Do this on both sides. The problem with giving priority is 2 fold. On one hand, you're guaranteed a minimum of 10 percent of your total reservable bandwidth. Total reservable is 75% of your link speed. If you have a T1, your link speed is 1544 with 1158k usable. Ten percent of that would be 115k that you would be guaranteed for this traffic, BUT it's also your maximum in times of congestion because LLQ also polices the traffic at that guaranteed rate to mitigate starvation of other queues.

Another way that you could do this is to give a bandwidth guarantee and then shape the traffic in the same queue. This would give the same effect, but you would have a little more control as to how high of a ceiling to give:

policy-map Policy

class Policy

bandwidth percent 10 ( minus any existing priority queues; if none exist, then you're back at 115k)

shape average 500000 (shape at 500k)

Above would guarantee 115k and cap it at 500k.

HTH,

John

HTH, John *** Please rate all useful posts ***
New Member

How to prioritize traffic?

If possible, we would like TCP 3389 & 3399 traffic to have priority over all other traffic - and use up to 50% of the bandwidth.  But we would also like the other traffic to be able to use 100% of the bandwidth if no TCP 3389 & 3399 traffic exists.

Will this do what we need it to do, if applied to the outside interface of both Routers?

class-map match-all PRIOR1

match access-group name PRIOR

policy-map PRIOR2

class PRIOR1

priority percent 50

interface GigabitEthernet0/1

service-policy output PRIOR2

ip access-list extended PRIOR

permit tcp any eq 3389 any

permit tcp any any eq 3389

permit tcp any any eq 3399

permit tcp any eq 3399 any

Gold

How to prioritize traffic?

Hey CTS,

it would do what u said there, but 50% for priority is somewhat a very high value, keep in mind that priority traffic not only uses up to 50% of the bandwidth, but its also gets time sensitive and low latency service, which may have great negative impact on the other trfic flows.

depends on ur equipment, you may need to add the class-default under the policy-map:

policy-map PRIOR2

class PRIOR1

  priority percent 50

class class-default

  fair-queue

  bandwidth remaining percent 100

HTH,

Soroush.

Hope it Helps!

Soroush.
Silver

How to prioritize traffic?

Is this traffic going over the WAN link? if so you will need to use some markings along with the priority statement and your service provider should honour those markings.

policy-map PRIOR2

class PRIOR1

  priority percent 50

  set ip dscp af41

class class-default

  fair-queue

  bandwidth remaining percent 100

Siddhartha
New Member

How to prioritize traffic?

Thanks guys.  This is for a dedicated point-to-point connection with 10Mbps.

Just to clarify - does this need to be applied to the inside & outside interfaces - or just the outside?

How to prioritize traffic?

Hi CTS,

on the outside only in this case. however, generally your need is telling you in which direction you want to apply it.

HTH

Alessio

453
Views
0
Helpful
6
Replies
CreatePlease to create content