Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

How to separate 2 networks on cisco 1721 with vlans on wic

Hello!

I have 1721 with wic-4-esw and onboard ethernet. Is it possible to have 2 vlans,

one that is configured on 4 ports of wic-4-esw and other on the onboard fastethernet. Is it possible to route these vlans with eigrp without trunk port.

The idea is that i configure interface vlan 1 with ip address 192.168.2.1

Than assigne fastehernet range 1-4 to vlan 1.

Then I configure int vlan 2 with IP 192.168.3.1 and assigned Fastetheret 0 to vlan 2.

If I configure eigrp with 192.168.0.0 will these networks be connected

11 REPLIES
Cisco Employee

Re: How to separate 2 networks on cisco 1721 with vlans on wic

Hi Fisko,

I believe fastether0 interface is a layer 3 interface on router itself so its not possible to assign it to some vlan.

Rest you can create "interface vlan 1" on your esw card and assign it an ip address 192.168.2.1/24 and then assign all 4 ports to vlan 1.

You can configure fast0 interface also with an ip address 192.168.3.1/24.

Check the sh ip route and you should see them as directly connected route on your router. If that does not work then reply back and I will update you with a workaround.

HTH

Ankur

Re: How to separate 2 networks on cisco 1721 with vlans on wic

yes, it is possible to route between two VLAN without any trunk port. In this case you need to have 2 links between router and switch. One link will carry one VLAn and second link will carry another VLAN.

Config will look like this:

Router#configure terminal

Router(config) interface fa0

Router(config-if) desc *** Connecting SW1 fa0/1 ***

Router(config-if) ip address 192.168.2.1 255.255.255.0

Router(config) interface fa1

Router(config-if) desc *** Connecting SW1 fa0/2 ***

Router(config-if) ip address 192.168.3.1 255.255.255.0

SW1# config t

SW1(config) int fa0/1

SW1(config-if)desc *** Connected to Router0fa1 ***

SW1(config-if) switchport mode access

SW1(config-if) switchposrt access vlan 1

SW1(config) int fa0/2

SW1(config-if)desc *** Connected to Router fa1 ***

SW1(config-if) switchport mode access

SW1(config-if) switchposrt access vlan 2

Router(config)#ip routing

Router(config)#router eigrp

Router(config-router)#network 192.168.0.0

Router(config-router)#no auto-summary

once done, check status of all interfaces and also check routing table to see if routes are there or not.

hope it helps ..... rate if it does ...

Cisco Employee

Re: How to separate 2 networks on cisco 1721 with vlans on wic

Hi Sourabh,

WHY do you need to have a routing protocol when the 2 interfaces are directly connected on router?

I believe the original poster wants to make sure if he can communicate between 2 networks using eigrp which is not required if he has the 2 networks defined on same router.

Regards,

Ankur

Re: How to separate 2 networks on cisco 1721 with vlans on wic

Hi Ankur,

you are right that we don't need routing protocol to run as both will be directly connected networks. I thought that poster want to know that how the config will look like if he want to run EIGRP.

sorry for the confusion.

New Member

Re: How to separate 2 networks on cisco 1721 with vlans on wic

Well You are right... directed connected network should see each other without eigrp (i need eigrp to connect these networks to other side over WAN WIC) but my problem is when i configure VLAN 1 interface and give the ip to vlan interface and assigne 4 port to vlan....when i configure other ip on fastethernet 0 i get line up protocol down i can not see that network on fastethernet0.

Re: How to separate 2 networks on cisco 1721 with vlans on wic

you can't create vlan interfaces on router. you need to assign IPs to fast ethernet interface of router.

can you post the config you have put on the switch/router?

New Member

Re: How to separate 2 networks on cisco 1721 with vlans on wic

interface FastEthernet0

ip address 192.168.1.1 255.255.255.0

interface FastEthernet1

no cdp enable

switchport access vlan1

!

interface FastEthernet2

no cdp enable

switchport access vlan1

!

interface FastEthernet3

no cdp enable

switchport access vlan1

!

interface FastEthernet4

no cdp enable

switchport access vlan1

interface Vlan1

ip address 192.168.2.1 255.255.255.0

eigrp 20

network 192.168.0.0

Re: How to separate 2 networks on cisco 1721 with vlans on wic

instead of creating vlan1 interface, please assign IP to fastethernet interface.

interface FastEthernet2

no cdp enable

ip address 192.168.2.1 255.255.255.0

now this router fa0 and fa1 will be connected to layer 2 switch and you will create layer 2 vlans on this switch ... correct me if I am wrong.

you need to assign vlan membership to the layer 2 switchports from which PCs will be connected.

Cisco Employee

Re: How to separate 2 networks on cisco 1721 with vlans on wic

Hi Fisko,

Is anything connected on your fastethernet 0 interface. You need to connect it to some switch or what you can do is take a cable and connect one port on your esw to your fasteherhernet 0 interface and assign that port on esw to vlan 2.

HTH

Ankur

New Member

Re: How to separate 2 networks on cisco 1721 with vlans on wic

Yes, PC is connected to fasteth0.....

I dont have a switch that's why I use 4esw wic.

Re: How to separate 2 networks on cisco 1721 with vlans on wic

you have connected PC to fa0 and line protocol is down that's why you can't see the route in that interface.

can you check connectivity between PC and router fa0, make sure you are using correct cable. Once your fa0 interface is UP, then you will be able to see the route.

hope it helps ... rate if it does ...

420
Views
0
Helpful
11
Replies