Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

How to set one to one NAT ?

Hello,

Please see attached screenshot first.

Internal have 2 servers for public users, how to map one to one NAT to those internal IP on Router 5 fa0/1 ? assume public IP has 210.0.214.1 - 3.

I tried to create subinterface on Router 5 fa0/1, assign encapsulation dot1Q 1, assign 210.0.214.2 on fa0/1.1, it has error message overlap on fa0/0 internface...

Thanks !

5 REPLIES
Bronze

Re: How to set one to one NAT ?

Hi Wilson,

You need to enable interfaces for nat first (ip nat inside(default gateway for servers), ip nat outside)

Second you need to add a secondary ip address to interface that connects to other router (ip address 210.0.214.3 255.255.255.0 secondary)

Third, you need to create a static mapping from each server IP to the default gateway (ip nat inside source static 192.168.0.2 192.168.0.1)

And router should take care of the rest.

I hope this helps

Eugen

New Member

Re: How to set one to one NAT ?

Hi,

Do you mean enable sub-interface for 210.0.214.3 ?

I known nat need define inside and outside.

Bronze

How to set one to one NAT ?

You dont need subinterfaces, on the physical interface you can assign a primary address 210.0.214.1 and a secondary 210.0.214.3 for example.

Another way is to create a pool of addresses from 210.0.214.0 subnet and an ACL to permit both servers to use the pool for translation.

Check this link

http://www.cisco.com/en/US/tech/tk648/tk361/technologies_q_and_a_item09186a00800e523b.shtml

Eugen

New Member

Re: How to set one to one NAT ?

Packet Tracer do not support secondary ip address ... I tried real 2600 router can assign secondary ip address.

Thanks !!

How to set one to one NAT ?

Hi Wilson,

Pls find below suggested config...as per your 03.jpg

configure for R5

Router#configure terminal

R5(config)#interface fastethernet 0/0

R5(config-if)#ip address 192.168.0.1 255.255.255.0

R5(config-if)#no shutdown

R5(config-if)#ip nat inside

R5(config-if)#exit

R5(config)#interface fastethernet 0/1

R5(config-if)#ip address 210.0.214.1 255.255.255.0

R5(config-if)#no shutdown

R5(config-if)#ip nat outside

R5(config-if)#exit

R5(config)#ip route 210.0.214.0 255.255.255.0 192.168.0.0

R5(config)#ip nat inside source static 192.168.0.3 210.0.214.3

configure for R6

R6(config)#interface fastethernet 0/0

R6(config-if)#ip address 210.0.214.2 255.255.255.0

R6(config-if)#clock rate 64000

R6(config-if)#bandwidth 64

R6(config-if)#no shutdown

R6(config-if)#exit

R6(config)#ip route 210.0.214.0 255.255.255.0 210.0.214.1

R6(config)#

Regards,

KodandaRao - Please rate helpful posts

439
Views
5
Helpful
5
Replies
CreatePlease to create content