Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

How to setup Redundancy

                   How to setup redundancy on a 2800 series Router so that whenever it fails it will be routed through the MPLS router

5 REPLIES
Gold

How to setup Redundancy

Hi there,

your question sounds kinda incompelete to me, but as far as i understood. you want to have ur MPLS network as a back up route.

simply what you gotta do is to manipulate your link's costs in a way to make your MPLS net second prefered route, then in case of primary link failure, devices roll back to MPLS.

for example if your running OSPF on your net, insert the ip ospf cost on your active interfaces in the order you please.

plz Rate if it helped.

Soroush

Hope it Helps, Soroush.
New Member

How to setup Redundancy

Yes,  In case the Router fails, Could I use our MPLS as back up router

Curently EIGRP is configured .

router eigrp 1

redistribute static

network 10.1.1.0 0.0.0.3

network 10.10.0.0 0.0.255.255

network 10.100.0.8 0.0.0.3

no auto-summary

!

ip route 0.0.0.0 0.0.0.0 67.*.*.*

How do I configure the backup route

New Member

How to setup Redundancy

DISASTER RECOVERY:

Yes, In case the Router fails, Could I use our MPLS as back up router (for Disaster Recovery)

Curently EIGRP is configured .

router eigrp 1

redistribute static

network 10.1.1.0 0.0.0.3

network 10.10.0.0 0.0.255.255

network 10.100.0.8 0.0.0.3

no auto-summary

!

ip route 0.0.0.0 0.0.0.0 67.*.*.*

How do I configure the backup route

Gold

How to setup Redundancy

Look,

does this >>  ip route 0.0.0.0 0.0.0.0 67.****  << points to your current gateway?and in case this gateway fails u want to point to other MPLS router? in this scenario you should reconfig your command with a distance at its end.

then you should associate a tracking object to the first one to track the availablity of the gateway, so if it becomes unavailable, it'll be removed from the network and other one will be installed. here u go:

ip sla 1

  icmp-echo 67.*.*.*

  time out 2000

  frequency 5

ip sla schedule 1 life forever start now

track 1 rtr 1

ip route 0.0.0.0 0.0.0.0 67.*.*.*  10 track 1 ............(10 is a AD by choice)

ip route 0.0.0.0 0.0.0.0 *.*.*.*  20  ........................(this points to your MPLS router with AD 20)

this is called reliable static routing, ip route with the lower metric is active and when it becomes unavailable the one with the higher metric does the job. of course if your r using static routes to point out.

the IP SLA command may varey fin different ios versions. look it up online.

plz Rate if it helped.

Soroush

Hope it Helps, Soroush.
New Member

How to setup Redundancy

Thank you for your help. I had a chance only now to test it

I have configured the interface for MPLS internet as follows

interface FastEthernet0/3/0.1
encapsulation dot1Q 10
ip address 65.242.*.* 255.255.255.240
ip access-group mpls-internet-in in
ip verify unicast reverse-path
no ip redirects
no ip proxy-arp
ip flow ingress
ip nat outside
ip inspect DEFAULT100 out
ip virtual-reassembly
no cdp enable


ip access-list extended mpls-internet-in
permit icmp any host 65.242.*.*
permit tcp any any eq 22

I am able to Ping the MPLS internet Gateway from the Router but not from my Desktop.

Something is blocking on the Router. Can you please help me to solve it. Thank you

304
Views
0
Helpful
5
Replies