Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

How to tftp an IOS into switch via laptop

Hi there,

I am just wondering if someone can assist me on getting an IOS copied to a switch that has old IOS.

I have new image inside my laptop.

Thanks in advance for the assistance.

rgrds

siraj

2 ACCEPTED SOLUTIONS

Accepted Solutions
Bronze

Re: How to tftp an IOS into switch via laptop

Download a TFTP server and install it.

TFTPD32 is a good one.

Copy the image into the TFTP's root directory.

Put an IP on your Laptop's ethernet NIC.

Ex: 10.0.0.2 255.255.255.0

Turn on the TFTP server application.

Terminal into the switch and type the following commands:

en

conf t

interface vlan 1

ip address 10.0.0.1 255.255.255.0

no shut

interface fa0/1 (this may change depending on model of switch)

switchport mode access

switchport access vlan 1

spanning-tree portfast

exit

exit

Plug in your laptop to the port we just configured.

Ping 10.0.0.1 from your laptop. It should work.

Then erase the flash:

Switch#erase flash:

Copy image if the image ends in .bin

Switch#copy tftp://10.0.0.2/nameofimage.bin flash:

Copy image if the image ends in .tar

Switch#archive download-sw tftp://10.0.0.2/nameofimage.tar flash:

Re: How to tftp an IOS into switch via laptop

One ethernet connection from your laptop to the switch. THe other connection is from the laptop serial (COM) port to the console of the switch. It's a special cable, usually flat and light blue or black in color.

6 REPLIES
Bronze

Re: How to tftp an IOS into switch via laptop

Download a TFTP server and install it.

TFTPD32 is a good one.

Copy the image into the TFTP's root directory.

Put an IP on your Laptop's ethernet NIC.

Ex: 10.0.0.2 255.255.255.0

Turn on the TFTP server application.

Terminal into the switch and type the following commands:

en

conf t

interface vlan 1

ip address 10.0.0.1 255.255.255.0

no shut

interface fa0/1 (this may change depending on model of switch)

switchport mode access

switchport access vlan 1

spanning-tree portfast

exit

exit

Plug in your laptop to the port we just configured.

Ping 10.0.0.1 from your laptop. It should work.

Then erase the flash:

Switch#erase flash:

Copy image if the image ends in .bin

Switch#copy tftp://10.0.0.2/nameofimage.bin flash:

Copy image if the image ends in .tar

Switch#archive download-sw tftp://10.0.0.2/nameofimage.tar flash:

Re: How to tftp an IOS into switch via laptop

New Member

Re: How to tftp an IOS into switch via laptop

thanks for the info guys,

i have another question, do i have to have 2 connections to the switch from a laptop?

1 for console ( do copy tftp commands)

1 for ethernet port (to tranfer image to switch)

Re: How to tftp an IOS into switch via laptop

One ethernet connection from your laptop to the switch. THe other connection is from the laptop serial (COM) port to the console of the switch. It's a special cable, usually flat and light blue or black in color.

New Member

Re: How to tftp an IOS into switch via laptop

thanks for the info again Colin,

cant we telnet into the switch using vlan1's ip and do the copy tftp stuff?

Bronze

Re: How to tftp an IOS into switch via laptop

You can telnet into the switch if that is already configured.

21136
Views
0
Helpful
6
Replies
CreatePlease to create content