Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

How to untar archive content directly into a flash root directory?

Hello everyone!

I have to transfer quite many files (and directories) from a ftp server to my UC500 flash so I put all of them into a tar archive and copied (let's say myArchive.tar) from ftp to flash. The problem is that when I untar the archive, its content goes to flash:/myArchive directory rather than directly to the flash root directory (without creating additional myArchive directory). Could you tell me if there's any solution to this problem?

 

Regards,

kozooh

Everyone's tags (1)
3 REPLIES

Hi,Can you show us command

Hi,

Can you show us command which you use for untaring files on flash?

syntax should be: #archive tar /xtract myArchive.tar flash:/

 

or you can directly extract files from tar file on tftp server into flash

http://www.cisco.com/c/en/us/td/docs/switches/lan/catalyst2950/software/release/12-1_22_ea11x/configuration/guide/scg/swiosfs.html#wp1064669

Best Regards Please rate all helpful posts and close solved questions
Community Member

I used the syntax you

I used the syntax you mentioned and everything works great. The problem was with my tar file as there was a directory inside named the same as archive and that misleaded me. What a silly mistake...

Anyway, thank you for a rapid response and your time!

Community Member

Hi,I have a similar Problem,

Hi,

I have a similar Problem, more specificaly:

by using the same command you mentioned for kozooh I am tryung to copy a tar file on the Flash drive of a c2960 catalyst.

Instead of copying the file as is, the Switch unpacks the file and enters everything it finds in the tar file as a command in the cli.

i get the same result either with copy or with Archive tar.

am i doung sth wrong?

 

1363
Views
0
Helpful
3
Replies
CreatePlease to create content