Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

HSRP Arp issue with Microsoft NLB

I have two 4506 switches running HSRP for a server vlan. On the server vlan my server guy has deployed two servers running microsoft NLB in vmware. I had to put a static arp entry in my 2 cores but HSRP doesn't seem to be acting rght. After the static arp entry we were able to ping the microsoft NLB'd virtual server. We simulated a failure on the server vlan and the secondary HSRP 4506 didn't take over as the active gateway. Any ideas?

4 REPLIES

Re: HSRP Arp issue with Microsoft NLB

What is the configuration of your interfaces that are using HSRP? Can you post that?

HTH,

John

HTH, John *** Please rate all useful posts ***
Purple

Re: HSRP Arp issue with Microsoft NLB

  How is the server hooked into this setup ?   Is there a switch below these 4500"s ?    Is the hsrp in the correct state with a active side and a standby side ?   We need a little more info on how the server is hooked in .    Here is a page that might help.

http://www.cisco.com/en/US/products/hw/switches/ps708/products_configuration_example09186a0080a07203.shtml

Community Member

Re: HSRP Arp issue with Microsoft NLB

this issue has been resolved. i created a test server SVI w/HSRP and trunked it to the bladecenter. Server guy created a test MS NLB cluster and i shut down the active SVI and the other SVI on the 4500 took over. i didn't have a solid way of testing without affecting production traffic. the static arp entries were the key to making this work.

Community Member

Re: HSRP Arp issue with Microsoft NLB

Where did you put your static arp entries?  where they for the HSRP interfaces, or the NLB?

thanks!!

1758
Views
0
Helpful
4
Replies
CreatePlease to create content