Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

HSRP between 2 Switches and 2 x 1GB Link

We have 2 switches - C6509 and C3550. there is a 1GB link on each of them. There is Cisco IOS on each of this Switches

Now, we want to run HSRP and load balancing between these 2 links?

How do I go about it?

Thanks

5 REPLIES
Cisco Employee

Re: HSRP between 2 Switches and 2 x 1GB Link

Hi Friend,

This link will guide you how to configure hsrp

http://www.cisco.com/univercd/cc/td/doc/product/lan/cat3750/12225see/scg/swhsrp.htm

HTH

Ankur

Re: HSRP between 2 Switches and 2 x 1GB Link

Hi,

assume that you have 5 vlans created on 6509, exactely the same configuration should be running on the the 3550, only the switch IP address & the vlan interface ip address should be different. where the standby ip should be the same on both the vlan interface of 6509 & 3550. you may also have a doubt that how 1 becomes the main & other becomes the standby. when you run HSRP, actually both the switches are active, which means the 3550 is also running same as 6509, when ever 6509 fails, immediately, within few seconds of delay in my test lab it took 8 seconds(juz to learn the MAC address everything)3550 will become the active switch. this is based on the priority of the switch configured on the vlan interface. here is now to configure one as an active switch & the other as the standby switch.

Physcial connectivity as follows

edge-1 -----> 6509

edge-1 -----> 3550

6509 -----> 3550

all these ports should be trunked.

on 6509

switch

set interface sc0 5 10.1.1.1/255.255.255.0 10.1.1.255

MSFC2(layer 3 module)

interface vlan 2

description ***Server Farm***

ip address 10.1.1.254 255.255.255.0

standby 1 ip 10.1.1.252 255.255.255.0

standby 1 timers 5 15

standby 1 priority 110

standby 1 preempt

interface vlan 3

description ***Marketing Department***

ip address 10.2.1.254 255.255.255.0

standby 2 ip 10.2.1.252 255.255.255.0

standby 2 timers 5 15

standby 2 priority 110

standby 2 preempt

on 3550

switch

interface vlan 2

description ***Server Farm***

ip address 10.1.1.253 255.255.255.0

standby 1 ip 10.1.1.252 255.255.255.0

standby 1 timers 5 15

standby 1 priority 109

standby 1 preempt

interface vlan 3

description ***Marketing Department***

ip address 10.2.1.253 255.255.255.0

standby 2 ip 10.2.1.252 255.255.255.0

standby 2 timers 5 15

standby 2 priority 109

standby 2 preempt

here you can see that the priority valvue is less on 3550,based on this value active & standby will be decided.

now in the client & server side, make the gateway ip address as the virtual IP. ie. for servers the gateway IP address should 10.1.1.252 & for the markerting pc's it should be 10.2.1.252.

which means even if 6509 interface vlan 2 fails this 10.2.1.252 virtual IP will act as 10.2.1.253

Note: HSRP between the switches (6509 & 3550) will communicate via Multicast, so when you implement access list make sure that you permitting the multicast IP address 224.0.0.2 for HSRP, if it is not permitted HSRP will not work.

hope this helps.

rate this post if cleared.

New Member

Re: HSRP between 2 Switches and 2 x 1GB Link

Thanks

We are running EIGRP.

SO what I want to know is

The 2 of them are configured as Trunks beween the Switches.

To run them as HSRP, do I put both of them in the same HSRP gorup.

I do know how to configure HSRP, it is the planning on how they should work that I am after?

Thanks

Re: HSRP between 2 Switches and 2 x 1GB Link

Hi,

i really don't understand what exactly your looking in for. regarding the the HSRP configuration i have clearly given the configuration part in my previous posting, you can do according to that. if still you have doubt, please lemme know so that i can clearly explain about that.

New Member

Re: HSRP between 2 Switches and 2 x 1GB Link

Thanks. I have posted a cleared expalnation on a new post. Please can u also have alook at this?

Thanks for your help

273
Views
0
Helpful
5
Replies
CreatePlease to create content