Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

HSRP configuration with two separate subnet

Hi,

I have two sites with 2 routers each as follows:

site1 - router1 - primary link - router1 - site2

site1 - router2 - secondary link - router 2 - site2

The ethernet interface for router1 & router 2 are different (different subnet)..

I want to implement the HSRP..Can you please help me..

Thanks in advance

Mohamed

10 REPLIES
Cisco Employee

Re: HSRP configuration with two separate subnet

Hi,

HSRP requires the two routers to have a common LAN and to be on the same subnet.

In your case make sure the two routers are in the same LAN. You might use secondary IP addresses on the LAN interfaces of both routers to support two subnets and deliver redundancy and two HSRP groups, one for each subnet.

For a detailed description of the Operation of HSRP please have a look at

http://www.cisco.com/en/US/docs/ios/12_4t/ip_appl/configuration/guide/htaiphsr.html#wp1053967

Hope this helps!

Regards, Martin

New Member

Re: HSRP configuration with two separate subnet

Hi,

Could you please advise if the below configuration is correct; according to your recommendation?

This is an example configuration for site1:

Router1 (primary)

interface Ethernet0

ip address 192.168.10.3 255.255.255.0

ip address 10.10.0.1 255.255.255.0 secondary

standby 1 ip 10.10.0.3

standby 1 preempt

standby 1 priority 100

standby 1 authentication denmark

standby 1 timers 5 15

!

interface serial0

ip address <> <>

!

router eigrp 1

network 192.168.10.0

network 10.10.0.0

network <>

Router2 (secondary)

interface Ethernet0

ip address 192.168.11.3 255.255.255.0

ip address 10.10.0.2 255.255.255.0 secondary

standby 1 ip 10.10.0.3

standby 1 preempt

standby 1 priority 100

standby 1 authentication denmark

standby 1 timers 5 15

!

interface serial0

ip address <> <>

!

router eigrp 1

network 192.168.11.0

network 10.10.0.0

network <>

Thanks in advance

Cheers

Mohamed

Cisco Employee

Re: HSRP configuration with two separate subnet

Hi Mohamed,

First, the main question is, for which devices do you setup HSRP on the two routers? Where (PC, router, ...) do you configure 10.10.0.3?

The main reason to use HSRP is to have redundancy for devices, where a fixed IP address needs to be configured as default gateway. If there are no such devices connected to the LAN of the two routers, then it is unlikely that you need HSRP at all. Your dynamic routing protocol should take care of redundancy.

Second, are the two routers on a common LAN or not? If the answer is "No", then a common HSRP group does not make sense.

If the answer is "Yes", then I would have expected something like:

interface Ethernet0

ip address 192.168.10.2 255.255.255.0

ip address 192.168.11.2 255.255.255.0 secondary

standby 1 ip 192.168.10.1

standby 1 preempt

standby 1 priority 110

standby 1 authentication denmark

standby 1 timers 5 15

standby 2 ip 192.168.11.1 secondary

standby 2 preempt

standby 2 priority 110

standby 2 authentication denmark

standby 2 timers 5 15

!

Router2 (secondary)

interface Ethernet0

ip address 192.168.10.3 255.255.255.0

ip address 192.168.11.3 255.255.255.0 secondary

standby 1 ip 192.168.10.1

standby 1 preempt

standby 1 priority 100

standby 1 authentication denmark

standby 1 timers 5 15

standby 2 ip 192.168.11.1 secondary

standby 2 preempt

standby 2 priority 100

standby 2 authentication denmark

standby 2 timers 5 15

!

Hope this helps! Please rate all posts.

Regards, Martin

New Member

Re: HSRP configuration with two separate subnet

Hi Martin,

The HSRP will be setup on the two routers. The is a device (server) connected to these two routers..this server has two network card..one card (192.168.10.4)connected to the primary router and another (192.168.11.4) for the secondary router.

So, according to your configuration, the default gateway for the server will be 192.168.10.1 for 192.168.10.0 subnet & 192.168.11.1 for 192.168.11.0 subnet, is it right?? and that's it?? the server will switch to the secondary router once the primary router goes down?

Thanks to advise?

Thanks for your help

Mohamed

New Member

Re: HSRP configuration with two separate subnet

Hi Mohamed,

Yes, in the solution of Martin the GW for 10.x is 10.1 and for the 11.x will be the 11.1

Also take a notice of the preempt value at the Marin solution. If the router goes down, the second one will take over. If the failed router comes up, the active one will be the one with the highest preempt value.

Cheers

J

Cisco Employee

Re: HSRP configuration with two separate subnet

Hi,

If the server will be connected back-to-back to the two routers then one basic requirement of HSRP is not fulfilled: the common LAN segment between the two routers.

HSRP requires Hello packets to be sent through a Switch, which means both router interfaces must belong to the same VLAN.

If the two routers and the server are in one VLAN then the example config can work.

Regards, Martin

New Member

Re: HSRP configuration with two separate subnet

Hi Martin,

So, to implement the HSRP, we need to have a Switch behind...

Last concern, for the backup link..for cost issue,This not going to be used unless the primary link goes down (no routing packet should cross the backup link)..

is it enough with HSRP setup or do i need to tune the routing configuration on both routers.

Thanks to advise.

Appreciate your help

Cheers

Mohamed

Cisco Employee

Re: HSRP configuration with two separate subnet

Hi,

It depends on your EIGRP link metrics and EIGRP configuration, if one or the other or even both links are used - assuming EIGRP is used between the sites.

To make sure the backup link is only used, if the primary is down, you can use a higher "bandwidth " statement on the prefered link compared to the backup link.

Hope this helps!

Regards, Martin

New Member

Re: HSRP configuration with two separate subnet

Hi Martin,

It's gonna be easier if we have one router with two links (primary & secondary)...

Is it the same for my case..One router with primary link and second router with back link..

i'm confused. Can you help me on.

Thanks in advance

Mohamed

New Member

Re: HSRP configuration with two separate subnet

Hi Martin,

It's gonna be easier if we have one router with two links (primary & secondary)...

Is it the same for my case..One router with primary link and second router with back link..

i'm confused. Can you help me on.

Thanks in advance

Mohamed

236
Views
17
Helpful
10
Replies