Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

HSRP configuration

I have a couple questions regarding HSRP. I understand how to configure it but i'm not too clear on how to configure the access layer switches. I plan to configure it on 2 4506's. Right now i am setting up a lab on 3 3560's. 2 are configured to intervlan route and i have a trunk carrying 3 vlans between the two. I have HSRP configured on both....

3560-1

!

interface Vlan1

ip address 10.0.0.2 255.255.255.0

standby 10 ip 10.0.0.1

standby 10 priority 100

!

interface Vlan2

ip address 10.0.2.2 255.255.255.0

standby 20 ip 10.0.2.1

standby 20 priority 100

!

interface Vlan3

ip address 10.0.3.2 255.255.255.0

standby 30 ip 10.0.3.1

standby 30 priority 100

!

3560-2

!

interface Vlan1

ip address 10.0.0.3 255.255.255.0

standby 10 ip 10.0.0.1

standby 10 priority 150

!

interface Vlan2

ip address 10.0.2.3 255.255.255.0

standby 20 ip 10.0.2.1

standby 20 priority 150

!

interface Vlan3

ip address 10.0.3.3 255.255.255.0

standby 30 ip 10.0.3.1

standby 30 priority 150

!

My question is, i have a 3rd 3560 with two patch cables coming out of it to each of the layer 3 switches. Each link is configured as a trunk. Question is, do i set up an ether channel? Right now STP is blocking one of the ports as expected.

1 ACCEPTED SOLUTION

Accepted Solutions
Hall of Fame Super Bronze

Re: HSRP configuration

having them connect to 2 layer 2 switches and the l2 switches connecting to the cores running HSRP. Does this sound right?

Without etherchanneling, sounds right. One port will be in blocking mode, though.

That way each server will have a redundant physical connection to the core. I want to run HSRP between the 4506. Does this sound like it would work? From all the documentation i've been reading it sounds like it would work. but i'm just not understanding how i can get a layer 2 switch connected to the cores with redundant connections with out STP.

It should work. If you want redundancy without STP, you must change your design from L2 inter-switch links to L3 (routed ports) inter-switch links.

__

Edison.

9 REPLIES
Hall of Fame Super Bronze

Re: HSRP configuration

Source and Destination devices must be the same when configuring etherchanneling. The only exception is when using 3750 (Stackable) or 6500 VSS (MEC).

You can avoid the STP blocking behavior by configuring L3 ports instead of L2 ports between switches. However, I don't know your requirements so proceed with caution.

HTH,

__

Edison.

Please rate helpful posts

New Member

Re: HSRP configuration

Ok, so ether channels can't connect to two different switches. What I'm after is providing redundancy for our servers. I'd like to have two links from the servers to two different switches and run HSRP. I was thinking about "teaming" the NIC's and having them connect to 2 switches. Or possibly having them connect to 2 layer 2 switches and the l2 switches connecting to the cores running HSRP. Does this sound right?

EDIT:

Currently we have one 4506 as our core doing intervlan routing. We have several switches trunked off of the core. We also have several servers connected to our core on the same vlan. What I'd like to do is add another 4506, and add another connection from the servers to the second switch. That way each server will have a redundant physical connection to the core. I want to run HSRP between the 4506. Does this sound like it would work? From all the documentation i've been reading it sounds like it would work. but i'm just not understanding how i can get a layer 2 switch connected to the cores with redundant connections with out STP.

Hall of Fame Super Bronze

Re: HSRP configuration

For this requirement, I suggest a 3750 switch solution (stackable). You don't even need to configure HSRP as the stack provides a single virtual switch.

You can then configure etherchannel between the server(s) and switches.

__

Edison.

New Member

Re: HSRP configuration

I edited my previous post. It explains the topology a little better. We already have the infrastructure in place to run HSRP. I do like the 3750's; we use these for our SAN. We actually have several 4506's. All but the core is in layer 2. Do you see an alternate method over the 3750's?

New Member

Re: HSRP configuration

Sorry to bump my post.

Hall of Fame Super Bronze

Re: HSRP configuration

having them connect to 2 layer 2 switches and the l2 switches connecting to the cores running HSRP. Does this sound right?

Without etherchanneling, sounds right. One port will be in blocking mode, though.

That way each server will have a redundant physical connection to the core. I want to run HSRP between the 4506. Does this sound like it would work? From all the documentation i've been reading it sounds like it would work. but i'm just not understanding how i can get a layer 2 switch connected to the cores with redundant connections with out STP.

It should work. If you want redundancy without STP, you must change your design from L2 inter-switch links to L3 (routed ports) inter-switch links.

__

Edison.

New Member

Re: HSRP configuration

ok, i see. I may run GRRP so using L3 links is what I'm looking for then. I'm sure i'll run into more problems. Thanks for your help as always Edison.

New Member

Re: HSRP configuration

Are the links between two HSRP enabled devices layer 2 or layer 3? Seems like i could set both sides to trunks to carry all of my vlans.

Hall of Fame Super Bronze

Re: HSRP configuration

If you have an IP address under the physical interface, it's a L3 inter-switch link - else it's L2 and STP will run on it.

HTH,

__

Edison.

310
Views
0
Helpful
9
Replies
CreatePlease to create content