Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

HSRP dupplicate addres issue

Hello,

We had a power faliure in our company last week, which resulted in a lot of problems on our network, we managed to braing everything back to life, theres just one more problem that we cant solve:

We have two 2811 routers working in HSRP, they are connected both deirectly and to two stacked c2960s switches that go on to the rest of the network. Since the faliure we keep getting messages like these on both routers:

Sep 26 07:27:03.626: %IP-4-DUPADDR: Duplicate address 10.251.214.201 on FastEthernet0/1, sourced by 0023.5e07.e0b9

Sep 26 07:32:03.631: %IP-4-DUPADDR: Duplicate address 10.251.214.41 on FastEthernet0/1, sourced by 0023.5e07.e0b8

Sep 26 07:27:13.485: %IP-4-DUPADDR: Duplicate address 10.251.214.43 on FastEthernet0/0, sourced by 0023.5e07.e058

We have been researching the problem and found a lot of ppl who had similar problems, buth all were caused by different things (loops, viruses, NAT, DHCP), and none of them seem to fit our situation, the most baffling thing about this is that other than these messages being generated every 30 seconds there are no other indications of the problem, everything seems to be working and all configurations are the same as they were before the power faliures, if our monitoring department werent complaining about recieving a bunch of alerts we wouldnt even bother with this

Below this im posting relevant configurations, if any1 has some ideas please help!

The configurations of the two routers are:

rtr101:

!

!

interface Port-channel1

switchport access vlan 112

switchport mode trunk

!

interface FastEthernet0/0

description Customer O&M Uplink 1

ip address 10.251.214.41 255.255.255.128

ip nat outside

ip virtual-reassembly

duplex auto

speed auto

standby 102 ip 10.251.214.40

standby 102 preempt

standby 102 track Vlan112

!

interface FastEthernet0/1

description Customer Production Uplink 1

ip address 10.251.214.201 255.255.255.224

ip nat outside

ip virtual-reassembly

duplex auto

speed auto

standby 103 ip 10.251.214.200

standby 103 preempt

standby 103 track Vlan128

!

interface FastEthernet1/0

description svr101:mgt

switchport access vlan 112

spanning-tree portfast

!

interface FastEthernet1/1

description svr101:nge0

switchport access vlan 112

switchport mode trunk

channel-group 1 mode on

spanning-tree portfast

!

interface FastEthernet1/2

description svr101:nge1

switchport access vlan 112

switchport mode trunk

channel-group 1 mode on

spanning-tree portfast

!

interface FastEthernet1/3

description rtr102:fa1/3

switchport mode trunk

spanning-tree portfast

!

interface FastEthernet1/4

!

interface FastEthernet1/5

!

interface FastEthernet1/6

description "local connector to traffic LAN"

switchport access vlan 128

!

interface FastEthernet1/7

description "local connector to OAM LAN"

switchport access vlan 112

!

interface FastEthernet1/8

shutdown

!

interface FastEthernet1/9

shutdown

!

interface FastEthernet1/10

shutdown

!

interface FastEthernet1/11

shutdown

!

interface FastEthernet1/12

shutdown

!

interface FastEthernet1/13

shutdown

!

interface FastEthernet1/14

shutdown

!

interface FastEthernet1/15

shutdown

!

interface Vlan1

no ip address

!

interface Vlan112

description O&M LAN

ip address 172.31.112.7 255.255.252.0

ip nat inside

ip virtual-reassembly

standby 112 ip 172.31.112.1

standby 112 preempt

standby 112 track FastEthernet0/0

!

interface Vlan128

description FE LAN

ip address 172.31.128.7 255.255.252.0

ip nat inside

ip virtual-reassembly

standby 128 ip 172.31.128.1

standby 128 preempt

standby 128 track FastEthernet0/1

!

interface Async0/0/0

description Terminalserver-Port svr102:con

no ip address

encapsulation slip

!

interface Async0/0/1

description Terminalserver-Port rtr101:con

no ip address

encapsulation slip

!

interface Async0/0/2

no ip address

encapsulation slip

!

interface Async0/0/3

no ip address

encapsulation slip

!

interface Async0/0/4

no ip address

encapsulation slip

!

interface Async0/0/5

no ip address

encapsulation slip

!

interface Async0/0/6

no ip address

encapsulation slip

!

interface Async0/0/7

no ip address

encapsulation slip

!

router rip

version 2

redistribute connected

redistribute static metric 5

passive-interface default

no passive-interface FastEthernet0/1

network 169.254.0.0

distribute-list prefix RIPv2-Out out

distribute-list prefix RIPv2-In in

no auto-summary

!

ip forward-protocol nd

ip route 0.0.0.0 0.0.0.0 10.251.214.1

ip route 10.12.2.100 255.255.255.255 10.251.130.1

ip route 10.12.4.41 255.255.255.255 10.251.130.1

ip route 198.18.16.1 255.255.255.255 198.18.100.254

ip route 198.18.16.2 255.255.255.255 198.18.100.254

ip route 198.18.16.3 255.255.255.255 198.18.100.254

!

no ip http server

no ip http secure-server

!

ip nat inside source static 172.31.112.7 10.251.214.41

ip nat inside source static 172.31.112.8 10.251.214.42

ip nat inside source static 172.31.112.128 10.251.214.43

ip nat inside source static 172.31.112.129 10.251.214.44

ip nat inside source static 172.31.113.128 10.251.214.45

ip nat inside source static 172.31.113.129 10.251.214.46

ip nat inside source static 172.31.128.128 10.251.214.47

ip nat inside source static 172.31.128.129 10.251.214.48

ip nat inside source static 172.31.129.32 10.251.214.201

ip nat inside source static 172.31.129.33 10.251.214.202

!

ip access-list standard SNMP-ACL

!

!

ip prefix-list RIPv2-In description Things we listen to via RIPv2

ip prefix-list RIPv2-In seq 5 deny 0.0.0.0/0 le 32

!

ip prefix-list RIPv2-Out description Things we publish via RIPv2

ip prefix-list RIPv2-Out seq 5 deny 0.0.0.0/0

ip prefix-list RIPv2-Out seq 999999 permit 0.0.0.0/0 le 32

logging facility local5

logging 172.31.112.128

logging 172.31.112.129


rtr102:

!

!

interface Port-channel2

switchport access vlan 112

switchport mode trunk

!

interface FastEthernet0/0

description Customer O&M Uplink 2

ip address 10.251.214.42 255.255.255.128

ip nat outside

ip virtual-reassembly

duplex auto

speed auto

standby 102 ip 10.251.214.40

standby 102 priority 95

standby 102 preempt

standby 102 track Vlan112

!

interface FastEthernet0/1

description Customer Production Uplink 2

ip address 10.251.214.202 255.255.255.224

ip nat outside

ip virtual-reassembly

duplex auto

speed auto

standby 103 ip 10.251.214.200

standby 103 priority 95

standby 103 preempt

standby 103 track Vlan128

!

interface FastEthernet1/0

description svr102:mgt

switchport access vlan 112

spanning-tree portfast

!

interface FastEthernet1/1

description svr102:nge0

switchport access vlan 112

switchport mode trunk

channel-group 2 mode on

spanning-tree portfast

!

interface FastEthernet1/2

description svr102:nge1

switchport access vlan 112

switchport mode trunk

channel-group 2 mode on

spanning-tree portfast

!

interface FastEthernet1/3

description rtr101:fa1/3

switchport mode trunk

spanning-tree portfast

!

interface FastEthernet1/4

shutdown

!

interface FastEthernet1/5

shutdown

!

interface FastEthernet1/6

description "local connector to traffic LAN"

switchport access vlan 128

!

interface FastEthernet1/7

description "local connector to OAM LAN"

switchport access vlan 112

!

interface FastEthernet1/8

no switchport

no ip address

shutdown

!

interface FastEthernet1/9

no switchport

no ip address

shutdown

!

interface FastEthernet1/10

shutdown

!

interface FastEthernet1/11

shutdown

!

interface FastEthernet1/12

shutdown

!

interface FastEthernet1/13

shutdown

!

interface FastEthernet1/14

shutdown

!

interface FastEthernet1/15

shutdown

!

interface Vlan1

no ip address

!

interface Vlan112

description O&M LAN

ip address 172.31.112.8 255.255.252.0

ip nat inside

ip virtual-reassembly

standby 112 ip 172.31.112.1

standby 112 priority 95

standby 112 preempt

standby 112 track FastEthernet0/0

!

interface Vlan128

description FE LAN

ip address 172.31.128.8 255.255.252.0

ip nat inside

ip virtual-reassembly

standby 128 ip 172.31.128.1

standby 128 priority 95

standby 128 preempt

standby 128 track FastEthernet0/1

!

interface Async0/0/0

description Terminalserver-Port svr102:con

no ip address

encapsulation slip

!

interface Async0/0/1

description Terminalserver-Port rtr101:con

no ip address

encapsulation slip

!

interface Async0/0/2

no ip address

encapsulation slip

!

interface Async0/0/3

no ip address

encapsulation slip

!

interface Async0/0/4

no ip address

encapsulation slip

!

interface Async0/0/5

no ip address

encapsulation slip

!

interface Async0/0/6

no ip address

encapsulation slip

!

interface Async0/0/7

no ip address

encapsulation slip

!

router rip

version 2

redistribute connected metric 11

redistribute static metric 11

passive-interface default

no passive-interface FastEthernet0/1

network 169.254.0.0

distribute-list prefix RIPv2-Out out

distribute-list prefix RIPv2-In in

no auto-summary

!

ip forward-protocol nd

ip route 0.0.0.0 0.0.0.0 10.251.214.1

ip route 10.12.2.100 255.255.255.255 10.251.130.1

ip route 10.12.4.41 255.255.255.255 10.251.130.1

ip route 198.18.16.1 255.255.255.255 198.18.100.254

ip route 198.18.16.2 255.255.255.255 198.18.100.254

ip route 198.18.16.3 255.255.255.255 198.18.100.254

!

no ip http server

no ip http secure-server

!

ip nat inside source static 172.31.112.7 10.251.214.41

ip nat inside source static 172.31.112.8 10.251.214.42

ip nat inside source static 172.31.112.128 10.251.214.43

ip nat inside source static 172.31.112.129 10.251.214.44

ip nat inside source static 172.31.113.128 10.251.214.45

ip nat inside source static 172.31.113.129 10.251.214.46

ip nat inside source static 172.31.128.128 10.251.214.47

ip nat inside source static 172.31.128.129 10.251.214.48

ip nat inside source static 172.31.129.32 10.251.214.201

ip nat inside source static 172.31.129.33 10.251.214.202

!

ip access-list standard SNMP-ACL

!

!

ip prefix-list RIPv2-In description Things we listen to via RIPv2

ip prefix-list RIPv2-In seq 5 deny 0.0.0.0/0 le 32

!

ip prefix-list RIPv2-Out description Things we publish via RIPv2

ip prefix-list RIPv2-Out seq 5 deny 0.0.0.0/0

ip prefix-list RIPv2-Out seq 999999 permit 0.0.0.0/0 le 32

logging facility local5

logging 172.31.112.128

logging 172.31.112.129


ARP tables of both routers:

rtr101#sh arp

Protocol  Address          Age (min)  Hardware Addr   Type   Interface

Internet  10.251.214.1           31   0000.0c07.ac04  ARPA   FastEthernet0/0

Internet  10.251.214.2           31   0026.cafb.76c1  ARPA   FastEthernet0/0

Internet  10.251.214.3           31   0026.cafb.7ec1  ARPA   FastEthernet0/0

Internet  10.251.214.10          30   34bd.c819.3641  ARPA   FastEthernet0/0

Internet  10.251.214.40           -   0000.0c07.ac66  ARPA   FastEthernet0/0

Internet  10.251.214.41           -   0023.5e07.e058  ARPA   FastEthernet0/0

Internet  10.251.214.42           -   0023.5e07.e058  ARPA   FastEthernet0/0

Internet  10.251.214.43           -   0023.5e07.e058  ARPA   FastEthernet0/0

Internet  10.251.214.44           -   0023.5e07.e058  ARPA   FastEthernet0/0

Internet  10.251.214.45           -   0023.5e07.e058  ARPA   FastEthernet0/0

Internet  10.251.214.46           -   0023.5e07.e058  ARPA   FastEthernet0/0

Internet  10.251.214.47           -   0023.5e07.e058  ARPA   FastEthernet0/0

Internet  10.251.214.48           -   0023.5e07.e058  ARPA   FastEthernet0/0

Internet  10.251.214.193         31   0026.0b31.11be  ARPA   FastEthernet0/1

Internet  10.251.214.196         31   0050.56ac.0008  ARPA   FastEthernet0/1

Internet  10.251.214.197         31   0050.56ac.000b  ARPA   FastEthernet0/1

Internet  10.251.214.198         31   0050.56ac.0008  ARPA   FastEthernet0/1

Internet  10.251.214.199         31   0050.56ac.0008  ARPA   FastEthernet0/1

Internet  10.251.214.200          -   0000.0c07.ac67  ARPA   FastEthernet0/1

Internet  10.251.214.201          -   0023.5e07.e059  ARPA   FastEthernet0/1

Internet  10.251.214.202          -   0023.5e07.e059  ARPA   FastEthernet0/1

Internet  172.31.112.1            -   0000.0c07.ac70  ARPA   Vlan112

Internet  172.31.112.7            -   0023.5e07.e058  ARPA   Vlan112

Internet  172.31.112.8           31   0023.5e07.e0b8  ARPA   Vlan112

Internet  172.31.112.128          0   0021.28ff.b3ee  ARPA   Vlan112

Internet  172.31.112.129          0   0021.28ff.b32e  ARPA   Vlan112

Internet  172.31.113.128         31   0021.28ff.b3f2  ARPA   Vlan112

Internet  172.31.113.129         31   0021.28ff.b332  ARPA   Vlan112

Internet  172.31.114.32           1   0021.28ff.b3ee  ARPA   Vlan112

Internet  172.31.114.33           1   0021.28ff.b32e  ARPA   Vlan112

Internet  172.31.128.1            -   0000.0c07.ac80  ARPA   Vlan128

Internet  172.31.128.7            -   0023.5e07.e058  ARPA   Vlan128

Internet  172.31.128.128          0   0021.28ff.b3ee  ARPA   Vlan128

Internet  172.31.128.129          0   0021.28ff.b32e  ARPA   Vlan128

Internet  172.31.129.32           4   0021.28ff.b3ee  ARPA   Vlan128

Internet  172.31.129.33           4   0021.28ff.b32e  ARPA   Vlan128

rtr102#sh arp

Protocol  Address          Age (min)  Hardware Addr   Type   Interface

Internet  10.251.214.1           31   0000.0c07.ac04  ARPA   FastEthernet0/0

Internet  10.251.214.2           31   0026.cafb.76c1  ARPA   FastEthernet0/0

Internet  10.251.214.3           31   0026.cafb.7ec1  ARPA   FastEthernet0/0

Internet  10.251.214.4           14   009c.02a7.24d8  ARPA   FastEthernet0/0

Internet  10.251.214.10          30   34bd.c819.3641  ARPA   FastEthernet0/0

Internet  10.251.214.12           1   0050.56ac.0007  ARPA   FastEthernet0/0

Internet  10.251.214.13          16   0050.56ac.000a  ARPA   FastEthernet0/0

Internet  10.251.214.41           -   0023.5e07.e0b8  ARPA   FastEthernet0/0

Internet  10.251.214.42           -   0023.5e07.e0b8  ARPA   FastEthernet0/0

Internet  10.251.214.43           -   0023.5e07.e0b8  ARPA   FastEthernet0/0

Internet  10.251.214.44           -   0023.5e07.e0b8  ARPA   FastEthernet0/0

Internet  10.251.214.45           -   0023.5e07.e0b8  ARPA   FastEthernet0/0

Internet  10.251.214.46           -   0023.5e07.e0b8  ARPA   FastEthernet0/0

Internet  10.251.214.47           -   0023.5e07.e0b8  ARPA   FastEthernet0/0

Internet  10.251.214.48           -   0023.5e07.e0b8  ARPA   FastEthernet0/0

Internet  10.251.214.193         31   0026.0b31.11be  ARPA   FastEthernet0/1

Internet  10.251.214.196         31   0050.56ac.0008  ARPA   FastEthernet0/1

Internet  10.251.214.197         31   0050.56ac.000b  ARPA   FastEthernet0/1

Internet  10.251.214.198         31   0050.56ac.0008  ARPA   FastEthernet0/1

Internet  10.251.214.199         31   0050.56ac.0008  ARPA   FastEthernet0/1

Internet  10.251.214.201          -   0023.5e07.e0b9  ARPA   FastEthernet0/1

Internet  10.251.214.202          -   0023.5e07.e0b9  ARPA   FastEthernet0/1

Internet  172.31.112.7           31   0023.5e07.e058  ARPA   Vlan112

Internet  172.31.112.8            -   0023.5e07.e0b8  ARPA   Vlan112

Internet  172.31.112.128          0   0021.28ff.b3ee  ARPA   Vlan112

Internet  172.31.112.129          0   0021.28ff.b32e  ARPA   Vlan112

Internet  172.31.113.128         31   0021.28ff.b3f2  ARPA   Vlan112

Internet  172.31.113.129         31   0021.28ff.b332  ARPA   Vlan112

Internet  172.31.114.32           1   0021.28ff.b3ee  ARPA   Vlan112

Internet  172.31.114.33           0   0021.28ff.b32e  ARPA   Vlan112

Internet  172.31.128.8            -   0023.5e07.e0b8  ARPA   Vlan128

Internet  172.31.128.128          1   0021.28ff.b3ee  ARPA   Vlan128

Internet  172.31.128.129          0   0021.28ff.b32e  ARPA   Vlan128

Internet  172.31.129.32           4   0021.28ff.b3ee  ARPA   Vlan128

Internet  172.31.129.33           0   0021.28ff.b32e  ARPA   Vlan128

Switch interfaces to which the routers are connected:

interface GigabitEthernet1/0/44

description AAA Management to rtr101 fa0/0

switchport access vlan 543

switchport mode access

!

interface GigabitEthernet1/0/45

description AAA Production to rtr101 fa0/1

switchport access vlan 546

switchport mode access

!

!

interface GigabitEthernet2/0/44

description AAA Management to rtr102 fa0/0

switchport access vlan 543

switchport mode access

!

interface GigabitEthernet2/0/45

description AAA Production to rtr102 fa0/1

switchport access vlan 546

switchport mode access

Thank you for reading,

regards

137
Views
0
Helpful
0
Replies
CreatePlease to create content