Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

HSRP in 3550 switch

Dear Sir/Madam,

  i have configure HSRP in two switches, and configuration like

SWITCH A

----------------------------------------

interface GigabitEthernet0/1
no switchport
no ip address
standby 1 ip 192.168.1.1
standby 1 priority 150
standby 1 preempt
standby 10 ip 192.168.10.1
standby 10 priority 151
standby 10 preempt
standby 20 ip 192.168.20.1
standby 20 priority 152
standby 20 preempt
standby ip 192.168.30.1
standby priority 153
standby preempt
!
interface GigabitEthernet0/2
!
!
interface Vlan 1
ip address 192.168.1.2 255.255.255.0
no ip route-cache
!
interface Vlan0010
ip address 192.168.10.2 255.255.255.0
no ip route-cache
!
interface Vlan0020
ip address 192.168.20.2 255.255.255.0
no ip route-cache
!
interface Vlan0030
ip address 192.168.30.2 255.255.255.0
no ip route-cache
!
vlan 10 name VLAN0010
vlan 20 name VLAN0020
vlan 30 name VLAN0030

----------------------------- -----------

SWITCH B

-----------------------------------------
interface GigabitEthernet0/1
no switchport
no ip address
standby 1 ip 192.168.1.1
standby 1 priority 100
standby 10 ip 192.168.10.1
standby 10 priority 101
standby 20 ip 192.168.20.1
standby 20 priority 102
standby ip 192.168.30.1
standby priority 103
!
interface GigabitEthernet0/2
!
!
interface Vlan 1
ip address 192.168.1.3 255.255.255.0
no ip route-cache
!
interface Vlan0010
ip address 192.168.10.3 255.255.255.0
no ip route-cache
!
interface Vlan0020
ip address 192.168.20.3 255.255.255.0
no ip route-cache
!
interface Vlan0030
ip address 192.168.30.3 255.255.255.0
no ip route-cache
!
vlan 10 name VLAN0010
vlan 20 name VLAN0020
vlan 30 name VLAN0030

----------------------------------------------------------------

after this configuration i can't ping the gateway (standby ip of HSRP) from client, also i can't ping the others vlan users also where ip routing is enable ... so can u suggest me what will be the issue.

Thanks

Debabrata 

10 REPLIES
VIP Purple

Re: HSRP in 3550 switch

With VLANs on a multilayer-switch, all ip-config will be on the vlan-interface and not on the physical interface. So change your config in the following way and your HRSP will work

interface GigabitEthernet0/1
switchport mode trunk
!
!
interface Vlan 1
ip address 192.168.1.2 255.255.255.0
standby 1 ip 192.168.1.1
standby 1 priority 150
standby 1 preempt
!
interface Vlan0010
ip address 192.168.10.2 255.255.255.0
standby 10 ip 192.168.10.1
standby 10 priority 151
standby 10 preempt
...



Sent from Cisco Technical Support iPad App


--
Don't stop after you've improved your network! Improve the world by lending money to the working poor: http://www.kiva.org/invitedby/karsteni
New Member

Re: HSRP in 3550 switch

Thanks for your reply, but one assign 4 standby group only for 4 vlan, but my requiremen it around 20 vlans, so that what can i do ?

Thanks

Debabrata

New Member

HSRP in 3550 switch

Dear Debabrata,

                      For each SVI VLAN you need to specfic standby group  . if its 20 SVI you need to have 20 standby group .

What do you mean by but one assign 4 standby group only for 4 vlan ??

HTH

Santhosh Saravanan

HTH Regards Santhosh Saravanan
VIP Purple

Re: HSRP in 3550 switch

I don't understand what you meam with that, but you can add the standby-configuration to all your vlans that need it.

-- 
Don't stop after you've improved your network! Improve the world by lending money to the working poor:
http://www.kiva.org/invitedby/karsteni


--
Don't stop after you've improved your network! Improve the world by lending money to the working poor: http://www.kiva.org/invitedby/karsteni
New Member

HSRP in 3550 switch

dear ,

  if i configure like

interface Vlan 1

ip address 192.168.1.2 255.255.255.0

standby 1 ip 192.168.1.1

standby 1 priority 150

standby 1 preempt

!

interface Vlan0010

ip address 192.168.10.2 255.255.255.0

standby 10 ip 192.168.10.1

standby 10 priority 151

standby 10 preempt

!

interface Vlan 20

ip address 192.168.20.2 255.255.255.0

standby 20 ip 192.168.20.1

standby 20 priority 152

standby 20 preempt

!

interface Vlan0030

ip address 192.168.30.2 255.255.255.0

standby (?)  ip 192.168.30.1

standby (?) priority 153

standby (?) preempt

i can't put here (?) the standby group 30 , supported command is " standby ip 192.168.30.1 " and its automatically bind with group 0, so that case i have able to assign here only 4 groups its 0,1,10 and 20. if i have anothe vlan then what will be standby group id ?

Thanks

Debabrata

VIP Purple

HSRP in 3550 switch

The standby group is only significant local to the interface. As long as you don't need multiple groups for load-sharing you can use any group you want. That includes that you can use the default group on all interfaces.

-- 
Don't stop after you've improved your network! Improve the world by lending money to the working poor:
http://www.kiva.org/invitedby/karsteni


--
Don't stop after you've improved your network! Improve the world by lending money to the working poor: http://www.kiva.org/invitedby/karsteni
New Member

HSRP in 3550 switch

okay,

i mean you want to say , i can configure all the vlan interface in same group  ? But when we will use different group?

another thing can i use same priority for all SVI ?

please explane... if possible send any reference documents..

Thanks

Debabrata

New Member

HSRP in 3550 switch

Dear Debabrata,

           What is your switch hardware which is being used for Switch A & Switch B , there are some limitation based on your hardware & IOS code .

Kindly give "show version" of your switch hardware to suggest you better .

If it  Catalyst 6500/6000s? switch then its allowed upto 255 based on supervisor engine .

http://www.cisco.com/en/US/partner/products/hw/switches/ps700/products_qanda_item09186a008011c6bb.shtml

What is the maximum number of HSRP group IDs supported on various Supervisor Engines?

A. This table lists the maximum number of unique HSRP group IDs supported (system wide) on various Supervisor Engines with MSFC1, MSFC2, MSFC3 (Supervisor Engine 720), or MSFC2A (Supervisor Engine 32). The Policy Feature Card 1 (PFC1) or PFC3-equipped Supervisor Engine has a 256 unique HSRP group ID limit. The Policy Feature Card 2 (PFC2)-equipped Supervisor Engine has a 16 unique HSRP group ID limit.

Supervisor EngineDescriptionMaximum Number of Unique HSRP Groups IDs (system wide)
WS-X6K-SUP1A-MSFC=Supervisor Engine 1 with PFC1 and MSFC1256
WS-X6K-S1A-MSFC2=Supervisor Engine 1 with PFC1 and MSFC2256
WS-X6K-S2-MSFC2= Supervisor Engine 2 with PFC2 and MSFC216
WS-X6K-S2U-MSFC2=Supervisor Engine 2 with PFC2 and MSFC2 (with additional DRAM memory)16
WS-SUP720Supervisor Engine 720 with PFC3 and MSFC3256
WS-SUP720-3BSupervisor Engine 720 with PFC3B and MSFC3256
WS-SUP720-3BXLSupervisor Engine 720 with PFC3BXL and MSFC3256
WS-SUP32-GE-3BSupervisor Engine 32 with PFC3B and MSFC2A256
WS-SUP32-10GE-3BSupervisor Engine 32 with PFC3B and MSFC2A256
HTH Regards Santhosh Saravanan
VIP Purple

Re: HSRP in 3550 switch

In each VLAN you have two routers which can act as the default-gateway for the clients. For HSRP to work both gateways use the same ID to monitor if the other gateway is available. If the primary gateway is not available any more the gateway with the next priority takes over. The role primary/secondary/third etc. is controlled by the priority. These parameters are only local to the interface. VLAN 100 doesn't care about the settings of VLAN 110.

Two (or even more) IDs on one interface are used when you want to share the traffic among your gateways. The group 1 for example has the standby IP 10.10.10.1 and the second group has the standby IP 10.10.10.2. Now you configure the group1 with a higher and group2 with a lower priority. Half of your clients use 10.10.10.1 as the default gateway and the other half use 10.10.10.2. With that both gateways forward traffic to the rest of the network.

Some links for more information:

http://en.wikipedia.org/wiki/HSRP

Edit: And a very good point of Santhoshkumar ... The 3550 also only supports 16 HRSP-groups. So with many VLANs you have to reuse the same group-ID on multiple interfaces.

-- 
Don't stop after you've improved your network! Improve the world by lending money to the working poor:
http://www.kiva.org/invitedby/karsteni


--
Don't stop after you've improved your network! Improve the world by lending money to the working poor: http://www.kiva.org/invitedby/karsteni
New Member

HSRP in 3550 switch

its now working......

Thanks

Debabrata

208
Views
0
Helpful
10
Replies
CreatePlease login to create content