Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

HSRP Migration to VSS with 0 Downtime

I have to migrate two Cat6K series switches in a Data center to the new Cisco 6509 Series switches with no downtime.

I know there are few threads on the same topic but none of them discuss about the downtime.

The two Old Cat6K series switches are working in HSRP redundant mode. All access/Dist switches are dual homed to these two switches in downlink direction.

In the uplink direction a router is dual homed to both Switches.

Now my requirement is to completely migrate the configuration from the old switches to the new one in VSS mode without any downtime. Already VTP server is running on of the old switches so VLAN migration is not an issue. Can any one guide how should i proceed with the migration. I will update the network diagram in few hours .As per now i am going to follow these steps:

1. Remove active links from switch 1 and shut it down

2. Monitor network and traffic impact on switch 2

3. Install the new 6509 switch along with switch 2 (VSS config already done in Staging)

4. Config HSRP and make it standby

5. Connect all removed links back to new switch

6. Remove old switch 2 and monitor network

7. Connect new switch with VSS config

8. Connect the two new switches together in VSS and move virtual IP to SVI.

During last step i think i will face some minor packet drops. I will appreciate suggestions/comments to optimize these steps. TY

3 REPLIES
Cisco Employee

HSRP Migration to VSS with 0 Downtime

New Member

HSRP Migration to VSS with 0 Downtime

Thanks a lot Mattew for your response, I just want to clear this point :

11. b:

  • In VSS, both active and standby chassis use active chassis burnt-in MAC address and VLAN IP address. HSRP is no longer required.

    • Move HSRP virtual IP addresses to the VLAN interfaces.

    • Remove HSRP configuration from the VLAN interfaces.

    Initial Configuration
    interface Vlan10
     ip address 10.1.1.2 255.255.255.0
     standby 10 ip 10.1.1.1
     standby 10 priority 110
    !
    interface Vlan20
     ip address 20.1.1.2 255.255.255.0
     standby 20 ip 20.1.1.1
     standby 20 priority 110
    !
    Configuration Changes
    VSS(config)# interface Vlan10
    VSS(config-if)# no standby 10 ip 10.1.1.1
    VSS(config-if)# no standby 10 priority 110
    VSS(config-if)# ip address 10.1.1.1 255.255.255.0
    VSS(config-if)# interface Vlan20
    VSS(config-if)# no standby 20 ip 20.1.1.1
    VSS(config-if)# no standby 20 priority 110
    VSS(config-if)# ip address 20.1.1.1 255.255.255.0

    Note: End devices would be still pointing their ARP entries to  initial HSRP MAC address. Until these entries time out or another ARP  is sent to update their cache, there is some connectivity loss.

  • What i need to know is at the same time, Old Dist Switch is active with the virtual IP where as new VSS Switch has the same IP on SVI. Will it not impact at all on the network before we check the connectivity and bring down the Old Dist SW 1?

    Also can any one tell me briefly how connectivity can be checked from new VSS switch to Access/Core Layer with same IP as Old Standalone Dist SW 1 ?

    New Member

    I disagree with the hsrp

    I disagree with the hsrp approach. II feel it buys no benefit. It provides no downtime. Once the migration is complete, you still have to reconfigure the SVIs, remove hsrp, and add the .1 back on, which is an outage.

    Why not just do all your L2 first, then shutdown each svi on the old distrbution switch and bring it up on the new VSS switch. Done and Done.
    The SVIs on the VSS will be shutdown until you are ready to bring it up.

    That is how I did a 6509 to Nexus Migration (although Nexus isn't VSS, and I probably could've leveraged hsrp to minimize downtime.

     

    Can anyone show the benefit of using hsrp to minimize downtime or 0 downtime. Based on this thread, it doesnt appear so.

    2592
    Views
    0
    Helpful
    3
    Replies
    CreatePlease to create content