Cisco Support Community
Showing results for 
Search instead for 
Did you mean: 
Community Member

HSRP msec timers


I have some serious issues using HSRP msec timers. I tried HSRP, HRSP v2 and GLBP ; all the same results

Actual : IOS 12.2(33)SXH

Old : IOS 12.2(18)SXF8

No physical problems, no errors on the interfaces, no STP problems (no redundant links) I tried to remove the port-channel, shutdown one of the two links and had the same symptoms...

The setup is simple, two 6506 + sup720 3B + 2GB port-channel between the two GB ports on each sup.

When I try to use anything less than 50 msec for hello and 150 msec for holddown I have a convergence the minute I do something ; anything like even "wr mem"

After debugging I see that the HSRP standby is not able to receive any hello from the HSRP active router each and every time the cpu is occupied (not 100% but 5% or more)

Thanks for any help, for now the timers are set at 250 msec for hello and 750 msec for holddown and everything seems ok.

Why with HSRP v2 the lowest value for hello is 15 msec when 50 msec is not even stable? I tried with 15 msec... disaster!

Community Member

Re: HSRP msec timers


If you use HSRPv1 you need to set the millisecond timers in all routers.Hope you did that.

I found a tip from

Some HSRP state flapping can occasionally occur if the holdtime is set to less than 250 milliseconds,

and the processor is busy. It is recommended that holdtime values less than 250 milliseconds be used on

Cisco 7200 platforms or better, and on Fast-Ethernet or FDDI interfaces or better.

Hope this helps you.



Community Member

Re: HSRP msec timers

Thanks Nambi,

Yes, of course the timers where set in both routers! I also tried 100 ms and 300 ms with the same kind of results. I don't know if it's another configuration related to multicast or if it's simlpy an hardware limitation...

Anyway, if I find something I will let you guys know!


CreatePlease to create content