Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

HSRP not switching over

Hi,

I have two routers running HSRP between them. On the higher priority router, I?m tracking some objects and when the track goes down, I want the router to switch over to the backup. The downed track is being detected by the active router and is communicated to the backup, but the backup never becomes active. Heres the log from the routers (A and B), as well as the relevant HSRP config. Any tips will be most wellcomed:

A:

interface FastEthernet0/0

description LAN Ruteador A Navega

ip address 10.48.96.66 255.255.255.224

ip nat inside

ip route-cache flow

duplex auto

speed auto

standby 1 ip 10.48.96.65

standby 1 timers 15 20

standby 1 priority 110

standby 1 preempt delay minimum 600

standby 1 track 220 decrement 20

!

Oct 2 10:06:35.890: Track: 130 Change #2630 rtr 130, state Up->Down

Oct 2 10:06:36.866: Track: 220 Change #2417 list, boolean and Up->Down(->10)

Oct 2 10:06:36.866: HSRP: Fa0/0 Grp 1 Track 220 object changed, state Up -> Down

Oct 2 10:06:36.866: HSRP: Fa0/0 Grp 1 Priority 110 -> 90

Oct 2 10:06:40.890: Track: 130 Change #2631 rtr 130, state Down->Up

Oct 2 10:06:41.866: Track: 220 Change #2418 list, boolean and Down->Up(->20)

Oct 2 10:06:41.866: HSRP: Fa0/0 Grp 1 Track 220 object changed, state Down -> Up

Oct 2 10:06:41.866: HSRP: Fa0/0 Grp 1 Priority 90 -> 110

Oct 2 10:38:35.946: Track: 130 Change #2638 rtr 130, state Up->Down

Oct 2 10:38:36.914: Track: 220 Change #2425 list, boolean and Up->Down(->10)

Oct 2 10:38:36.914: HSRP: Fa0/0 Grp 1 Track 220 object changed, state Up -> Down

Oct 2 10:38:36.914: HSRP: Fa0/0 Grp 1 Priority 110 -> 90

Oct 2 10:38:40.946: Track: 130 Change #2639 rtr 130, state Down->Up

Oct 2 10:38:41.914: Track: 220 Change #2426 list, boolean and Down->Up(->20)

Oct 2 10:38:41.914: HSRP: Fa0/0 Grp 1 Track 220 object changed, state Down -> Up

Oct 2 10:38:41.914: HSRP: Fa0/0 Grp 1 Priority 90 -> 110

Oct 2 10:38:55.946: Track: 130 Change #2640 rtr 130, state Up->Down

Oct 2 10:38:56.914: Track: 220 Change #2427 list, boolean and Up->Down(->10)

Oct 2 10:38:56.914: HSRP: Fa0/0 Grp 1 Track 220 object changed, state Up -> Down

Oct 2 10:38:56.914: HSRP: Fa0/0 Grp 1 Priority 110 -> 90

Oct 2 10:39:00.946: Track: 100 Change #7631 rtr 1, state Up->Down

Oct 2 10:39:00.946: Track: 130 Change #2641 rtr 130, state Down->Up

Oct 2 10:39:01.914: Track: 220 Change #2428 list, boolean and Down->Up(->20)

Oct 2 10:39:01.914: HSRP: Fa0/0 Grp 1 Track 220 object changed, state Down -> Up

Oct 2 10:39:01.914: HSRP: Fa0/0 Grp 1 Priority 90 -> 110

B:

!

interface FastEthernet0/0

ip address 10.48.96.67 255.255.255.224

ip nat inside

duplex auto

speed auto

standby preempt

standby 1 ip 10.48.96.65

standby 1 preempt delay minimum 5

!

Oct 2 10:06:40.261: HSRP: Fa0/0 Grp 1 Standby: h/Hello rcvd from lower pri Active router (90/10.48.96.66)

Oct 2 10:06:40.261: HSRP: Fa0/0 Grp 1 Starting minimum preempt delay (5 secs)

Oct 2 10:06:55.261: HSRP: Fa0/0 Grp 1 Standby: g/Hello rcvd from higher pri Active router (110/10.48.96.66)

Oct 2 10:06:55.261: HSRP: Fa0/0 Grp 1 Stopping minimum preempt delay

Oct 2 10:38:40.299: HSRP: Fa0/0 Grp 1 Standby: h/Hello rcvd from lower pri Active router (90/10.48.96.66)

Oct 2 10:38:40.299: HSRP: Fa0/0 Grp 1 Starting minimum preempt delay (5 secs)

Oct 2 10:38:55.300: HSRP: Fa0/0 Grp 1 Standby: g/Hello rcvd from higher pri Active router (110/10.48.96.66)

Oct 2 10:38:55.300: HSRP: Fa0/0 Grp 1 Stopping minimum preempt delay

4 REPLIES
Hall of Fame Super Silver

Re: HSRP not switching over

Eduardo

I am slightly puzzled about some differences in the time stamps from the first router as compared to the second router. But I believe that looking at the log records from the first router will help explain what is happening and why the standby router does not become active.

The first tracking change started at 10:06:36:866 and at 10:06:41:866 the original priority was restored (note the length of 5 seconds). The next track lowering of priority began at 10:38:36:914 and the original priority was restored at 10:38:41:914 (again a 5 second length). The third track lowering of priority was at 10:38:56:914 and the original priority was restored at 10:39:01:914 (again a 5 second interval).

So what appears to be happening is that the tracked interface goes down, stays down 5 seconds, and comes back. The backup router is configured to delay 5 seconds before taking control, and each time the primary track restored the original priority before the delay expired on the backup router.

HTH

Rick

New Member

Re: HSRP not switching over

Thanks for your answer.

And yes, the track that triggers the switchover is 220 (a composite or). My doubt is this: the ping is supposed to be sent every 10 seconds, with a default timeout of 2secs. Theoretical question..why am I getting a reply (with the track=up), before it sends out another ping, or receives a reply? I was under the impression that once the track was detected, the switchover began when the next hello was received from a lower priority router...and the B router, start the preempt delay, 5 secs, and after it expires, it waits another 10 secs before stopping the minimum preempt delay...Should it not have started the switchover right after the min delay expired? It seems that the B router is doing nothing for 10 secs., between the expiration of the preempt delay and receiving the next hello...

regards,

Eduardo

Re: HSRP not switching over

Could you please do a show standby on each router.

I think this is not working because you have changed the timers on one partner but not on the other. Router B has a hello time of 3 seconds and a hold time of 10 seconds, but router A has a hello of 15 seconds and a hold of 20. That will be confusing them. The switchover is proably not happening because router B is losing sight of the Hello from router A.

I would suggest you remove your standby timers commanbd from router A and see where that leaves you.

In fact, I would remove the preempt delay until you have the switchover working properly.

You also have a preempt on group 0 which seems to be unnecessary.

Kevin Dorrell

Luxembourg

New Member

Re: HSRP not switching over

Thanks for the tips. I will look into them. Router B is learning the timers from the active router, so configuring them explicitly in not necessary, I think.

For the mean time, here are the Sh stand:

R_A#sh stand

FastEthernet0/0 - Group 1

State is Active

294 state changes, last state change 4d12h

Virtual IP address is 10.48.96.65

Active virtual MAC address is 0000.0c07.ac01

Local virtual MAC address is 0000.0c07.ac01 (v1 default)

Hello time 15 sec, hold time 20 sec

Next hello sent in 4.912 secs

Preemption enabled, delay min 3600 secs

Active router is local

Standby router is 10.48.96.67, priority 100 (expires in 15.724 sec)

Priority 110 (configured 110)

Track object 220 state Up decrement 20

IP redundancy name is "hsrp-Fa0/0-1" (default)

R_A#

R_B#sh stand

FastEthernet0/0 - Group 1

State is Standby

300 state changes, last state change 4d12h

Virtual IP address is 10.48.96.65

Active virtual MAC address is 0000.0c07.ac01

Local virtual MAC address is 0000.0c07.ac01 (v1 default)

Hello time 15 sec, hold time 20 sec

Next hello sent in 3.096 secs

Preemption enabled, delay min 5 secs

Active router is 10.48.96.66, priority 110 (expires in 17.284 sec)

Standby router is local

Priority 100 (default 100)

IP redundancy name is "hsrp-Fa0/0-1" (default)

R_B#

208
Views
0
Helpful
4
Replies