Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

HSRP not working

i configured HSRP on my both 6500 switches, but its still not working, i need help here please here is the output

Router#show standby

FastEthernet4/48 - Group 1

Local state is Active, priority 51, may preempt

Hellotime 3 holdtime 10

Next hello sent in 00:00:02.758

Virtual IP address is 1.1.1.1 configured

Active router is local

Standby router is 1.1.1.2 expires in 00:00:07

Standby virtual mac address is 0000.0c07.ac01

1 state changes, last state change 00:18:54

Tracking interface states for 1 interface, 1 up:

Up FastEthernet4/13

interface FastEthernet4/48

ip address 1.1.1.3 255.255.255.0

no ip redirects

standby 1 priority 51 preempt

standby 1 ip 1.1.1.1

standby 1 track Fa4/13

1 ACCEPTED SOLUTION

Accepted Solutions

Re: HSRP not working

Friend,

You are missing the preempt command on the second router. The preempt command will make sure the standby takes over the control when the primary is active but the priority is reduced.

If the preempt is not configured, then eventhough the priority becomes low, the standby will not take the active role as long as it is receiving hellos from the active one.

configure "standby preempt" in the second router and let us know how it goes

HTH, rate if it does

Narayan

7 REPLIES
New Member

Re: HSRP not working

from above all looks good - what is the problem ?

New Member

Re: HSRP not working

when i turn off the active router.. the second doesnt go ACTIVE.. or when i remove one of the tracked interfaces.. please help me.. 2 days i'm working on this and its not working

Bronze

Re: HSRP not working

Hi,

To help you we need the output of you second router.

Have you tries to configure standby 1 mac ?

BR,

Bjornarsb

Purple

Re: HSRP not working

You will have to post the configs of both routers and indicate which interfaces they are connected together with . All this really tells us is you have configured hsrp on one side , need more information .

New Member

Re: HSRP not working

Dear Sir, sorry for being late on you, i attached to you the configuration from the 2 switches, you can see on the second switch, thats it having higher priority but its not becoming active. if i pulled the 4/48 cable physically out and then in to the port immediately, it becomes the active one !! i really appreciate your help.

Re: HSRP not working

Friend,

You are missing the preempt command on the second router. The preempt command will make sure the standby takes over the control when the primary is active but the priority is reduced.

If the preempt is not configured, then eventhough the priority becomes low, the standby will not take the active role as long as it is receiving hellos from the active one.

configure "standby preempt" in the second router and let us know how it goes

HTH, rate if it does

Narayan

New Member

Re: HSRP not working

Thank you so much for your help.

143
Views
0
Helpful
7
Replies
CreatePlease login to create content