Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
You may experience some slow load times, errors, and slight inconsistencies. We ask for your patience as we finalize the launch. Thank you.

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

HSRP on BVI Interface

Dears

Would like your assistance please regarding below scenario

I have a server with two tagged L2 uplinks terminated on two 802.1q subinterfaces @ 2800 routers as shown in below diagram

I wish to run HSRP between both routers but as you know neither SVI nor L2 interfaces are supported on low end routers unless there is switching module inserted in router

BVI.JPG

What I have been thinking of is to use integrated bridging (irb) where to bridge both interfaces fa0/0 & fa0/1 and run HSRP on bvi interface

I did this but unfortunately HSRP was not working !

Thanks to share your comments

R1#sh standby brief

                    P indicates configured to preempt.

                    |

Interface  Grp  Pri P State  Active          Standby        Virtual IP

BV100      100  120  Active  local          unknown        100.0.0.254

R1#

_________________
Below are the configurations

R1

bridge irb

interface FastEthernet0/0

no ip address

!

interface FastEthernet0/0.1

encapsulation dot1Q 100

bridge-group 100

!

interface FastEthernet0/1

no ip address

bridge-group 100

!

interface BVI100

ip address 100.0.0.1 255.255.255.0

standby 100 ip 10.0.0.254

standby 100 priority 120

||||

R2

bridge irb

interface FastEthernet0/0

no ip address

!

interface FastEthernet0/0.1

encapsulation dot1Q 100

bridge-group 100

!

interface FastEthernet0/1

no ip address

bridge-group 100

!

interface BVI100

ip address 100.0.0.2 255.255.255.0

standby 100 ip 10.0.0.254

Thanks
Sherif Ismail
  • LAN Switching and Routing
Everyone's tags (2)
3 REPLIES
Gold

HSRP on BVI Interface

Hi Sherif,

when you enable routing on the BVI, packets that come in on a routed interface, are taken care by the L3 BVI and in your design, there is no Layer 3 interface except for the BVI itself. BVI is a bridge between routed and bridge domain. i dont think BVI alone can do much here.

and one other thing, with regards to the diagram, you have ur sever connected to both routers, why HSRP then?

Hope it Helps,

Soroush.

Hope it Helps, Soroush.

HSRP on BVI Interface

Hi Soroush

mmm ... I believe my configuration is similar to below one except that mine have HSRP

http://cisconet.com/lanman/lan-general/552-how-to-configure-irbintegrated-routing-and-bridging.html

Can you advise an example with BVI HSRP or explain how HSRP messages will follow between both routers

Many Thanks

Sherif Ismail

Gold

HSRP on BVI Interface

Sherif, in the url u sent, there are 2 bridge ports setup PC1 and 2, and one routed port setup for PC3, so its not the same.

with regards to ur configuration, u made a switch out of ur routers. besides... if this is the exact physical setup? why do u want hsrp?

when you set HSRP, one router takes control as active and the other one as standby, so there is only one router active at a time! members of a hrsp group continuesly exchange messages, so if the active went out, the standby takes control.

but for this setup u have i dont see a reason and possibility for a HSRP env.

u might find this useful:

http://www.cisco.com/en/US/tech/tk648/tk362/technologies_tech_note09186a0080094a91.shtml#background

Hope it Helps,

plz Rate if it helped.

Soroush.

Hope it Helps, Soroush.
824
Views
0
Helpful
3
Replies