Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

HSRP on trunk

Hi,

can I configure HSRP from two router with only one inteface ethernet for each so that I have to use trunk 802.1q (Vlan) ?

Does anyone advice me one a document about ?

Best regards

Lorenzo

4 REPLIES

Re: HSRP on trunk

You can configure hsrp per vlan, using and instances of the stand by like this.

interface FastEthernet0/0.1

encapsulation dot1Q 1 native

ip address 10.6.1.252 255.255.255.0

no ip redirects

ip nbar protocol-discovery

ip policy route-map internet-corp

standby use-bia scope interface

standby 51 ip 10.6.1.254

standby 51 priority 210

standby 51 preempt

standby 51 track Serial0/0.18 150

!

interface FastEthernet0/0.2

encapsulation dot1Q 2

ip address 10.6.2.252 255.255.255.0

no ip redirects

ip nbar protocol-discovery

standby use-bia scope interface

standby 52 ip 10.6.2.254

standby 52 priority 110

standby 52 preempt

interface FastEthernet0/0.3

encapsulation dot1Q 3

ip address 10.6.3.252 255.255.255.0

no ip redirects

ip nbar protocol-discovery

standby use-bia scope interface

standby 53 ip 10.6.3.254

standby 53 priority 210

standby 53 preempt

standby 53 track Serial0/0.18 150

don't forget qualify me.

Hall of Fame Super Silver

Re: HSRP on trunk

Hello,

correct example

just a little explanation you need to use different HSRP group number on the vlan subintefaces. This derives from the Cisco implementation on Cisco routers that don't retain the vlan tag to decide to what HSRP instance a received HSRP packet belongs.

Using the same group address will produce an error message.

hope to help

Giuseppe

Hall of Fame Super Silver

Re: HSRP on trunk

Hello,

I just wanted to explain why we need to use different group numbers the example is correct.

best regards

Giuseppe

New Member

Re: HSRP on trunk

Hi Giuseppe,

I want show you the configuration of my two

routers HSRP with trunk for Vlans.

Can it work in order ?

best regards

Lorenzo

Cisco 1800

interface FastEthernet0/0

no ip address

duplex auto

speed auto

interface FastEthernet0/0.1

encapsulation dot1Q 1 native

ip address 192.168.19.253 255.255.255.0

standby 1 ip 192.168.19.254

standby 1 priority 105

standby 1 preempt

standby 1 track serial0/0

interface FastEthernet0/0.2

encapsulation dot1Q 2

ip address 172.16.19.3 255.255.255.0

standby 2 ip 172.16.19.1

standby 2 priority 100

standby 2 preempt

standby 2 track serial0/0

Cisco 2600

interface FastEthernet0/0

no ip address

duplex auto

speed auto

interface FastEthernet0/0.1

encapsulation dot1Q 1 native

ip address 192.168.19.252 255.255.255.0

standby 1 ip 192.168.19.254

standby 1 priority 100

standby 1 preempt

standby 1 track serial0/0

interface FastEthernet0/0.2

encapsulation dot1Q 2

ip address 172.16.19.4 255.255.255.0

standby 2 ip 172.16.19.1

standby 2 priority 105

standby 2 preempt

standby 2 track serial0/0

828
Views
17
Helpful
4
Replies
CreatePlease to create content