Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Hsrp on two cat3750 routed port facing Nexus router with HSRP

Hi there,

 

I want to have HSRP configured in my two cat 3750 routed port, the routed ports are connected to two Nexus router also running HSRP.

 

Is it possible with this kind of set up?

 

I tried configuring HSRP on each router port of the L3 switch, but when i tried running "sh standby" or "sh standby brief" both are in "Active State". what connection should  I have between switches to make HSRP work on routed ports.

 

server (vlan 10) -----------------Switch 1 and switch 2  

                            

Server (vlan 20)------------------Switch 1 and switch 2                      Switch 1(hsrp)----------------Nexus1 (hsrp)

                                                                                                             Switch 2(hsrp)----------------Nexus2 (hsrp)

Server (vlan 30)-----------------Switch 1 and switch 2  

 

My goal is to use 3750 as layer 2 for the servers and layer 3 when uplink going to router with hsrp on switches facing hsrp on nexus.

 

IP's

x.x.x.0/29 -----network

x.x.x.1 -------VIP nexus

x.x.x.2 -------Nexus 1 ip

x.x.x.3 -------Nexus 2 ip

x.x.x.4 -------Switch 3750 VIP

x.x.x.2 -------Switch 1 ip

x.x.x.3 -------Switch 2 ip

x.x.x.5 ----broadcast address

 

Note: I only handle the configuration for the two 3750 switches. 

 

Everyone's tags (1)
5 REPLIES
Bronze

keep in mind that to use hsrp

keep in mind that to use hsrp you need have the same layer 2 domain across switches. So you need to have a switchport interface at some point, unless if have a switch stack and VPC on Nexus you can do a L3 Port-channel

New Member

I tried trunking between two

I tried trunking between two switches. Still both Active in HSRP, and Standby router is unknown

Bronze

you are missing something,

you are missing something, can you post the config from both switches?

New Member

@switch 1 !!interface

@ Switch-1
!
interface FastEthernet0/1

switchport trunk encapsulation dot1q
switchport mode trunk
!
interface FastEthernet0/2
no switchport
ip address 1.1.1.2 255.255.255.0
duplex auto
speed auto
standby version 2
standby 1 ip 1.1.1.1
standby 1 priority 110
!

Sw-1(config)#
Sw-1#
%SYS-5-CONFIG_I: Configured from console by console

Sw-1#
Sw-1#
Sw-1#sh stand
FastEthernet0/2 - Group 1 (version 2)
State is Active
4 state changes, last state change 00:05:28
Virtual IP address is 1.1.1.1
Active virtual MAC address is 0000.0C9F.F001
Local virtual MAC address is 0000.0C9F.F001 (v2 default)
Hello time 3 sec, hold time 10 sec
Next hello sent in 2.946 secs
Preemption disabled
Active router is local
Standby router is unknown
Priority 110 (configured 110)
Group name is hsrp-Fa0/2-1 (default)
Sw-1#

@Switch-2

!
interface FastEthernet0/1
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface FastEthernet0/2
no switchport
ip address 1.1.1.3 255.255.255.0
duplex auto
speed auto
standby version 2
standby 1 ip 1.1.1.1
!
interface FastEthernet0/3

Sw-2#sh stand
FastEthernet0/2 - Group 1 (version 2)
State is Active
4 state changes, last state change 00:05:29
Virtual IP address is 1.1.1.1
Active virtual MAC address is 0000.0C9F.F001
Local virtual MAC address is 0000.0C9F.F001 (v2 default)
Hello time 3 sec, hold time 10 sec
Next hello sent in 2.669 secs
Preemption disabled
Active router is local
Standby router is unknown
Priority 100 (default 100)
Group name is hsrp-Fa0/2-1 (default)
Sw-2#


Both fa0/2 of switches are directly connected to nexus router (HSRP)

 

Bronze

with that config you are

with that config you are isolating both switches.

Use config below:

@Switch-1

vlan 2000

name INTER_NEXUS

interface vl2000
ip address 1.1.1.2 255.255.255.0
duplex auto
speed auto
standby version 2
standby 1 ip 1.1.1.1
standby 1 priority 110

interface FastEthernet0/2

switchport

switchport mode access

switchport access vl 2000

switchport spann portfast

spann portfast bpduguard enable

 

 

@Switch-2

!

vlan 2000

name INTER_NEXUS
interface vl2000

ip address 1.1.1.3 255.255.255.0
duplex auto
speed auto
standby version 2
standby 1 ip 1.1.1.1

interface FastEthernet0/2

switchport

switchport mode access

switchport access vl 2000

switchport spann portfast

spann portfast bpduguard enable

114
Views
0
Helpful
5
Replies