Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

HSRP over dot1q

Is it possible to run HSRP over trunk? I have pair of Cisco 2620 and I'm trying to run HSRP with the following conifguration and without luck. Can someone tell me if it is doable or anything wrong in my config?

Thanks.

interface FastEthernet0/0

no ip address

ip pim sparse-dense-mode

no ip route-cache

no ip mroute-cache

speed 100

full-duplex

!

interface FastEthernet0/0.1

encapsulation dot1Q 101

ip address 192.168.215.62 255.255.255.224

no ip route-cache

no ip mroute-cache

standby 1 ip 192.168.215.33

standby 1 priority 110

standby 1 preempt

standby 1 track Serial0/0

!

interface FastEthernet0/0.2

encapsulation dot1Q 102

ip address 192.168.215.189 255.255.255.192

ip pim sparse-dense-mode

no ip route-cache

no ip mroute-cache

standby 2 ip 192.168.215.129

standby 2 priority 110

standby 2 preempt

standby 2 track Serial0/0

!

interface FastEthernet0/0.3

encapsulation dot1Q 103

ip address 192.168.216.125 255.255.255.128

ip pim sparse-dense-mode

no ip route-cache

no ip mroute-cache

standby 3 ip 192.168.216.1

standby 3 priority 110

standby 3 preempt

standby 3 track Serial0/0

12 REPLIES
Purple

Re: HSRP over dot1q

Config looks ok. How is it connected to the other hsrp device ? Yes it will work over a trunk .

New Member

Re: HSRP over dot1q

Int fa0/0 is connected to a 2948 siwtch as trunk, another 2620 is hanging off that switch on vlan 101. I'm also running multicast when I treid to activate HSRP, my multicast didn't work and i was able to failover only vlan 101. Any other suggestions?

Bronze

Re: HSRP over dot1q

There is an issue when using multicast in an HSRP environment. Care must be used in configuring multicast with the physical IP address as opposed to the HSRP logical address as the IP Address. If the HSRP address is used, multicast traffic will not be sent. Why Doesn't PIM Sparse Mode Work with a Static Route to an HSRP Address

http://www.cisco.com/en/US/tech/tk828/technologies_tech_note09186a0080094aab.shtml

Purple

Re: HSRP over dot1q

You would have to have the same trunk setup going to the other 2620 to have it work from the 2948 . It won't work if you only have a single vlan going to the other 2620. Set your subinterfaces the same way as the the router you posted and make the link to the 2948 a trunk .

Re: HSRP over dot1q

what Glen is saying is the following:

2620A fa0/0---.1Q---2948---.1Q---fa0/0 2620B

From you description above you have the other 2620 connected to a vlan 101 access port on 2948. BOTH ports connecting to the 2620s will need to be trunked. The config on one router looks good.

New Member

Re: HSRP over dot1q

My trunk set up is identical on both routers on each side. Only think I'm lacking is the dynamic routing as crow930us suggested. I wil go ahead and turn the ospf on and see if that makes any difference. I will keep you guys posted. Thanks you all for help.

Purple

Re: HSRP over dot1q

How are the 2948 links setup for trunking ?

New Member

Re: HSRP over dot1q

connected as trunk with the following config:

set trunk 2/1 nonegotiate dot1q 1-1005,1025-4094

Topology look like this:

hosts-2948--trunk--2620A1--serial--2620A2-trunk--2948

hosts-2948--trunk--2620B1---serial----2620B2--truank--2948

Re: HSRP over dot1q

the HSRP hellos are not routed. Which of the routers are doing the hsrp? is it between 2620A1 and 2620A2? can you post the show standby output from both of the routers and show cdp neigh. The topology above seems to suggest that you are running gateway redundnacy between two routers that is separated by a wan link, serial interface.

New Member

Re: HSRP over dot1q

You are right, I'm running gateway redundnacy between two routers that is separated by a wan link, serial interface. I will have to enable the link tover the weekend and will post you the show standby.

Re: HSRP over dot1q

HSRP between routers separated by a wan link will not work, for one thing you will need to bridge your dot1q subinterface to the serial interfaces so that the hrsp on both routers will see each other. In addition, think aobut what you are doing here, if a user in 2620A1 needs to talked to anther user in another vlan that happens to be local to 2620A1, and hsrp is active on 2620A2, it will need to forward that traffic across the serial link to the active hsrp then back out to serial interface, not a very efficient way to forward a packet.

New Member

Re: HSRP over dot1q

I have similar production environment with the exception of multicast and it is working fine for years, I'm just not able to make multicast work over the HSRP. My goal is to make 2620A1,2620A2 as an active pair and 2620B1 and 2620B2 a passive pair while tracking the serial interface I don' know if you call it "HSRP between routers separated by a wan link "

1058
Views
0
Helpful
12
Replies