Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

HSRP Problem with Cisco 1941

Hi,

We are having 2 Cisco 1941 routers running as primary & secondary connection.

We have configured HSRP on both routers, but the HSRP state on both routers shows Active & Standby Unknown.

R1#sh standby gi0/1 brief

                     P indicates configured to preempt.

                     |

Interface   Grp  Pri P State   Active          Standby         Virtual IP

Gi0/1       22   109 P Active  local           unknown         192.168.252.20

R2#sh standby gi0/1 brief

                     P indicates configured to preempt.

                     |

Interface   Grp  Pri P State   Active          Standby         Virtual IP

Gi0/1       22   105 P Active  local           unknown         192.168.252.20

below is the configuration for the interface Gi0/1 on both routers..

R1#sh run int gi0/1

interface GigabitEthernet0/1

ip address 192.168.252.21 255.255.255.0

standby 22 ip 192.168.252.20

standby 22 timers 1 3

standby 22 priority 109

standby 22 preempt delay minimum 300

standby 22 authentication Auth22

standby 22 track 1 decrement 10

ip ospf message-digest-key 1 md5 7 070C706E49

ip ospf cost 11

duplex auto

speed auto

end

R2#sh run int gi0/1

interface GigabitEthernet0/1

ip address 192.168.252.22 255.255.255.0

standby 22 ip 192.168.252.20

standby 22 timers 1 3

standby 22 priority 105

standby 22 preempt delay minimum 300

standby 22 authentication Auth22

standby 22 track 1 decrement 10

ip ospf message-digest-key 1 md5 7 011057265C

ip ospf cost 11

duplex auto

speed auto

end

OSPF key is same on both router.

Can anyone please help me to solve this problem?

Thanks.

2 REPLIES
New Member

HSRP Problem with Cisco 1941

Have you verfied that the layer3 interfaces can actually communicate with each other? Are you using a seperate switch to connect the two routers?

Silver

HSRP Problem with Cisco 1941

Yes, this is a common problem where both routers can't see each other so they both declare themselves to be master. Verify that the router interfaces are in the same VLAN.

737
Views
0
Helpful
2
Replies
CreatePlease login to create content