Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

HSRP Problem with Trunking

Hi, I have two 7206VXR routers running IOS 12.4(15)T6. Each 7206 has a connection to a 3750G switch. On the switches I trunking VLAN 1 adn 199.

On the routers, I have configured subinterface G0/2.199 and I'm running HSRP. When I configured this the first time the HSRP was fine, I was able to ping both ways and there were "hello" packets going across.

7206(1)--------------- 7206(2)

   |                         |

   |trunk(1,199)        |trunk (1,199)

   |                         |

3570-------------------3750

        trunk(1,199)

The problem that I have is that after the 7206(1) reloads it shows the subinterface G0/2.199 up/up but the HSRP state is in "Init (interface down)". I have to manually shutdown and the "no shut" the subinterface g0/2.199 and then it comes right up. Has anybody seen anything like this?

7206(1)#sh stand
GigabitEthernet0/2.199 - Group 199
  State is Init (interface down)
  Virtual IP address is 192.168.242.131
  Active virtual MAC address is unknown
    Local virtual MAC address is 0000.0c07.acc7 (v1 default)
  Hello time 3 sec, hold time 10 sec
  Preemption enabled
  Active router is unknown
  Standby router is unknown
  Priority 105 (configured 105)
    Track object 2 state Up decrement 10
  Group name is "hsrp-Gi0/2.199-199" (default)

4 REPLIES
Hall of Fame Super Blue

Re: HSRP Problem with Trunking


You are tracking an interface, what is the state of that interface when the HSRP is init.

Also can you ping from the subinterface to the subinterface on the other router and what do the cam tables show on the 3750 switches ?

Jon

New Member

Re: HSRP Problem with Trunking

Hi Jon.

The interface that I'm tracking is UP and it shows "up" when the HRSP is in the "init" state. Also, I'm able to ping between the two routers via the subinterfaces.

Thanks,

Gus

Purple

Re: HSRP Problem with Trunking

  Can you post the interface configs from both sides , it would help .  Also check to make sure the native vlan is set the same  for  all interfaces ...  If the hsrp is not working you do not have a path thru the 3750 from one 7206 to the other .

New Member

Re: HSRP Problem with Trunking

Hi Glen,

Thanks for the reply.

This is the weird thing, I do have a path through the 3750G switches or else I wouldn't be able to ping the other router's subinterface, besides the HSRP on router 1 should've gone into "active" state instead of "Init (interface down). Here is a piece of configuration from each device. Thanks again for the help.

Router 1

track 2 interface Hssi1/0.700 line-protocol

interface GigabitEthernet0/2
ip address 192.168.240.66 255.255.255.240
duplex auto
speed 1000
media-type rj45
!
interface GigabitEthernet0/2.199
encapsulation dot1Q 199
ip address 192.168.242.129 255.255.255.240
standby 199 ip 192.168.242.131
standby 199 priority 105
standby 199 preempt
standby 199 track 2 decrement 10
!
interface Hssi1/0.700 point-to-point
bandwidth 12000
ip address 166.155.250.194 255.255.255.252
ip access-group security-hssi in
snmp trap link-status
frame-relay interface-dlci 700 IETF

<>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>

Router 2

interface GigabitEthernet0/2
ip address 192.168.240.67 255.255.255.240
duplex auto
speed 1000
  media-type rj45
!
interface GigabitEthernet0/2.199
encapsulation dot1Q 199
ip address 192.168.242.130 255.255.255.240
standby 199 ip 192.168.242.131
standby 199 preempt

<>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>

Switch 1

interface GigabitEthernet1/0/1
description ** Trunk to Router #1 **
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1,199
switchport mode trunk
no ip address
duplex full
speed 1000
!
interface GigabitEthernet1/0/24
description ** Trunk to Switch 2 **
switchport trunk encapsulation dot1q
switchport mode trunk
no ip address
no mdix auto

<>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>

Switch 2

interface GigabitEthernet1/0/1
description ** Trunk to Router #2 **
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1,199
switchport mode trunk
speed 1000
duplex full
!
interface GigabitEthernet1/0/24
description ** Trunk to Switch 1 **
switchport trunk encapsulation dot1q
switchport mode trunk

514
Views
0
Helpful
4
Replies
CreatePlease to create content