Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

HSRP - Question - Using same standby nr.

Hi,

I'm looking into changing the way we use HSRP in our network,

My Gold

I want to use standby 2 for all CUST1's SVI interfaces, and Standby 3 for all CUST2's SVI interfaces, and so on ...

Any recommendations ?? .. Is that the right way or ??

Snip of config.

interface vlan2

ip address 10.1.1.2 255.255.255.0

ip vrf forwarding CUST1

standby 2 preempt

standby 2 ip 10.1.1.1

!

interface vlan3

ip address 10.1.2.2 255.255.255.0

ip vrf forwarding CUST1

standby 2 preempt

standby 2 ip 10.1.2.1

interface vlan12

ip address 10.1.1.2 255.255.255.0

ip vrf forwarding CUST2

standby 3 preempt

standby 3 ip 10.1.1.1

!

interface vlan13

ip address 10.1.2.2 255.255.255.0

ip vrf forwarding CUST2

standby 3 preempt

standby 3 ip 10.1.2.1

Thanks in advance.

/Peter

2 ACCEPTED SOLUTIONS

Accepted Solutions

Re: HSRP - Question - Using same standby nr.

Hi Peter,

configuration looks absolutely fine, you should can also standby 2 times 5 15,standby 2 priority & standby 3 times 5 15,standby 3 priority, , so that your routers understands 1 as the ACTIVE router & the other as STANDBY.

hope this helps,

rate this post if it helps.

Cisco Employee

Re: HSRP - Question - Using same standby nr.

Hi Peter,

You can also think of having Customer 1 active on one L3 switch and Customer 2 active on second L3 switch by playing around with priority.

In this way all your customer 2 traffic will route through first router and all your customer 3 traffic will route through second router which will give you load balancing also and once any router goes down all traffic of both the cutsomer will start getting routed from available router.

You can have one router with high priority for vlan 2 and 3 on one router and on second router configure "standby priority " command with low priority and in same way for vlan 12 and vlan 13 configure second router with high priority and first router with low priority which will result in router 1 active for vlan 2 and vlan 3 and router 2 as standby for same vlan and vice versa for vlan 12 and vlan 13.

http://www.cisco.com/univercd/cc/td/doc/cisintwk/ics/cs009.htm#wp3551

HTH

Ankur

*Pls rate helpfull pot

3 REPLIES

Re: HSRP - Question - Using same standby nr.

Hi Peter,

configuration looks absolutely fine, you should can also standby 2 times 5 15,standby 2 priority & standby 3 times 5 15,standby 3 priority, , so that your routers understands 1 as the ACTIVE router & the other as STANDBY.

hope this helps,

rate this post if it helps.

Cisco Employee

Re: HSRP - Question - Using same standby nr.

Hi Peter,

You can also think of having Customer 1 active on one L3 switch and Customer 2 active on second L3 switch by playing around with priority.

In this way all your customer 2 traffic will route through first router and all your customer 3 traffic will route through second router which will give you load balancing also and once any router goes down all traffic of both the cutsomer will start getting routed from available router.

You can have one router with high priority for vlan 2 and 3 on one router and on second router configure "standby priority " command with low priority and in same way for vlan 12 and vlan 13 configure second router with high priority and first router with low priority which will result in router 1 active for vlan 2 and vlan 3 and router 2 as standby for same vlan and vice versa for vlan 12 and vlan 13.

http://www.cisco.com/univercd/cc/td/doc/cisintwk/ics/cs009.htm#wp3551

HTH

Ankur

*Pls rate helpfull pot

Re: HSRP - Question - Using same standby nr.

Hi

I think the original post was to confirm whether the same group number can be used for multiple HSRP interfaces.

The answer is yes. You can group 16 interfaces with a single HSRP group number.

The switch supports HSRP MAC addresses for up to 16 unique HSRP groups. Because each group address can be used on up to 16 Layer 3 interfaces, the maximum number of HSRP interfaces is 256

Each of the 16 HSRP MAC addresses can be used by 16 consecutive Layer 3 interfaces because each address is associated with a group of VLANs by using a 4-bit mask

For example, HSRP Group 1 might be assigned to interface VLANs 16 to 31, which equals the group maximum of 16 VLANs

See the link for more information

http://www.cisco.com/en/US/products/hw/switches/ps646/products_configuration_guide_chapter09186a00801cdf27.html#1044151

HTH, rate if it does

Narayan

118
Views
0
Helpful
3
Replies
CreatePlease login to create content