Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

HSRP: Standby ip x.x.x.x secondary

VLAN 10 below is configured on two Cat6500 switches. Layer 2 etherchannel is running between both switches.

Can anyone explain the multiple instances of standby ip x.x.x.x secondary under vlan 10.

Thanks,

Colm

interface Vlan10

ip address 134.226.102.3 255.255.255.0

no ip redirects

ip flow ingress

ip pim sparse-mode

standby ip 134.226.137.2

standby ip 134.226.100.1 secondary

standby ip 134.226.100.2 secondary

standby ip 134.226.101.1 secondary

standby ip 134.226.101.2 secondary

standby ip 134.226.102.2 secondary

standby ip 134.226.103.1 secondary

standby ip 134.226.103.2 secondary

standby ip 134.226.136.1 secondary

standby ip 134.226.136.2 secondary

standby ip 134.226.174.1 secondary

standby ip 134.226.174.2 secondary

standby ip 134.226.175.1 secondary

standby ip 134.226.175.2 secondary

standby ip 134.226.190.1 secondary

standby ip 134.226.190.2 secondary

standby ip 134.226.191.1 secondary

standby ip 134.226.191.2 secondary

standby priority 120

standby preempt

standby authentication notcisco

interface Vlan10

ip address 134.226.102.5 255.255.255.0

no ip redirects

ip flow ingress

ip pim sparse-mode

standby ip 134.226.137.2

standby ip 134.226.100.1 secondary

standby ip 134.226.100.2 secondary

standby ip 134.226.101.1 secondary

standby ip 134.226.101.2 secondary

standby ip 134.226.102.2 secondary

standby ip 134.226.103.1 secondary

standby ip 134.226.103.2 secondary

standby ip 134.226.136.1 secondary

standby ip 134.226.136.2 secondary

standby ip 134.226.174.1 secondary

standby ip 134.226.174.2 secondary

standby ip 134.226.175.1 secondary

standby ip 134.226.175.2 secondary

standby ip 134.226.190.1 secondary

standby ip 134.226.190.2 secondary

standby ip 134.226.191.1 secondary

standby ip 134.226.191.2 secondary

standby priority 110

standby preempt

standby authentication notcisco

3 REPLIES

Re: HSRP: Standby ip x.x.x.x secondary

They are the virtual addresses that the clients will use as their gateway.

HTH,

John

HTH, John *** Please rate all useful posts ***
Hall of Fame Super Silver

Re: HSRP: Standby ip x.x.x.x secondary

Hello Colm,

the secondary option is allowed to instruct the switch that the VIP of that group has to be associated to a secondary ip address.

However, I think that this configuration is wrong:

a)the device should have an ip address .... secondary configured to have it to work to provide a valid source for HSRP packets and to be able to advertise the subnet.

b) I think different HSRP group numbers should be used

I think the right configuration should be something like:

int vlan 10

ip address 10.10.10.2 255.255.255.0

ip address 10.10.20.2 255.255.255.0 secondary

standby 1 10.10.10.1

standby 2 10.10.20.1 secondary

and so on

c) the primary command is in the wrong subnet

for me none of these HSRP statements are effective

if all you need is a single working HSRP group use

standby 134.226.102.x

Hope to help

Giuseppe

New Member

Re: HSRP: Standby ip x.x.x.x secondary

Thanks Giuseppe.

2897
Views
5
Helpful
3
Replies
CreatePlease to create content