Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

HSRP - standby router replying instead of active

Hi,

I am preparing for CCNP. I came across a problem in configuring HSRP.

I have the following topology.

                    R1======R2

                         |         |

                         Switch

                              |

                            Host

This is R1's config

R1#sho standby

Vlan70 - Group 1

  State is Standby

    3 state changes, last state change 01:44:39

  Virtual IP address is 1.1.1.2

  Active virtual MAC address is 0000.0c07.ac01

    Local virtual MAC address is 0000.0c07.ac01 (v1 default)

  Hello time 3 sec, hold time 10 sec

    Next hello sent in 2.232 secs

  Preemption disabled

  Active router is 1.1.1.3, priority 100 (expires in 9.696 sec)

  Standby router is local

  Priority 100 (default 100)

  Group name is "hsrp-Vl70-1" (default)

This is R2's config

R2#show standby

Vlan70 - Group 1

  State is Active

    2 state changes, last state change 01:45:53

  Virtual IP address is 1.1.1.2

  Active virtual MAC address is 0000.0c07.ac01

    Local virtual MAC address is 0000.0c07.ac01 (v1 default)

  Hello time 3 sec, hold time 10 sec

    Next hello sent in 1.012 secs

  Preemption disabled

  Active router is local

  Standby router is 1.1.1.1, priority 100 (expires in 7.564 sec)

  Priority 100 (default 100)

  Group name is "hsrp-Vl70-1" (default)

But R2 is never responds for Ping from hosts. Ping succeeds but it goes through R1 which is the standby. Also when I disconnect link between Switch and R1, ping fails. That means HSRP not works. What puzzles me is that the state shows correctly. Active and standby. but it does not work. Can you guys help me out how.

Thanks

Chidambaram

Everyone's tags (3)
7 REPLIES

HSRP - standby router replying instead of active

Can you post your interface configs? I also noticed that you have vlan 70 configured for these groups. Do you have a crossover cable between the routers or are you using the vlan through the switch?

HTH, John *** Please rate all useful posts ***
New Member

Re: HSRP - standby router replying instead of active

Hi Blakley,

thanks much for your response.

That is how my topology is. I ll attach the configs now. The line protocol for vlan 70 is up.

R1

interface FastEthernet1/2

switchport access vlan 70

interface Vlan70

ip address 1.1.1.1 255.255.255.0

standby 1 ip 1.1.1.2

R2

interface FastEthernet1/2

switchport access vlan 70

interface Vlan70

ip address 1.1.1.3 255.255.255.0

standby 1 ip 1.1.1.2

HOST

Ip is 1.1.1.4. I am pinging a remote netowrok. From wireshark capture i noticed that arp goes to both router, but only R1 responds to the arp and icmps.Also R1 is the standby which puzzles me.

please tell me if you need any other configs.

thanks

Chidambaram

Re: HSRP - standby router replying instead of active

The configuration looks fine. Have you tried saving the configs and exiting out of GNS? Sometimes I lose connectivity in GNS and have to exit to get it to work again....

Otherwise, can you ping the physical interfaces of the switches?

Also, run debug standby on both switches to see if you're getting any errors.

HTH, John *** Please rate all useful posts ***
VIP Super Bronze

HSRP - standby router replying instead of active

If you want r2 to be the primary, assign a higher priority than 100 to it (110) and test again.

New Member

Re: HSRP - standby router replying instead of active

CHIDAMBARAM RAMANATHAN wrote:

From wireshark capture i noticed that arp goes to both router, but only R1 responds to the arp and icmps.Also R1 is the standby which puzzles me.

- Can R1 ping 1.1.1.3 and 1.1.1.2?

- Can R2 ping ping 1.1.1.1?

- Are f1/0 (on both switches) Switchports with vlan 70? If not: What are SPT Port-State von SW1?

- What ip.dst and mac.dst have the ICMPs and the ARP-Replies - the R1's or the HSRP-Addresses?

- And concurring with j.blakey: Save config and restart GNS!

HSRP - standby router replying instead of active

1)  You say its not working.....are you waiting atleast 10 seconds (the default delay w/missed hellos)?

2)  Can you ping both ints on both routers from the end user station?

3) When you ping the remote network, maybe the pings are getting there but not getting back.

Just some thoughts....

New Member

Re: HSRP - standby router replying instead of active

@All:Thanks very much for looking into this,

The problem was, spanning tree was blocking the link between switch and R2. So packets were coming though R1's interface. I mistook this as R1 was replying to the icmp's. Also as jimmy mentioned, i did not wait for 10s. i just pinged and concluded that it dint work.

753
Views
0
Helpful
7
Replies
CreatePlease to create content