Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

HSRP state change from active to standby and backforth

Hi all,

I have two 3550 switches running HSRP in between them.

Here is what i saw on logs on Active switch

Aug  8 02:15:02.352 MST: %HSRP-5-STATECHANGE: Vlan20 Grp 1 state Active -> Speak

Aug  8 02:15:12.353 MST: %HSRP-5-STATECHANGE: Vlan20 Grp 1 state Speak -> Standby

Aug  8 02:47:59.406 MST: %HSRP-5-STATECHANGE: Vlan20 Grp 1 state Standby -> Active

Aug  8 05:00:02.629 MST: %HSRP-5-STATECHANGE: Vlan20 Grp 1 state Active -> Speak

Aug  8 05:00:12.629 MST: %HSRP-5-STATECHANGE: Vlan20 Grp 1 state Speak -> Standby

Aug  8 05:06:59.643 MST: %HSRP-5-STATECHANGE: Vlan20 Grp 1 state Standby -> Active

Second switch has these logs

000487: Aug  8 02:15:02.351 MST: %HSRP-5-STATECHANGE: Vlan20 Grp 1 state Standby

-> Active

000488: Aug  8 02:47:59.405 MST: %HSRP-5-STATECHANGE: Vlan20 Grp 1 state Active

-> Speak

000489: Aug  8 02:48:09.405 MST: %HSRP-5-STATECHANGE: Vlan20 Grp 1 state Speak -

> Standby

000490: Aug  8 05:00:02.628 MST: %HSRP-5-STATECHANGE: Vlan20 Grp 1 state Standby

-> Active

000491: Aug  8 05:06:59.646 MST: %HSRP-5-STATECHANGE: Vlan20 Grp 1 state Active

-> Speak

000492: Aug  8 05:07:09.646 MST: %HSRP-5-STATECHANGE: Vlan20 Grp 1 state Speak -

> Standby

3550SMIB#$

Right now they are working as expected.

Is there something i can check to know why the state changed for vlan 20 only?

Thanks

Mahesh

Everyone's tags (5)
3 ACCEPTED SOLUTIONS

Accepted Solutions
New Member

HSRP state change from active to standby and backforth

It happened once? Dont worry about it then, of course it happens...

We had some pretty aggressive timers and it kept happening until we set them to some reasonable values, but you´ve got the default ones (1,4s), and the preempt is configured with a 60 second delay... maybe you could tune those timers a bit, depends on the environment...

New Member

HSRP state change from active to standby and backforth

It depends on the link, and the distance. For example - if you´ve got a relatively close distribution switches with a GigabitEthernet link - you can go pretty aggressive, as 250ms and 800ms. If we´re talking about a few kilometers and a slower link - you´d have to adjust the values, but I guess 1s and 4s would be fine.

Re: HSRP state change from active to standby and backforth

Hello,

In your configuration it looks like the HRSP timers haven't been change-


I can see tracking enabled, so when this feature is applied the timers are not applicable if that tracking interface becomes unavailable, HRSP will transition/preempt straight without using these timers -

On the other hand the default timers (default hello 3 secs holdtime 10 secs) are used so the hrsp peers can communicate with each other and if for some reason that communication is lost and the 3xhellos are not received from active to standby peers then then you will see a state change.

sh standby- this will show you detauil of the hrsp settings applied.

So i would start by investigating possible layer 1 & 2 issues - cabling / stp etc

  • between hrsp peers -
  • tracked interface

res

Paul

.

Please don't forget to rate this post if it has been helpful.

Please don't forget to rate any posts that have been helpful. Thanks.
10 REPLIES
Silver

HSRP state change from active to standby and backforth

seems to be there is a problem in HSRP timers (hello timer).

can you paste the configuration under HSRP interfaces?

VIP Purple

HSRP state change from active to standby and backforth

Hi Mahesh,

Can you paste your config for hsrp int.

Then only we cabn see the error.

REgards

New Member

HSRP state change from active to standby and backforth

Hi Sandeep,

Here is config of vlan 20 interface from each switch

h run int vlan 20
Building configuration...

Current configuration : 214 bytes
!
interface Vlan20
ip address 192.168.20.1 255.255.255.0
ip ospf hello-interval 40
standby 1 ip 192.168.20.3
standby 1 priority 150
standby 1 preempt delay minimum 60
standby 1 track FastEthernet0/11 60
end

  sh run int vlan 20
Building configuration...

Current configuration : 153 bytes
!
interface Vlan20
ip address 192.168.20.2 255.255.255.0
ip ospf hello-interval 40
standby 1 ip 192.168.20.3
standby 1 preempt delay minimum 60
end

Hello timers are same on both as per config.

It happened 1 time only so might be some weird thing.

Does not happen again.

Thanks

MAhesh

New Member

HSRP state change from active to standby and backforth

It happened once? Dont worry about it then, of course it happens...

We had some pretty aggressive timers and it kept happening until we set them to some reasonable values, but you´ve got the default ones (1,4s), and the preempt is configured with a 60 second delay... maybe you could tune those timers a bit, depends on the environment...

New Member

HSRP state change from active to standby and backforth

Hi Mateja,

Thanks for reply.

Any idea what value i should tune HSRP timers?

Thanks

Mahesh

New Member

HSRP state change from active to standby and backforth

It depends on the link, and the distance. For example - if you´ve got a relatively close distribution switches with a GigabitEthernet link - you can go pretty aggressive, as 250ms and 800ms. If we´re talking about a few kilometers and a slower link - you´d have to adjust the values, but I guess 1s and 4s would be fine.

Re: HSRP state change from active to standby and backforth

Hello,

In your configuration it looks like the HRSP timers haven't been change-


I can see tracking enabled, so when this feature is applied the timers are not applicable if that tracking interface becomes unavailable, HRSP will transition/preempt straight without using these timers -

On the other hand the default timers (default hello 3 secs holdtime 10 secs) are used so the hrsp peers can communicate with each other and if for some reason that communication is lost and the 3xhellos are not received from active to standby peers then then you will see a state change.

sh standby- this will show you detauil of the hrsp settings applied.

So i would start by investigating possible layer 1 & 2 issues - cabling / stp etc

  • between hrsp peers -
  • tracked interface

res

Paul

.

Please don't forget to rate this post if it has been helpful.

Please don't forget to rate any posts that have been helpful. Thanks.
New Member

HSRP state change from active to standby and backforth

Hi Everyone,

I check the default HSRP timers it is 3 secs and holdtime is 10 secs.

This happened only once.

Also Both HSRP switches are close to each other just 2 feet away.

So i can live with these HSRP timers for now?

Thanks

MAhesh

HSRP state change from active to standby and backforth

Mahesh

Please don't forget to rate this post if it has been helpful.

Please don't forget to rate any posts that have been helpful. Thanks.
New Member

HSRP state change from active to standby and backforth

Hi Everyone,

Many thanks to everyone for helping me out.

Thanks

Mahesh

10887
Views
0
Helpful
10
Replies