Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

Silver

HSRP - Track command

Hi All ,

I would like to know how many interfaces can be tracked using syandby track command.

ex:

I want to track four serial interfaces on a router using standby track command.

interface GigabitEthernet0/0

ip address 10.105.3.8 255.255.255.128

standby 2 ip 10.105.3.7

standby 2 priority 105

standby 2 preempt

standby 2 track Serial0/0/0:0

standby 2 track Serial0/0/1:0

standby 2 track Serial0/1/0:0

standby 2 track Serial0/1/1:0

!

interface Serial0/0/0:0

ip address 10.254.238.5 255.255.254.0

encapsulation ppp

!

interface Serial0/0/1:0

ip address 10.254.238.21 255.255.254.0

encapsulation ppp

!

interface Serial0/1/0:0

ip address 10.254.238.13 255.255.254.0

encapsulation ppp

!

interface Serial0/1/1:0

ip address 10.10.10.1 255.255.255.252

encapsulation ppp

Can I use the above config for tracking four serials.

Suppose if serial 0/0/0:0 goes down , then the traffice will go through second router.What about the remaining serial interface traffice. Does it goes through first router or second router , since the three other serial interfaces are up in first router.

Thanks in advance.

Satish

4 REPLIES

Re: HSRP - Track command

Hello satish,

I dont think there should be any issues with the config posted by you... you can have as many interfaces as the router supports , on the standby track command. i dont feel that there is any limitations to this. The standby track command will then work in accordance ith the document given below

http://www.cisco.com/warp/public/619/hsrpguidetoc.html#intracking

The pririty value on the interface decreases and if it goes lower than the priority of the second router, then the primary router switches to standby...

Hope this helps.. all the best.. rate replies if found useful..

Raj

Silver

Re: HSRP - Track command

Hi Raj ,

Thanks for your reply.I have small dought on how hsrp decreses priority when interface goes dowwn and traffic floe of remaining interfaces.

RTR A RTR B

||| |||

|||______ RTR C _|||

||________RTR D___||

|________RTR E_____|

RTA and RTR B atr connecting to RTR c ,RTR D and RTR E using serial interfaces.

hsrp is configured on RTR A and RTR B and serial interafaces are tarcked by using harp track command.

Assume that s0 of router A went down, RTR A priority is decreses by 10 amd RTR B becomes active. Traffic folws throuth RTR B for RTR C.

My question is ,

RTR A's S1 and S2 are up , how the traffice flow for RTR D and RTR E. Will it go through RTR A ? means which is active router for RTR D and RTR E.

Thanks,

Satish

Re: HSRP - Track command

Hello satish,

As you are aware, HSRP is more a LAN protocol.. the default gateway in the lan for one particular device can either be router a or router b.. it cannot be a case where for some particular destinations ,it is router a and for some other destinations it is router b.. the serial tracking also works in accordance with this..

if one of the links go down and the priority of router a becomes less than router b, ALL THE TRAFFIC FLAPS ONTO ROUTER B... so, if the primary links are still up in router a, it will not be used, because the traffic has been flapped to router b... if you want to still use router a, you need to give another L3 connection beteen router a and b and do some routing changes which can become too complex..

Hope this helps.. all the best.. rate replies if found useful..

Raj

Silver

Re: HSRP - Track command

Hi Raj ,

I've configured "Standby track " for three serials on both routers and observed that whenever one serial link oges down on a router , all the traffice will be punted through second router.

Please find the attached diagram where both routers are connected to L3 -3750 switch.

In the previous post you mentioned that L3 can help in resolving this issue.Can you give example for this.

Many thanks in advance.

477
Views
5
Helpful
4
Replies
CreatePlease login to create content