Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

HSRP: Track

Hi

Will this work for two core switches running HSRP. Basically I want HSRP running between the switches and also to track interface gig1/1 on the coreA switch.

!- CoreA

interface Vlan2

ip address 2.0.0.2 255.255.255.0

ip helper-address 2.153.20.25

no ip redirects

no ip proxy-arp

standby 2 ip 2.0.0.1

standby 2 priority 105

standby 2 preempt

standby 2 authentication C1sc0

standby 2 track gig1/1

inter gig1/1

switchport

switchport access vlan 2

swithport mode access

!- Core B

interface Vlan2

ip address 2.0.0.3 255.255.255.0

ip helper-address 2.153.20.25

no ip redirects

no ip proxy-arp

standby 2 ip 2.0.0.1

standby 2 priority

standby 2 preempt

standby 2 authentication C1sc0

!- Router 1 att to Core A (gig0/1)

int g0/1

ip address 2.0.0.100 255.255.255.0

6 REPLIES
Hall of Fame Super Bronze

Re: HSRP: Track

I see nothing wrong with the config, it should work as intended.

__

Edison.

Re: HSRP: Track

a very small detail, u need to set priority on core B if u intend to use a different value from default...I am sure its a copy and paste typo.

Sam

Hall of Fame Super Bronze

Re: HSRP: Track

Sam,

The default decrement is 10 and the primary has priority 105, thus the configuration looks fine.

In case of failure, the primary will have priority 95 and the standby will have priority 100 (default).

Re: HSRP: Track

Edison,

I know :-)

But the fact that second device has "standby 2 priority " suggests that there is an intended value planned for priority.

IMHO, we cannot tell if the config is fine until we see what value has been planned for second device.

However,if the config is pasted as is, this particular line would be rejected since "standby 2 priority" with no value is not valid syntax and second device would then use 100 default.

Thanks

Sam

Re: HSRP: Track

Hi

Just to add to the above posts isee that u havent specified the vlaue of the priority to be decremsted in case of the gig1/1 goes down.

Thanks

Mahmood

Re: HSRP: Track

Mahmood, good point !

Default tracking penalty is 10..so all depends on how much will be assigned to standby.

Sam

122
Views
0
Helpful
6
Replies