Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Community Member

HSRP/tracking configuration problem

I am trying to set up HSRP on 3 routers (see attached drawing).  At one point I had it running on one side, but then ran in to a static route problem on the other side.  I have added a switch to hand the static route/IP addressing on interfaces part, but now I can seem to get anythign to work together.

The desired end result is if either port G0/0.12 or G0/1 goes down on R1, R2 takes over.

Please take a look at my current configs and the attached drawing, currently R1 G0/0 is unpluggedR1 sh standby and tracking, don't seem to want to see that G0/0 is down and do what they are configured to do, unless I have something wrong...

Any help you can provide is greatly appreicated....

Tracey

R1:
track 100 interface GigabitEthernet0/0.12 ip routing
!
track 101 interface GigabitEthernet0/0.12 line-protocol
!
track 112 interface GigabitEthernet0/1 ip routing

interface GigabitEthernet0/0.12
encapsulation dot1Q 12
ip vrf forwarding VLAN12
ip address 192.168.26.99 255.255.255.0
ip nat inside
ip virtual-reassembly in
standby 0 ip 192.168.26.100
standby 0 priority 120
standby 0 preempt

interface GigabitEthernet0/1
ip address 172.16.1.2 255.255.255.0
ip nat outside
ip virtual-reassembly in
standby 1 ip 172.16.1.1
standby 1 priority 120
standby 1 preempt
standby 1 track 101 decrement 11
duplex auto
speed auto

ip nat inside source static network 192.168.26.0 172.16.12.0 /24 vrf VLAN12
ip route 10.0.0.0 255.0.0.0 172.16.1.3
ip route vrf VLAN12 0.0.0.0 0.0.0.0 172.16.1.3 global


R1#sh track
Track 100
  Interface GigabitEthernet0/0.12 ip routing
  IP routing is Down (hw down)
    5 changes, last change 00:48:33
Track 101
  Interface GigabitEthernet0/0.12 line-protocol
  Line protocol is Down (hw down)
    1 change, last change 00:33:13
  Tracked by:
    HSRP GigabitEthernet0/1 1
Track 112
  Interface GigabitEthernet0/1 ip routing
  IP routing is Up
    11 changes, last change 00:49:10

R1#sh stand
GigabitEthernet0/0.12 - Group 0
  State is Init (interface down)
    15 state changes, last state change 00:47:50
  Virtual IP address is 192.168.26.100
  Active virtual MAC address is unknown
    Local virtual MAC address is 0000.0c07.ac00 (v1 default)
  Hello time 3 sec, hold time 10 sec
  Preemption enabled
  Active router is unknown
  Standby router is unknown
  Priority 120 (configured 120)
  Group name is "hsrp-Gi0/0.12-0" (default)
GigabitEthernet0/1 - Group 1
  State is Active
    23 state changes, last state change 00:48:25
  Virtual IP address is 172.16.1.1
  Active virtual MAC address is 0000.0c07.ac01
    Local virtual MAC address is 0000.0c07.ac01 (v1 default)
  Hello time 3 sec, hold time 10 sec
    Next hello sent in 0.272 secs
  Preemption enabled
  Active router is local
  Standby router is 172.16.1.4, priority 110 (expires in 8.944 sec)
  Priority 109 (configured 120)
    Track object 101 state Down decrement 11
  Group name is "hsrp-Gi0/1-1" (default)


R2:
track 100 interface GigabitEthernet0/2.12 ip routing
!
track 101 interface GigabitEthernet0/2.12 line-protocol
!
track 112 interface GigabitEthernet0/1 ip routing

interface GigabitEthernet0/1
ip address 172.16.1.4 255.255.255.0
ip nat outside
ip virtual-reassembly in
standby 1 ip 172.16.1.1
standby 1 priority 110
duplex auto
speed auto
!
interface GigabitEthernet0/2
no ip address
duplex auto
speed auto
!
interface GigabitEthernet0/2.12
encapsulation dot1Q 12
ip vrf forwarding VLAN12
ip address 192.168.26.98 255.255.255.0
ip nat inside
ip virtual-reassembly in
standby 0 ip 192.168.26.100
standby 0 priority 110
!
ip nat inside source static network 192.168.26.0 172.16.12.0 /24 vrf VLAN12
ip route 10.0.0.0 255.0.0.0 172.16.1.3
ip route vrf VLAN12 0.0.0.0 0.0.0.0 172.16.1.3 global

R2#sh track
Track 100
  Interface GigabitEthernet0/2.12 ip routing
  IP routing is Up
    2 changes, last change 03:16:17
Track 101
  Interface GigabitEthernet0/2.12 line-protocol
  Line protocol is Up
    1 change, last change 00:43:52
Track 112
  Interface GigabitEthernet0/1 ip routing
  IP routing is Up
    3 changes, last change 02:36:57

R2#sh stan
GigabitEthernet0/1 - Group 1
  State is Standby
    28 state changes, last state change 00:49:30
  Virtual IP address is 172.16.1.1
  Active virtual MAC address is 0000.0c07.ac01
    Local virtual MAC address is 0000.0c07.ac01 (v1 default)
  Hello time 3 sec, hold time 10 sec
    Next hello sent in 2.512 secs
  Preemption disabled
  Active router is 172.16.1.2, priority 109 (expires in 7.984 sec)
  Standby router is local
  Priority 110 (configured 110)
  Group name is "hsrp-Gi0/1-1" (default)
GigabitEthernet0/2.12 - Group 0
  State is Active
    28 state changes, last state change 00:48:59
  Virtual IP address is 192.168.26.100
  Active virtual MAC address is 0000.0c07.ac00
    Local virtual MAC address is 0000.0c07.ac00 (v1 default)
  Hello time 3 sec, hold time 10 sec
    Next hello sent in 1.888 secs
  Preemption disabled
  Active router is local
  Standby router is unknown
  Priority 110 (configured 110)
  Group name is "hsrp-Gi0/2.12-0" (default)

R3:
interface GigabitEthernet0/0
ip address 10.0.0.1 255.255.255.0
duplex auto
speed auto
!
interface GigabitEthernet0/1
ip address 172.16.1.3 255.255.255.0
duplex auto
speed auto
!
ip route 172.16.10.0 255.255.255.0 172.16.1.1
ip route 172.16.11.0 255.255.255.0 172.16.1.1
ip route 172.16.12.0 255.255.255.0 172.16.1.1
ip route 172.16.13.0 255.255.255.0 172.16.1.1

Everyone's tags (1)
1 ACCEPTED SOLUTION

Accepted Solutions

HSRP/tracking configuration problem

R2#sh stand


GigabitEthernet0/1 - Group 1

  State is Standby

    28 state changes, last state change 03:30:06

  Virtual IP address is 172.16.1.1

  Active virtual MAC address is 0000.0c07.ac01

    Local virtual MAC address is 0000.0c07.ac01 (v1 default)

  Hello time 3 sec, hold time 10 sec

    Next hello sent in 0.976 secs

Preemption disabled

Same problem, different interface

R2

int gi0/1

standby 1 preempt

Regards

Dan

16 REPLIES

HSRP/tracking configuration problem

Hi Tracey ,

R2 :

interface GigabitEthernet0/2.12

standby 0 preempt

Regards

Dan

Community Member

HSRP/tracking configuration problem

Dan,

Thank you for the prompt reply, however I have added the line (had it in there before too) and it still won't switch over.  The pings I have going on each to each other are still not coming through.

Any other suggestions?

Tracey

HSRP/tracking configuration problem

Could you post from R1 and R2 

show standby

Regards

Dan

Community Member

HSRP/tracking configuration problem

R1#sh stand

GigabitEthernet0/0.12 - Group 0

  State is Init (interface down)

    15 state changes, last state change 00:47:50

  Virtual IP address is 192.168.26.100

  Active virtual MAC address is unknown

    Local virtual MAC address is 0000.0c07.ac00 (v1 default)

  Hello time 3 sec, hold time 10 sec

  Preemption enabled

  Active router is unknown

  Standby router is unknown

  Priority 120 (configured 120)

  Group name is "hsrp-Gi0/0.12-0" (default)

GigabitEthernet0/1 - Group 1

  State is Active

    23 state changes, last state change 00:48:25

  Virtual IP address is 172.16.1.1

  Active virtual MAC address is 0000.0c07.ac01

    Local virtual MAC address is 0000.0c07.ac01 (v1 default)

  Hello time 3 sec, hold time 10 sec

    Next hello sent in 0.272 secs

  Preemption enabled

  Active router is local

  Standby router is 172.16.1.4, priority 110 (expires in 8.944 sec)

  Priority 109 (configured 120)

    Track object 101 state Down decrement 11

  Group name is "hsrp-Gi0/1-1" (default)

R2#sh stan

GigabitEthernet0/1 - Group 1

  State is Standby

    28 state changes, last state change 00:49:30

  Virtual IP address is 172.16.1.1

  Active virtual MAC address is 0000.0c07.ac01

    Local virtual MAC address is 0000.0c07.ac01 (v1 default)

  Hello time 3 sec, hold time 10 sec

    Next hello sent in 2.512 secs

  Preemption disabled

  Active router is 172.16.1.2, priority 109 (expires in 7.984 sec)

  Standby router is local

  Priority 110 (configured 110)

  Group name is "hsrp-Gi0/1-1" (default)

GigabitEthernet0/2.12 - Group 0

  State is Active

    28 state changes, last state change 00:48:59

  Virtual IP address is 192.168.26.100

  Active virtual MAC address is 0000.0c07.ac00

    Local virtual MAC address is 0000.0c07.ac00 (v1 default)

  Hello time 3 sec, hold time 10 sec

    Next hello sent in 1.888 secs

  Preemption disabled

  Active router is local

  Standby router is unknown

  Priority 110 (configured 110)

  Group name is "hsrp-Gi0/2.12-0" (default)

R1#sh stand

GigabitEthernet0/0.12 - Group 0

  State is Init (interface down)

    15 state changes, last state change 00:47:50

  Virtual IP address is 192.168.26.100

  Active virtual MAC address is unknown

    Local virtual MAC address is 0000.0c07.ac00 (v1 default)

  Hello time 3 sec, hold time 10 sec

  Preemption enabled

  Active router is unknown

  Standby router is unknown

  Priority 120 (configured 120)

  Group name is "hsrp-Gi0/0.12-0" (default)

GigabitEthernet0/1 - Group 1

  State is Active

    23 state changes, last state change 00:48:25

  Virtual IP address is 172.16.1.1

  Active virtual MAC address is 0000.0c07.ac01

    Local virtual MAC address is 0000.0c07.ac01 (v1 default)

  Hello time 3 sec, hold time 10 sec

    Next hello sent in 0.272 secs

  Preemption enabled

  Active router is local

  Standby router is 172.16.1.4, priority 110 (expires in 8.944 sec)

  Priority 109 (configured 120)

    Track object 101 state Down decrement 11

  Group name is "hsrp-Gi0/1-1" (default)

R2#sh stan
GigabitEthernet0/1 - Group 1
  State is Standby
    28 state changes, last state change 00:49:30
  Virtual IP address is 172.16.1.1
  Active virtual MAC address is 0000.0c07.ac01
    Local virtual MAC address is 0000.0c07.ac01 (v1 default)
  Hello time 3 sec, hold time 10 sec
    Next hello sent in 2.512 secs
  Preemption disabled
  Active router is 172.16.1.2, priority 109 (expires in 7.984 sec)
  Standby router is local
  Priority 110 (configured 110)
  Group name is "hsrp-Gi0/1-1" (default)
GigabitEthernet0/2.12 - Group 0
  State is Active
    28 state changes, last state change 00:48:59
  Virtual IP address is 192.168.26.100
  Active virtual MAC address is 0000.0c07.ac00
    Local virtual MAC address is 0000.0c07.ac00 (v1 default)
  Hello time 3 sec, hold time 10 sec
    Next hello sent in 1.888 secs
  Preemption disabled
  Active router is local
  Standby router is unknown
  Priority 110 (configured 110)
  Group name is "hsrp-Gi0/2.12-0" (default)

HSRP/tracking configuration problem

As per your output :

GigabitEthernet0/2.12 - Group 0

  State is Active

    28 state changes, last state change 00:48:59

  Virtual IP address is 192.168.26.100

  Active virtual MAC address is 0000.0c07.ac00

    Local virtual MAC address is 0000.0c07.ac00 (v1 default)

  Hello time 3 sec, hold time 10 sec

    Next hello sent in 1.888 secs

  Preemption disabled

I insist

on R2 :

en

conf t

int gi0/2.12

standby 0 preempt

Regards

Dan

Community Member

HSRP/tracking configuration problem

R2#sh stan

GigabitEthernet0/1 - Group 1

  State is Standby

    28 state changes, last state change 00:49:30

  Virtual IP address is 172.16.1.1

  Active virtual MAC address is 0000.0c07.ac01

    Local virtual MAC address is 0000.0c07.ac01 (v1 default)

  Hello time 3 sec, hold time 10 sec

    Next hello sent in 2.512 secs

  Preemption disabled

  Active router is 172.16.1.2, priority 109 (expires in 7.984 sec)

  Standby router is local

  Priority 110 (configured 110)

  Group name is "hsrp-Gi0/1-1" (default)

GigabitEthernet0/2.12 - Group 0

  State is Active

    28 state changes, last state change 00:48:59

  Virtual IP address is 192.168.26.100

  Active virtual MAC address is 0000.0c07.ac00

    Local virtual MAC address is 0000.0c07.ac00 (v1 default)

  Hello time 3 sec, hold time 10 sec

    Next hello sent in 1.888 secs

  Preemption enabled

  Active router is local

  Standby router is unknown

  Priority 110 (configured 110)

  Group name is "hsrp-Gi0/2.12-0" (default)

HSRP/tracking configuration problem

OK ,

That's perfect.

R2 :

  Preemption enabled

  Active router is local

  Standby router is unknown

R1 : interface down

You can test how , by "no shut" on R1 Gi0/0.12 , See the show standby brie on R1 and R2

And then shut this interface and show standby bri on R1 and R2

Regards

Dan

Community Member

HSRP/tracking configuration problem

everything is in a normal state and running.
R1
Mar 19 19:49:25.566: %TRACKING-5-STATE: 101 interface Gi0/0.12 line-protocol Dow
n->Up
Mar 19 19:49:25.566: %TRACKING-5-STATE: 100 interface Gi0/0.12 ip routing Down->
Up
Mar 19 19:49:26.930: %LINK-3-UPDOWN: Interface GigabitEthernet0/0, changed state
to up
Mar 19 19:49:27.930: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthe
rnet0/0, changed state to up
Mar 19 19:49:49.798: %HSRP-5-STATECHANGE: GigabitEthernet0/0.12 Grp 0 state Stan
dby -> Active
R1#sh standby
GigabitEthernet0/0.12 - Group 0
  State is Active
    17 state changes, last state change 00:01:14
  Virtual IP address is 192.168.26.100
  Active virtual MAC address is 0000.0c07.ac00
    Local virtual MAC address is 0000.0c07.ac00 (v1 default)
  Hello time 3 sec, hold time 10 sec
    Next hello sent in 1.456 secs
  Preemption enabled
  Active router is local
  Standby router is 192.168.26.98, priority 110 (expires in 9.792 sec)
  Priority 120 (configured 120)
  Group name is "hsrp-Gi0/0.12-0" (default)
GigabitEthernet0/1 - Group 1
  State is Active
    23 state changes, last state change 02:23:17
  Virtual IP address is 172.16.1.1
  Active virtual MAC address is 0000.0c07.ac01
    Local virtual MAC address is 0000.0c07.ac01 (v1 default)
  Hello time 3 sec, hold time 10 sec
    Next hello sent in 2.496 secs
  Preemption enabled
  Active router is local
  Standby router is 172.16.1.4, priority 110 (expires in 10.192 sec)
  Priority 120 (configured 120)
    Track object 101 state Up decrement 11
  Group name is "hsrp-Gi0/1-1" (default)

R2#sh stand
GigabitEthernet0/1 - Group 1
  State is Standby
    28 state changes, last state change 02:24:22
  Virtual IP address is 172.16.1.1
  Active virtual MAC address is 0000.0c07.ac01
    Local virtual MAC address is 0000.0c07.ac01 (v1 default)
  Hello time 3 sec, hold time 10 sec
    Next hello sent in 1.152 secs
  Preemption disabled
  Active router is 172.16.1.2, priority 120 (expires in 9.200 sec)
  Standby router is local
  Priority 110 (configured 110)
  Group name is "hsrp-Gi0/1-1" (default)
GigabitEthernet0/2.12 - Group 0
  State is Standby
    30 state changes, last state change 00:02:12
  Virtual IP address is 192.168.26.100
  Active virtual MAC address is 0000.0c07.ac00
    Local virtual MAC address is 0000.0c07.ac00 (v1 default)
  Hello time 3 sec, hold time 10 sec
    Next hello sent in 0.336 secs
  Preemption enabled
  Active router is 192.168.26.99, priority 120 (expires in 8.112 sec)
  Standby router is local
  Priority 110 (configured 110)
  Group name is "hsrp-Gi0/2.12-0" (default)

Shut down R1 int g0/0.12

R1(config)#int g0/0.12
R1(config-subif)#shut
R1(config-subif)#
Mar 19 19:53:22.742: %HSRP-5-STATECHANGE: GigabitEthernet0/0.12 Grp 0 state Active -> Init
Mar 19 19:53:22.986: %TRACKING-5-STATE: 101 interface Gi0/0.12 line-protocol Up->Down
Mar 19 19:53:22.986: %TRACKING-5-STATE: 100 interface Gi0/0.12 ip routing Up->Down

R1r#sh stand
GigabitEthernet0/0.12 - Group 0
  State is Init (interface down)
    18 state changes, last state change 00:00:26
  Virtual IP address is 192.168.26.100
  Active virtual MAC address is unknown
    Local virtual MAC address is 0000.0c07.ac00 (v1 default)
  Hello time 3 sec, hold time 10 sec
  Preemption enabled
  Active router is unknown
  Standby router is unknown
  Priority 120 (configured 120)
  Group name is "hsrp-Gi0/0.12-0" (default)
GigabitEthernet0/1 - Group 1
  State is Active
    23 state changes, last state change 02:26:02
  Virtual IP address is 172.16.1.1
  Active virtual MAC address is 0000.0c07.ac01
    Local virtual MAC address is 0000.0c07.ac01 (v1 default)
  Hello time 3 sec, hold time 10 sec
    Next hello sent in 1.184 secs
  Preemption enabled
  Active router is local
  Standby router is 172.16.1.4, priority 110 (expires in 7.744 sec)
  Priority 109 (configured 120)
    Track object 101 state Down decrement 11
  Group name is "hsrp-Gi0/1-1" (default)
R2#sh stand
GigabitEthernet0/1 - Group 1
  State is Standby
    28 state changes, last state change 02:26:33
  Virtual IP address is 172.16.1.1
  Active virtual MAC address is 0000.0c07.ac01
    Local virtual MAC address is 0000.0c07.ac01 (v1 default)
  Hello time 3 sec, hold time 10 sec
    Next hello sent in 0.576 secs
  Preemption disabled
  Active router is 172.16.1.2, priority 109 (expires in 9.216 sec)
  Standby router is local
  Priority 110 (configured 110)
  Group name is "hsrp-Gi0/1-1" (default)
GigabitEthernet0/2.12 - Group 0
  State is Active
    31 state changes, last state change 00:01:09
  Virtual IP address is 192.168.26.100
  Active virtual MAC address is 0000.0c07.ac00
    Local virtual MAC address is 0000.0c07.ac00 (v1 default)
  Hello time 3 sec, hold time 10 sec
    Next hello sent in 1.200 secs
  Preemption enabled
  Active router is local
  Standby router is unknown
  Priority 110 (configured 110)
  Group name is "hsrp-Gi0/2.12-0" (default)

HSRP/tracking configuration problem

Yes

GigabitEthernet0/2.12 - Group 0

  State is Active

    31 state changes, last state change 00:01:09

Your issue was the preemption

Regards

Dan

Community Member

HSRP/tracking configuration problem

I can not ping from one side to the other!  Issue is still  on going!  Traceroute from laptop on 192.168.26.229 fails at 192.168.26.98.  Traceroute from other laptop goes from 10.0.0.1, 172.16.1.2, 172.16.1.3, then fails.  As a matter of fact, the 10 laptop goes to R3 to R1 then back to R3. 

If you look at my config at the beginning, HSRP is on 2 ports on R1 and R2.  yes, the virtual IP of 192.168.26.100 fails over, but the other virtual ip of 172.16.1.1 does not.  This is why I am trying to do the Tacking, but it doesn't seem to work.

Please take another look......

Community Member

HSRP/tracking configuration problem

No matter what I do, I can't seem to get g0/1 to actually track what G0/0.12 is doing.....  I just changed this "standby track interface g0/0.12 11"  and I can see that when int g0/0.12 goes down, int g0/1 decrements to 109 from120.  However, int g0/1 stays the active interface and doesn't switch over....  What could be causing this?????

I have R1, R2 and R3 connected to a netgear switch.  Could the switch be faking out the router ports somehow?

Please someone help me!

HSRP/tracking configuration problem

R1

interface GigabitEthernet0/0.12

standby 0 track GigabitEthernet0/1 50

!

interface GigabitEthernet0/1

standby 1 track GigabitEthernet0/0.12 50

R2

interface GigabitEthernet0/2.12

standby 0 track GigabitEthernet0/1 50

!

interface GigabitEthernet0/1

standby 1 track GigabitEthernet0/2.12 50

This way each HSRP group will track the other interface status.

Dan

Community Member

HSRP/tracking configuration problem

That's what I have been trying tot do all day, but I must be missing something as it won't work!

I can say, that this is the first time I have seen the sh track show something that was "Via HSRP"....

I did a shut/no shut cycle on int g0/0.12, results are at the end....  Still can get the pings to go through....

R2 shows that int g0/2.12 is active and g0/1 is in standby.......

R1 shows that int g0/0.12 is init and g0/1 is active.......   Hence my problem...  Is there some global config that neds to happen?///

Tracey

R2
track 1 interface GigabitEthernet0/1 line-protocol
!
track 2 interface GigabitEthernet0/2.12 line-protocol
!
interface GigabitEthernet0/1
ip address 172.16.1.4 255.255.255.0
ip nat outside
ip virtual-reassembly in
standby 1 ip 172.16.1.1
standby 1 priority 110
standby 1 track 2 decrement 50
duplex auto
speed auto
!
interface GigabitEthernet0/2.12
encapsulation dot1Q 12
ip vrf forwarding VLAN12
ip address 192.168.26.98 255.255.255.0
ip nat inside
ip virtual-reassembly in
standby 0 ip 192.168.26.100
standby 0 priority 110
standby 0 preempt
standby 0 track 1 decrement 50

ip nat inside source static network 192.168.26.0 172.16.12.0 /24 vrf VLAN12
ip route 10.0.0.0 255.0.0.0 172.16.1.3
ip route vrf VLAN12 0.0.0.0 0.0.0.0 172.16.1.3 global
!
R2#sh stand
GigabitEthernet0/1 - Group 1
  State is Standby
    28 state changes, last state change 03:30:06
  Virtual IP address is 172.16.1.1
  Active virtual MAC address is 0000.0c07.ac01
    Local virtual MAC address is 0000.0c07.ac01 (v1 default)
  Hello time 3 sec, hold time 10 sec
    Next hello sent in 0.976 secs
  Preemption disabled
  Active router is 172.16.1.2, priority 70 (expires in 10.096 sec)
  Standby router is local
  Priority 110 (configured 110)
    Track interface GigabitEthernet0/2.12 state Up decrement 50
  Group name is "hsrp-Gi0/1-1" (default)
GigabitEthernet0/2.12 - Group 0
  State is Active
    37 state changes, last state change 00:25:35
  Virtual IP address is 192.168.26.100
  Active virtual MAC address is 0000.0c07.ac00
    Local virtual MAC address is 0000.0c07.ac00 (v1 default)
  Hello time 3 sec, hold time 10 sec
    Next hello sent in 1.120 secs
  Preemption enabled
  Active router is local
  Standby router is unknown
  Priority 110 (configured 110)
    Track interface GigabitEthernet0/1 state Up decrement 50
  Group name is "hsrp-Gi0/2.12-0" (default)
R2#sh track
Track 1  (via HSRP)
  Interface GigabitEthernet0/1 line-protocol
  Line protocol is Up
    1 change, last change 00:04:25
  Tracked by:
    HSRP GigabitEthernet0/2.12 0
Track 2  (via HSRP)
  Interface GigabitEthernet0/2.12 line-protocol
  Line protocol is Up
    1 change, last change 00:03:59
  Tracked by:
    HSRP GigabitEthernet0/1 1
Track 100
  Interface GigabitEthernet0/2.12 ip routing
  IP routing is Up
    2 changes, last change 05:57:00
Track 101
  Interface GigabitEthernet0/2.12 line-protocol
  Line protocol is Up
    1 change, last change 03:24:35
Track 112
  Interface GigabitEthernet0/1 ip routing
  IP routing is Up
    3 changes, last change 05:17:40

R1:
track 1 interface GigabitEthernet0/0.12 line-protocol
!
track 2 interface GigabitEthernet0/1 line-protocol

interface GigabitEthernet0/0.12
encapsulation dot1Q 12
ip vrf forwarding VLAN12
ip address 192.168.26.99 255.255.255.0
ip nat inside
ip virtual-reassembly in
standby 0 ip 192.168.26.100
standby 0 priority 120
standby 0 preempt
standby 0 track 2 decrement 50
shutdown
!
interface GigabitEthernet0/1
ip address 172.16.1.2 255.255.255.0
ip nat outside
ip virtual-reassembly in
standby 1 ip 172.16.1.1
standby 1 priority 120
standby 1 preempt
standby 1 track 1 decrement 50
duplex auto
speed auto

R1#sh stand
GigabitEthernet0/0.12 - Group 0
  State is Init (interface down)
    22 state changes, last state change 00:28:45
  Virtual IP address is 192.168.26.100
  Active virtual MAC address is unknown
    Local virtual MAC address is 0000.0c07.ac00 (v1 default)
  Hello time 3 sec, hold time 10 sec
  Preemption enabled
  Active router is unknown
  Standby router is unknown
  Priority 120 (configured 120)
    Track interface GigabitEthernet0/1 state Up decrement 50
  Group name is "hsrp-Gi0/0.12-0" (default)
GigabitEthernet0/1 - Group 1
  State is Active
    23 state changes, last state change 03:33:28
  Virtual IP address is 172.16.1.1
  Active virtual MAC address is 0000.0c07.ac01
    Local virtual MAC address is 0000.0c07.ac01 (v1 default)
  Hello time 3 sec, hold time 10 sec
    Next hello sent in 0.192 secs
  Preemption enabled
  Active router is local
  Standby router is 172.16.1.4, priority 110 (expires in 9.344 sec)
  Priority 70 (configured 120)
    Track interface GigabitEthernet0/0.12 state Down decrement 50
  Group name is "hsrp-Gi0/1-1" (default)
R1#sh track
Track 1  (via HSRP)
  Interface GigabitEthernet0/0.12 line-protocol
  Line protocol is Down (sw admin-down)
    1 change, last change 00:08:39
  Tracked by:
    HSRP GigabitEthernet0/1 1
Track 2  (via HSRP)
  Interface GigabitEthernet0/1 line-protocol
  Line protocol is Up
    1 change, last change 00:09:20
  Tracked by:
    HSRP GigabitEthernet0/0.12 0

I shut and no shut the port (cycle), and here are the results
R1#sh stan
GigabitEthernet0/0.12 - Group 0
  State is Init (interface down)
    24 state changes, last state change 00:00:32
  Virtual IP address is 192.168.26.100
  Active virtual MAC address is unknown
    Local virtual MAC address is 0000.0c07.ac00 (v1 default)
  Hello time 3 sec, hold time 10 sec
  Preemption enabled
  Active router is unknown
  Standby router is unknown
  Priority 120 (configured 120)
    Track interface GigabitEthernet0/1 state Up decrement 50
  Group name is "hsrp-Gi0/0.12-0" (default)
GigabitEthernet0/1 - Group 1
  State is Active
    23 state changes, last state change 03:36:30
  Virtual IP address is 172.16.1.1
  Active virtual MAC address is 0000.0c07.ac01
    Local virtual MAC address is 0000.0c07.ac01 (v1 default)
  Hello time 3 sec, hold time 10 sec
    Next hello sent in 2.320 secs
  Preemption enabled
  Active router is local
  Standby router is 172.16.1.4, priority 110 (expires in 10.160 sec)
  Priority 70 (configured 120)
    Track interface GigabitEthernet0/0.12 state Down decrement 50
  Group name is "hsrp-Gi0/1-1" (default)

R2 show that ing g0/2.12 is active and g0/1 is in standby

HSRP/tracking configuration problem

R2#sh stand


GigabitEthernet0/1 - Group 1

  State is Standby

    28 state changes, last state change 03:30:06

  Virtual IP address is 172.16.1.1

  Active virtual MAC address is 0000.0c07.ac01

    Local virtual MAC address is 0000.0c07.ac01 (v1 default)

  Hello time 3 sec, hold time 10 sec

    Next hello sent in 0.976 secs

Preemption disabled

Same problem, different interface

R2

int gi0/1

standby 1 preempt

Regards

Dan

1320
Views
0
Helpful
16
Replies
CreatePlease to create content