Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

HSRP tracks incorrectly

Dear Experts,

what do you think can be a reason for this "odd" situation:

I've HSRP configured on 3550

interface vlan3

ip address 172.18.0.3 255.255.255.0

standby 3 ip 172.18.0.1

standby 3 priority 95

standby 3 track Port-channel2 5

HSRP track the Po2 interface (which is a L2 trunk): Port-channel2 is up, line protocol is up

however, tracking somehow considers Po2 being down as IP DISABLED, and decreases local priority

Vlan3 - Group 3

Local state is Standby, priority 90 (confgd 95), may preempt

Preemption delayed for at least 900 secs

Hellotime 3 sec, holdtime 10 sec

Next hello sent in 2.246

Virtual IP address is 172.18.0.1 configured

Active router is 172.18.0.2, priority 100 expires in 7.648

Standby router is local

7 state changes, last state change 9w6d

Priority tracking 1 interface, 0 up:

Interface Decrement State

Port-channel2 5 Down (IP disabled)

How come? Appreciate your advise!

Thanks,

-igor

3 REPLIES
Hall of Fame Super Bronze

Re: HSRP tracks incorrectly

I'm unable to duplicate your problem:

Switch#sh ver | i IOS

Cisco IOS Software, C3550 Software (C3550-IPSERVICESK9-M), Version 12.2(25)SEC2, RELEASE SOFTWARE (fc1)

Switch#sh stand

Vlan1 - Group 3

State is Standby

4 state changes, last state change 00:00:48

Virtual IP address is 172.18.0.1

Active virtual MAC address is 0000.0c07.ac03

Local virtual MAC address is 0000.0c07.ac03 (v1 default)

Hello time 3 sec, hold time 10 sec

Next hello sent in 0.039 secs

Preemption enabled

Active router is 172.18.0.2, priority 100 (expires in 8.985 sec)

Standby router is local

Priority 95 (configured 95)

Track interface Port-channel1 state Up decrement 5

IP redundancy name is "hsrp-Vl1-3" (default)

___

Can you post the show track output?

Here is mine:

Switch#sh track

Track 1 (via HSRP)

Interface Port-channel1 line-protocol

Line protocol is Up

1 change, last change 00:07:03

Tracked by:

HSRP Vlan1 3

Switch#

HTH,

__

Edison.

New Member

Re: HSRP tracks incorrectly

will get 'show track' in awhile

however, I've an older IOS

Cisco Internetwork Operating System Software

IOS (tm) C3550 Software (C3550-I9Q3L2-M), Version 12.1(11)EA1, RELEASE SOFTWARE (fc1)

can it be a bug in it?

I did an experiment with tracking a FE interface instead of Po, got the same result

Vlan606 - Group 9

Local state is Standby, priority 90 (confgd 95), may preempt

Next hello sent in 2.124

Virtual IP address is 172.18.5.65 configured

Active router is 172.18.5.66, priority 100 expires in 9.764

Standby router is local

10 state changes, last state change 5d02h

Priority tracking 1 interface, 0 up:

Interface Decrement State

FastEthernet0/11 5 Down (IP disabled)

FastEthernet0/11 is up, line protocol is up

interface Vlan606

ip address 172.18.5.67 255.255.255.240

standby 9 ip 172.18.5.65

standby 9 priority 95

standby 9 track FastEthernet0/11 5

First time in my hundreds of HSRP installations..

Hall of Fame Super Bronze

Re: HSRP tracks incorrectly

I suggest upgrading the code as the newer version don't have that issue.

__

Edison.

173
Views
0
Helpful
3
Replies