Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

HSRP trouble

I've configured MHSRP to achieve load balancing across 2 WAN links: R1 has priority 100 for group 1 and 95 for group 2, whereas R2 has priority 100 for group 2 and 95 for group 1.

If the WAN link fails, the priority is decreased by 10, allowing switchover.

However something ain't working properly, since R2 is active for both groups

R1

interface FastEthernet0/0

description ** LAN **

ip address 10.2.100.75 255.255.255.240

no ip proxy-arp

standby 1 ip 10.2.100.78

standby 1 priority 95

standby 1 track 10 decrement 10

standby 2 ip 10.2.100.77

standby 2 track 10 decrement 10

R2

interface FastEthernet0/0

description ** LAN **

ip address 10.2.100.76 255.255.255.240

no ip proxy-arp

standby 1 ip 10.2.100.78

standby 1 track 10 decrement 10

standby 2 ip 10.2.100.77

standby 2 priority 95

standby 2 track 10 decrement 10

R2#show standby brief

Fa0/0 1 100 Standby 10.2.100.75 local 10.2.100.78

Fa0/0 2 95 Standby 10.2.100.75 local 10.2.100.77

Anybody can give me an explanation?

thank you anticipately

1 ACCEPTED SOLUTION

Accepted Solutions
Hall of Fame Super Silver

Re: HSRP trouble

Hello Carlo,

you need to add

standby xx preempt

on all groups

Hope to help

Giuseppe

6 REPLIES
Hall of Fame Super Silver

Re: HSRP trouble

Hello Carlo,

you need to add

standby xx preempt

on all groups

Hope to help

Giuseppe

New Member

Re: HSRP trouble

Solved, thank you!

What's the purpose of this command?

Re: HSRP trouble

The standby preempt command enables the Hot Standby Router Protocol (HSRP) router with the highest priority to immediately become the active router. Priority is determined first by the configured priority value, and then by the IP address. In each case, a higher value is of greater priority. When a higher priority router preempts a lower priority router, the router sends a Coup message. When a lower priority active router receives a Coup message or a Hello message from an active, higher priority router, the router changes to the Speak state and sends a resign message.

http://www.cisco.com/en/US/tech/tk648/tk362/technologies_tech_note09186a0080094e8c.shtml

Re: HSRP trouble

Hi,

The preempt command allows the device with the better priority to take over the role of Active, without having to wait for the current Active device to go down.

So, in your example, i expect that when you configured the first device, it became the active router for both groups (as there was no backup present) then, when you configured the backup without the preempt command, it would not have taken over as active until the first device failed.

As a rule of thumb, especially if you are using interface tracking, always ensure preempt is enabled.

Cheers

Jonathan

Re: HSRP trouble

Whoops, look like medan beat me to it!

New Member

Re: HSRP trouble

Thank you for the answers.

However, in the 1st step i didn't configure the standby preemt, assuming that the router with the highest priority would become the active router.

However, i noticed that the router with the highest IP was the one becoming active, leading to have it active on both the groups (this is what i wasn't able to explain). Although i rebooted it twice, i had no changes until i configured the standby preemt on both the routers

149
Views
5
Helpful
6
Replies
CreatePlease to create content