Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

HSRP Virtual IP not able to ping

Hello ,

   I need help to ping my virtual ip of HSRP group

First i will explain my scenario

I have  a lan with 4 switches of cisco 2960 model inter-connected with trunk links and  , then i  created 4 different vlan for e.g Vlan 10 ,20 ,30 ,40 in core switch and i populated the created vlans to all other switches using VTP. Then the core switch is connected to a 2 routers on ports Gi 0/1 and Gi 0/2 ( both the ports are trunked and encapsulated with 802.1Q , also configured the links to carry traffic of all the VLANS in the switch )

In Both the routers i created 4 subinterface one for each vlan and assigned ip address for all subinterfaces . then i created HSRP group 10 , 20 ,and  30 and 40 then assigned virtual ip's .

I canble to ping virtual ip address from the active router. but i canot able to ping the virtual ip from standby router as well as the client system .

R1#

R1#sh run

R1#sh running-config

Building configuration...

Current configuration : 1530 bytes

!

version 12.4

no service timestamps log datetime msec

no service timestamps debug datetime msec

no service password-encryption

!

hostname R1

!

!

!

!

!

!

!

!

!

!

!

!

!

!

spanning-tree mode pvst

!

!

!

!

interface FastEthernet0/0

no ip address

duplex auto

speed auto

!

interface FastEthernet0/0.1

encapsulation dot1Q 10

ip address 10.0.10.3 255.255.255.0

ip helper-address 10.0.50.5

standby version 2

standby 10 ip 10.0.10.1

!

interface FastEthernet0/0.2

encapsulation dot1Q 20

ip address 10.0.20.3 255.255.255.0

ip helper-address 10.0.50.5

standby version 2

standby 20 ip 10.0.20.1

!

interface FastEthernet0/0.3

encapsulation dot1Q 30

ip address 10.0.30.3 255.255.255.0

ip helper-address 10.0.50.5

standby version 2

standby 30 ip 10.0.30.1

!

interface FastEthernet0/0.4

encapsulation dot1Q 40

ip address 10.0.40.3 255.255.255.0

ip helper-address 10.0.50.5

standby version 2

standby 40 ip 10.0.40.1

!

interface FastEthernet0/0.5

encapsulation dot1Q 50

ip address 10.0.50.3 255.255.255.0

ip helper-address 10.0.50.5

standby version 2

standby 50 ip 10.0.50.1

!

interface FastEthernet0/1

ip address 20.0.0.4 255.255.255.0

duplex auto

speed auto

standby version 2

standby 1 ip 20.0.0.1

!

interface Serial1/0

no ip address

shutdown

!

interface Serial1/1

no ip address

shutdown

!

interface Serial1/2

no ip address

shutdown

!

interface Serial1/3

no ip address

shutdown

!

interface Vlan1

no ip address

shutdown

!

ip classless

!

!

!

!

!

!

!

line con 0

!

line aux 0

!

line vty 0 4

login

!

!

!

end

The below output is for R2 router

R2#

R2#sh ru

R2#sh running-config

Building configuration...

Current configuration : 1530 bytes

!

version 12.4

no service timestamps log datetime msec

no service timestamps debug datetime msec

no service password-encryption

!

hostname R2

!

!

!

!

!

!

!

!

!

!

!

!

!

!

spanning-tree mode pvst

!

!

!

!

interface FastEthernet0/0

no ip address

duplex auto

speed auto

!

interface FastEthernet0/0.1

encapsulation dot1Q 10

ip address 10.0.10.2 255.255.255.0

ip helper-address 10.0.50.5

standby version 2

standby 10 ip 10.0.10.1

!

interface FastEthernet0/0.2

encapsulation dot1Q 20

ip address 10.0.20.2 255.255.255.0

ip helper-address 10.0.50.5

standby version 2

standby 20 ip 10.0.20.1

!

interface FastEthernet0/0.3

encapsulation dot1Q 30

ip address 10.0.30.2 255.255.255.0

ip helper-address 10.0.50.5

standby version 2

standby 30 ip 10.0.30.1

!

interface FastEthernet0/0.4

encapsulation dot1Q 40

ip address 10.0.40.2 255.255.255.0

ip helper-address 10.0.50.5

standby version 2

standby 40 ip 10.0.40.1

!

interface FastEthernet0/0.5

encapsulation dot1Q 50

ip address 10.0.50.2 255.255.255.0

ip helper-address 10.0.50.5

standby version 2

standby 50 ip 10.0.50.1

!

interface FastEthernet0/1

ip address 20.0.0.3 255.255.255.0

duplex auto

speed auto

standby version 2

standby 1 ip 20.0.0.1

!

interface Serial1/0

no ip address

shutdown

!

interface Serial1/1

no ip address

shutdown

!

interface Serial1/2

no ip address

shutdown

!

interface Serial1/3

no ip address

shutdown

!

interface Vlan1

no ip address

shutdown

!

ip classless

!

!

!

!

!

!

!

line con 0

!

line aux 0

!

line vty 0 4

login

!

!

!

end

the " show standby brief " command output

R1#show standby brief

                     P indicates configured to preempt.

                     |

Interface   Grp  Pri P State    Active          Standby         Virtual IP

Fa0/1       1    100   Active   local           20.0.0.3        20.0.0.1      

            10   100   Active   local           10.0.10.2       10.0.10.1     

            20   100   Active   local           10.0.20.2       10.0.20.1     

            30   100   Active   local           10.0.30.2       10.0.30.1     

            40   100   Active   local           10.0.40.2       10.0.40.1     

            50   100   Active   local           10.0.50.2       10.0.50.1     

R1#exit

R2#sh standby brief

                     P indicates configured to preempt.

                     |

Interface   Grp  Pri P State    Active          Standby         Virtual IP

Fa0/1       1    100   Standby  20.0.0.4        local           20.0.0.1      

            10   100   Standby  10.0.10.3       local           10.0.10.1     

            20   100   Standby  10.0.20.3       local           10.0.20.1     

            30   100   Standby  10.0.30.3       local           10.0.30.1     

            40   100   Standby  10.0.40.3       local           10.0.40.1     

            50   100   Standby  10.0.50.3       local           10.0.50.1     

R2#exit

8 REPLIES

HSRP Virtual IP not able to ping

Hi,

are you able to Ping the physical IP address of the other ourter?

I.e., to Ping 10.0.10.2 from R1?

And to Ping 10. 0.10.3 from R2?

When you issue sh arp

on your router, do you see the entries for the other router physical IP address?

And on R2, do you see the ARP entry for the virtual IP address?

Best regards,

Milan

New Member

HSRP Virtual IP not able to ping

yes i am able to ping the physical ip address one router from the others . but i cannot ping the virtual ip

the show arp cmd output is given below

R1#show arp

Protocol  Address          Age (min)  Hardware Addr   Type   Interface

Internet  10.0.10.1               5   0000.0C9F.0000  ARPA   FastEthernet0/0.1

Internet  10.0.10.2               4   00D0.97BA.C401  ARPA   FastEthernet0/0.1

Internet  10.0.20.1               5   0000.0C9F.0000  ARPA   FastEthernet0/0.2

Internet  10.0.20.2               3   00D0.97BA.C401  ARPA   FastEthernet0/0.2

Internet  10.0.30.1               3   0000.0C9F.0000  ARPA   FastEthernet0/0.3

Internet  10.0.30.2               3   00D0.97BA.C401  ARPA   FastEthernet0/0.3

Internet  10.0.40.1               5   0000.0C9F.0000  ARPA   FastEthernet0/0.4

Internet  10.0.50.1               5   0000.0C9F.0000  ARPA   FastEthernet0/0.5

Internet  10.0.50.2               3   00D0.97BA.C401  ARPA   FastEthernet0/0.5

Internet  10.0.50.5               5   0050.0F3E.8942  ARPA   FastEthernet0/0.5

Internet  20.0.0.1                5   0000.0C9F.F001  ARPA   FastEthernet0/1

Internet  20.0.0.3                1   00D0.97BA.C402  ARPA   FastEthernet0/1

Internet  20.0.0.4                -   0060.47D9.8B02  ARPA   FastEthernet0/1

R1#ping 10.0.40.2

R2#show arp

Protocol  Address          Age (min)  Hardware Addr   Type   Interface

Internet  10.0.10.1               8   0000.0C9F.0000  ARPA   FastEthernet0/0.1

Internet  10.0.10.3               8   0060.47D9.8B01  ARPA   FastEthernet0/0.1

Internet  10.0.20.1               5   0000.0C9F.0000  ARPA   FastEthernet0/0.2

Internet  10.0.20.3               8   0060.47D9.8B01  ARPA   FastEthernet0/0.2

Internet  10.0.30.1               10  0000.0C9F.0000  ARPA   FastEthernet0/0.3

Internet  10.0.30.3               8   0060.47D9.8B01  ARPA   FastEthernet0/0.3

Internet  10.0.40.3               2   0060.47D9.8B01  ARPA   FastEthernet0/0.4

Internet  10.0.50.1               4   0000.0C9F.0000  ARPA   FastEthernet0/0.5

Internet  10.0.50.3               7   0060.47D9.8B01  ARPA   FastEthernet0/0.5

Internet  10.0.50.5               9   0050.0F3E.8942  ARPA   FastEthernet0/0.5

Internet  20.0.0.1                5   0000.0C9F.F001  ARPA   FastEthernet0/1

Internet  20.0.0.3                -   00D0.97BA.C402  ARPA   FastEthernet0/1

R2#ping 10.0.10.1

Re: HSRP Virtual IP not able to ping

If you shut down the uplink from the core to the active router, does the standby assume the role of the active for the HSRP groups?

Can you post the config for your core router?

New Member

HSRP Virtual IP not able to ping

Yes the standby  router becomes when the link between core switch and active get disconnected .

HSRP Virtual IP not able to ping

Hi,

I can see the MAC addresses of virtual IPs are strange:

All of theam are

0000.0C9F.0000

But they should be

0000.0C9F.Fxxx

where the xxxx is the hex representation of the HSRP group number.

(I can see 0000.0C9F.F068 for group 104 on my router.)

Also the Age of the virtual IP address ARP entry should be - on the primary router (it's his own virtual MAC address, not received by ARP response).

Can you provide a complete sh standby command output from your routers (not just brief)?

Which IOS version are you running (possible bug in it)?

I'd also try to add  standby priority 110 on the primary router  interface just for sure.

Best regards,

Milan

New Member

HSRP Virtual IP not able to ping

The Output of show standby command is below

R1#show stand

R1#show standby

FastEthernet0/1 - Group 1 (version 2)

  State is Standby

    5 state changes, last state change 00:00:36

  Virtual IP address is 20.0.0.1

  Active virtual MAC address is unknown

    Local virtual MAC address is 0000.0C9F.F001 (v2 default)

  Hello time 3 sec, hold time 10 sec

    Next hello sent in 1.657 secs

  Preemption disabled

  Active router is 20.0.0.3

  Standby router is local

  Priority 100 (default 100)

  Group name is hsrp-Fa0/1-1 (default)

FastEthernet0/0.1 - Group 10 (version 2)

  State is Active

    10 state changes, last state change 00:09:59

  Virtual IP address is 10.0.10.1

  Active virtual MAC address is 0000.0C9F.0000

    Local virtual MAC address is 0000.0C9F.F00A (v2 default)

  Hello time 3 sec, hold time 10 sec

    Next hello sent in 1.066 secs

  Preemption disabled

  Active router is local

  Standby router is 10.0.10.2

  Priority 100 (default 100)

  Group name is hsrp--10 (default)

FastEthernet0/0.2 - Group 20 (version 2)

  State is Standby

    9 state changes, last state change 00:10:06

  Virtual IP address is 10.0.20.1

  Active virtual MAC address is 0000.0C9F.0000

    Local virtual MAC address is 0000.0C9F.F014 (v2 default)

  Hello time 3 sec, hold time 10 sec

    Next hello sent in 1.31 secs

  Preemption disabled

  Active router is 10.0.20.2

  Standby router is local

  Priority 100 (default 100)

  Group name is hsrp--20 (default)

FastEthernet0/0.3 - Group 30 (version 2)

  State is Standby

    9 state changes, last state change 00:09:57

  Virtual IP address is 10.0.30.1

  Active virtual MAC address is 0000.0C9F.0000

    Local virtual MAC address is 0000.0C9F.F01E (v2 default)

  Hello time 3 sec, hold time 10 sec

    Next hello sent in 0.869 secs

  Preemption disabled

  Active router is 10.0.30.2

  Standby router is local

  Priority 100 (default 100)

  Group name is hsrp--30 (default)

FastEthernet0/0.4 - Group 40 (version 2)

  State is Active

    10 state changes, last state change 00:09:58

  Virtual IP address is 10.0.40.1

  Active virtual MAC address is 0000.0C9F.0000

    Local virtual MAC address is 0000.0C9F.F028 (v2 default)

  Hello time 3 sec, hold time 10 sec

    Next hello sent in 1.096 secs

  Preemption disabled

  Active router is local

  Standby router is 10.0.40.2

  Priority 100 (default 100)

  Group name is hsrp--40 (default)

FastEthernet0/0.5 - Group 50 (version 2)

  State is Active

    9 state changes, last state change 00:09:50

  Virtual IP address is 10.0.50.1

  Active virtual MAC address is 0000.0C9F.0000

    Local virtual MAC address is 0000.0C9F.F032 (v2 default)

  Hello time 3 sec, hold time 10 sec

    Next hello sent in 2.413 secs

  Preemption disabled

  Active router is local

  Standby router is 10.0.50.2

  Priority 100 (default 100)

  Group name is hsrp--50 (default)

R1#

R2#

R2#show stan

R2#show standby

FastEthernet0/1 - Group 1 (version 2)

  State is Active

    5 state changes, last state change 00:00:18

  Virtual IP address is 20.0.0.1

  Active virtual MAC address is 0000.0C9F.F001

    Local virtual MAC address is 0000.0C9F.F001 (v2 default)

  Hello time 3 sec, hold time 10 sec

    Next hello sent in 2.448 secs

  Preemption disabled

  Active router is local

  Standby router is 20.0.0.4

  Priority 100 (default 100)

  Group name is hsrp-Fa0/1-1 (default)

FastEthernet0/0.1 - Group 10 (version 2)

  State is Standby

    10 state changes, last state change 00:10:11

  Virtual IP address is 10.0.10.1

  Active virtual MAC address is 0000.0C9F.0000

    Local virtual MAC address is 0000.0C9F.F00A (v2 default)

  Hello time 3 sec, hold time 10 sec

    Next hello sent in 0.011 secs

  Preemption disabled

  Active router is 10.0.10.3

  Standby router is local

  Priority 100 (default 100)

  Group name is hsrp--10 (default)

FastEthernet0/0.2 - Group 20 (version 2)

  State is Active

    8 state changes, last state change 00:01:55

  Virtual IP address is 10.0.20.1

  Active virtual MAC address is 0000.0C9F.0000

    Local virtual MAC address is 0000.0C9F.F014 (v2 default)

  Hello time 3 sec, hold time 10 sec

    Next hello sent in 0.824 secs

  Preemption disabled

  Active router is local

  Standby router is 10.0.20.3

  Priority 100 (default 100)

  Group name is hsrp--20 (default)

FastEthernet0/0.3 - Group 30 (version 2)

  State is Active

    8 state changes, last state change 00:01:53

  Virtual IP address is 10.0.30.1

  Active virtual MAC address is 0000.0C9F.0000

    Local virtual MAC address is 0000.0C9F.F01E (v2 default)

  Hello time 3 sec, hold time 10 sec

    Next hello sent in 0.741 secs

  Preemption disabled

  Active router is local

  Standby router is 10.0.30.3

  Priority 100 (default 100)

  Group name is hsrp--30 (default)

FastEthernet0/0.4 - Group 40 (version 2)

  State is Standby

    10 state changes, last state change 00:10:11

  Virtual IP address is 10.0.40.1

  Active virtual MAC address is 0000.0C9F.0000

    Local virtual MAC address is 0000.0C9F.F028 (v2 default)

  Hello time 3 sec, hold time 10 sec

    Next hello sent in 0.827 secs

  Preemption disabled

  Active router is 10.0.40.3

  Standby router is local

  Priority 100 (default 100)

  Group name is hsrp--40 (default)

FastEthernet0/0.5 - Group 50 (version 2)

  State is Standby

    10 state changes, last state change 00:10:10

  Virtual IP address is 10.0.50.1

  Active virtual MAC address is 0000.0C9F.0000

    Local virtual MAC address is 0000.0C9F.F032 (v2 default)

  Hello time 3 sec, hold time 10 sec

    Next hello sent in 1.146 secs

  Preemption disabled

  Active router is 10.0.50.3

  Standby router is local

  Priority 100 (default 100)

  Group name is hsrp--50 (default)

R2#

HSRP Virtual IP not able to ping

Hi,

tis is really strange:

Active virtual MAC address is 0000.0C9F.0000

Local virtual MAC address is 0000.0C9F.F00A (v2 default)

I'd

1) enable HSRP preemption on your routers

2) check other Cisco devices ( L3 switches) for HSRP configuration.

It could be there is HSRP v1, e.g., configured somewhere using the same IP addresses?

Best regards,

Milan

Hall of Fame Super Silver

HSRP Virtual IP not able to ping

I agree with Milan that this is very strange. I also believe that it explains the problem in ping to the virtual address. From a previous post in this thread we can see that the response to ARP for the various virtual addresses always returns this MAC address  0000.0C9F.0000   but this is not the local virtual MAC. So the ping is using  0000.0C9F.0000   and the interfaces do not respond because they do not believe that it is their MAC.

HTH

Rick

1764
Views
0
Helpful
8
Replies