Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

hsrp with sub-interface

Hi,

some doubt about the HSRP configuration for the sub-interface, wish netpro can enlighten me. thank you in advance.

R1 :

-----

interface Vlan10

description yahoo

ip address 192.20.137.253 255.255.255.0 secondary

ip address 192.10.3.253 255.255.255.0

standby 10 ip 192.10.3.254

standby 10 priority 110

standby 10 preempt

standby 20 ip 192.20.137.254

standby 20 priority 105

standby 20 preempt

Vl10 10 110 P Active local 192.10.3.252 192.10.3.254

Vl10 20 105 P Standby 192.10.3.252 local 192.20.137.254

R2:

---

interface Vlan10

description yahoo

ip address 192.20.137.252 255.255.255.0 secondary

ip address 192.10.3.252 255.255.255.0

standby 10 ip 192.10.3.254

standby 10 priority 105

standby 10 preempt

standby 20 ip 192.20.137.254

standby 20 priority 110

standby 20 preempt

Vl10 10 105 P Standby 192.10.3.253 local 192.10.3.254

Vl10 20 110 P Active local 192.10.3.253 192.20.137.254

thanks

2 REPLIES
Hall of Fame Super Silver

Re: hsrp with sub-interface

Jack

Perhaps we need some clarification: the question that you ask is about subinterface but the configuration that you give is not subinterface but is secondary addressing.

HSRP supports secondary addressing without needing a second HSRP group. In defining the shared address you can specify the optional parameter secondary to indicate to HSRP that this is a secondary address range. I am not sure whether the config that you give works, but what I have usually seen is the secondary address specified in the same group as the primary.

HTH

Rick

New Member

Re: hsrp with sub-interface

Hi Rick,

sorry for the typo, yes you are right i was asking the secondary interface.

ok , so which mean if i have secondary interface whereby i need not to put the secondary standby 20 ? for instance, standby 10 and standby 20 ( for secondary interface ) ?

thanks a lot man,

regards,

Jack

126
Views
0
Helpful
2
Replies
CreatePlease login to create content