Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

HSRP

I have two vlans, vlan 100 (170.10.0.0/25) and vlan 200 (170.10.0.128/25)

Vlan 100 is connected to router in interface gig0/0.1 and Vlan 200 is connected to router on interface gig0/0.2

Now consider only for vlan 100

i have a host with ip 170.10.0.1/25 and i have used a virutual ip as 170.10.0.100 and configured both the HSRP routers as 

Router1(config)#int gigabitEthernet 0/0.1
Router1(config-subif)#standby 1 ip 170.10.0.100
Router1(config-subif)#standby 1 priority 200
Router1(config-subif)#standby 1 preempt 
Router1(config-subif)#exit
 %HSRP-6-STATECHANGE: GigabitEthernet0/0.1 Grp 1 state Standby -> Active
Router1(config-subif)#standby 1 track gigabitEthernet 0/1

 

Router2(config)#int gigabitEthernet 0/0.1
Router2(config-subif)#standby 1 ip 170.10.0.100
Router2(config-subif)#standby 1 priority 210
Router2(config-subif)#standby 1 preempt 
Router2(config-subif)#exit
 %HSRP-6-STATECHANGE: GigabitEthernet0/0.1 Grp 1 state Standby -> Active
Router2(config-subif)#standby 1 track gigabitEthernet 0/1

 

Now when i try to ping the virtual ip from my host 170.10.0.1, it gives me request time out.

Are my config right?

12 REPLIES

You config looks fine. I'd

You config looks fine. I'd question why both are going Active. Router2 should have went to a standby state. Can you post "show standby" along with the interface configurations?

HTH, John *** Please rate all useful posts ***
Cisco Employee

John, am I missing something

John, am I missing something or did you?  R2 has a priority of 210 and preempt enabled. R1 has a priority of 200, so R2 preempts and goes active.  R1 went active when it was configured, as it was the only router in the group, but should have gone to standby when R2 went active.

Nope...I missed the priority.

Nope...I missed the priority...

R2 should be active and R1 standby. I have a feeling we don't have all of the information, but yeah, I missed it...

HTH, John *** Please rate all useful posts ***
New Member

Ok here is the complete

Ok here is the complete details of n/w

I have two vlans, vlan 100 (170.10.0.0/25) and vlan 200 (170.10.0.128/25).  Both are connected to a switch and switch is connected to a router.

Vlan 100 is connected to router in interface gig0/0.1 and Vlan 200 is connected to router on interface gig0/0.2

Now consider only for vlan 100

In vlan 100 i  have a host with ip 170.10.0.1/25 and i have used a virutual ip as 170.10.0.100 and configured both the HSRP routers as 

Router1(config)#int gigabitEthernet 0/0.1
Router1(config-subif)#standby 1 ip 170.10.0.100
Router1(config-subif)#standby 1 priority 200
Router1(config-subif)#standby 1 preempt 
Router1(config-subif)#exit
 %HSRP-6-STATECHANGE: GigabitEthernet0/0.1 Grp 1 state Standby -> Active
Router1(config-subif)#standby 1 track gigabitEthernet 0/1

 

Router2(config)#int gigabitEthernet 0/0.1
Router2(config-subif)#standby 1 ip 170.10.0.100
Router2(config-subif)#standby 1 priority 210
Router2(config-subif)#standby 1 preempt 
Router2(config-subif)#exit
 %HSRP-6-STATECHANGE: GigabitEthernet0/0.1 Grp 1 state Standby -> Active
Router2(config-subif)#standby 1 track gigabitEthernet 0/1

Now the R1 is standby and R2 is active.

Now when i try to ping the virtual ip from any of my host in vlan 100, it gives me request time out. I am not able to ping the virtual ip assigned to router.

 

And when i do it without using subinterface i am able to ping it correctly using same config.

By the way i am using packet tracer 6.0.1, does packet tracer 6.0.1 supports HSRP for subinterfaces?

If yes can you just provide me an example.

 

Thanks

 

 

I'm not sure about packet

I'm not sure about packet tracer, but I've heard there are some bugs with it. Can you post "sh run int g0/0.1"

HTH, John *** Please rate all useful posts ***
New Member

Router# sh interfaces

Router# sh interfaces gigabitEthernet 0/0.1
GigabitEthernet0/0.1 is up, line protocol is up (connected)
  Hardware is PQUICC_FEC, address is 00d0.ff2c.ca01 (bia 00d0.ff2c.ca01)
  Internet address is 170.10.0.126/25
  MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec, 
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation 802.1Q Virtual LAN, Vlan ID 100
  ARP type: ARPA, ARP Timeout 04:00:00, 
  Last clearing of "show interface" counters never

Please run "show run int g0/0

Please run "show run int g0/0.1" and post those results. You gave me something entirely different. :)

HTH, John *** Please rate all useful posts ***
New Member

can you please check the

can you please check the command again, there is no such command in packet trace,

what we have is

show running-config 

sh interfaces gigabitEthernet 0/0.1

 

New Member

Do i have to configure switch

Do i have to configure switch connected between vlans and router for HSRP?

 

Post the complete config and

Post the complete config and a screenshot of your layout. I don't have packet tracer, so I'll have to go off of what you can post.

HTH, John *** Please rate all useful posts ***
New Member

I have configured HSRP only

I have configured HSRP only for Vlan 100

 

Config files

FOR ROUTER 0

 

Router# sh running-config 
Building configuration...

Current configuration : 1031 bytes
!
version 15.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router
!
!
!
!
!
!
!
!
!
!
!
!
license udi pid CISCO2911/K9 sn FTX1524SOM6
!
!
!
!
!
spanning-tree mode pvst
!
!
!
!
interface GigabitEthernet0/0
 no ip address
 duplex auto
 speed auto
!
interface GigabitEthernet0/0.1
 encapsulation dot1Q 100
 ip address 170.10.0.126 255.255.255.128
 standby version 2
 standby 1 ip 170.10.0.100
 standby 1 priority 200
 standby 1 preempt
 standby 1 track GigabitEthernet0/1
!
interface GigabitEthernet0/0.2
 encapsulation dot1Q 200
 ip address 170.10.0.254 255.255.255.128
!
interface GigabitEthernet0/1
 ip address 200.10.10.2 255.255.255.252
 duplex auto
 speed auto
!
interface GigabitEthernet0/2
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface Vlan1
 no ip address
 shutdown
!
router eigrp 100
 network 170.10.0.0
 network 200.10.10.0
 no auto-summary
!
ip classless
!
!
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
 login
!
!
!
end

---------------------------------------------------------------------------

 

 

ROUTER 1

Router#sh running-config 
Building configuration...

Current configuration : 1028 bytes
!
version 15.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router
!
!
!
!
!
!
!
!
!
!
!
!
license udi pid CISCO2911/K9 sn FTX152437VH
!
!
!
!
!
spanning-tree mode pvst
!
!
!
!
interface GigabitEthernet0/0
 no ip address
 duplex auto
 speed auto
!
interface GigabitEthernet0/0.1
 encapsulation dot1Q 100
 ip address 170.10.0.125 255.255.255.128
 standby version 2
 standby 1 ip 170.10.0.100
 standby 1 priority 210
 standby 1 preempt
 standby 1 track GigabitEthernet0/1
!
interface GigabitEthernet0/0.2
 encapsulation dot1Q 200
 ip address 170.10.0.253 255.255.255.128
!
interface GigabitEthernet0/1
 ip address 200.20.20.2 255.255.255.252
 duplex auto
 speed auto
!
interface GigabitEthernet0/2
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface Vlan1
 no ip address
 shutdown
!
router eigrp 100
 network 170.10.0.0
 network 200.20.20.0
 auto-summary
!
ip classless
!
!
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
 login
!
!
!
end

-----------------------------------------------------------------------------------------

SWITCH CONFIG

 

Switch#sh running-config 
Building configuration...

Current configuration : 1129 bytes
!
version 12.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Switch
!
!
spanning-tree mode pvst
!
interface FastEthernet0/1
 switchport access vlan 100
!
interface FastEthernet0/2
 switchport access vlan 100
!
interface FastEthernet0/3
 switchport access vlan 200
!
interface FastEthernet0/4
 switchport access vlan 200
!
interface FastEthernet0/5
 switchport mode trunk
!
interface FastEthernet0/6
 switchport mode trunk
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface Vlan1
 no ip address
 shutdown
!
!
line con 0
!
line vty 0 4
 login
line vty 5 15
 login
!
!
end

Ok...the config looks fine to

Ok...the config looks fine to me. If you have your hosts connected to ports 1 and 2 on the switch, and the router is connected to one of the trunk ports, you should be good to go. The only other thing that I would check is that the vlans were in fact created on the switch. Do a "show vlan" on the switch and see if they're there. If they are, I believe you're hitting a bug in packet tracer.

HTH, John *** Please rate all useful posts ***
183
Views
0
Helpful
12
Replies
CreatePlease login to create content