Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

HSRP

Hi ,

I have a simple HSRP connection with 2 routers , 2 switches for redundancy.

Both the routers are used for load balancing instead of just one being Active HSRP and the other Standby.

For ROUTE1 , Router1 acts as Active and Router 2 Standby

For ROUTE2 , Router2 acts as Active and Router1 Standby

Problem is , HSRP standby state on both the routers keeps changing every now and then.

These are the messages I see on both the routers :

Router1 :

Jun 25 14:31:02 BST: %HSRP-6-STATECHANGE: FastEthernet0/1 Grp 15 state Standby -> Active

Jun 25 14:31:03 BST: %HSRP-6-STATECHANGE: FastEthernet0/1 Grp 15 state Active -> Speak

Jun 26 09:49:45 BST: %HSRP-6-STATECHANGE: FastEthernet0/1 Grp 15 state Standby -> Active

Jun 26 09:49:45 BST: %HSRP-6-STATECHANGE: FastEthernet0/1 Grp 15 state Active -> Speak

Jun 28 10:07:27 BST: %HSRP-6-STATECHANGE: FastEthernet0/1 Grp 15 state Standby -> Active

Jun 28 10:07:27 BST: %HSRP-6-STATECHANGE: FastEthernet0/1 Grp 15 state Active -> Speak

Jul 2 09:39:45 BST: %HSRP-6-STATECHANGE: FastEthernet0/1 Grp 15 state Standby -> Active

Jul 2 09:39:45 BST: %HSRP-6-STATECHANGE: FastEthernet0/1 Grp 15 state Active -> Speak

Jul 2 09:56:01 BST: %HSRP-6-STATECHANGE: FastEthernet0/1 Grp 15 state Standby -> Active

Jul 2 09:56:34 BST: %HSRP-6-STATECHANGE: FastEthernet0/1 Grp 15 state Active -> Speak

Jul 2 11:48:50 BST: %HSRP-6-STATECHANGE: FastEthernet0/1 Grp 15 state Standby -> Active

Jul 2 11:48:51 BST: %HSRP-6-STATECHANGE: FastEthernet0/1 Grp 15 state Active -> Speak

ROUTER2 :

Jul 2 09:39:44 BST: %HSRP-6-STATECHANGE: FastEthernet0/1 Grp 10 state Standby - > Active

Jul 2 09:39:45 BST: %HSRP-6-STATECHANGE: FastEthernet0/1 Grp 10 state Active -> Speak

.Jul 2 09:55:59 BST: %HSRP-6-STATECHANGE: FastEthernet0/1 Grp 10 state Standby -> Active

.Jul 2 09:56:01 BST: %HSRP-6-STATECHANGE: FastEthernet0/1 Grp 10 state Active - > Speak

Jul 2 11:07:15 BST: %HSRP-6-STATECHANGE: FastEthernet0/1 Grp 10 state Standby - > Active

Jul 2 11:07:16 BST: %HSRP-6-STATECHANGE: FastEthernet0/1 Grp 10 state Active -> Speak

Jul 2 11:48:50 BST: %HSRP-6-STATECHANGE: FastEthernet0/1 Grp 10 state Standby - > Active

Jul 2 11:48:51 BST: %HSRP-6-STATECHANGE: FastEthernet0/1 Grp 10 state Active -> Speak

Any idea why this is happening.

Thanks in advance.

Pallavi

4 REPLIES

Re: HSRP

Hi

Have u checked the link between the routers,is it working fine.

If can post the config we can check whats going on.

Normally this may be caused due to improper exchange of hello messages between the devices.

Thanks

Mahmood

New Member

Re: HSRP

Thanks Mahmood.

Ya , I have checked the physical connections.No issues with it.

Configs :

ROUTER1 :

int fa0/0

standby 15 ip

standby 15 priority 150

standby 15 preempt

standby 15 track FastEthernet1/1 90

int fa0/1

standby 10 ip

standby 10 preempt

ROUTER2 :

Int fa0/0

standby 10 ip

standby 10 priority 150

standby 10 preempt

standby 10 track FastEthernet1/0 90

int fa0/1

standby 15 ip

standby 15 preempt

Thanks.

Re: HSRP

It feels that the hello packets are getting missed between the routers.

Check for errors on the switch ports where the routers are connected. Make sure there are no duplex issues.

Try chnaging the switchports a well

HTH

Narayan

New Member

Re: HSRP

Checked the Switches for interface errors , speed/duplex mismatch , logs - everything normal.

143
Views
0
Helpful
4
Replies
CreatePlease to create content