Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

HTTP CP 99% cpu utilization in catalyst 2960

Hi everybody!

As the title says, I have a problem with a 2960. When I arrived this morning to the office it was at 99% cpu utilization, permanently. I've issued a show process cpu sorted to localize the problematic process and I've found it is HTTP CP, with a 92-95% of cpu time for it. I shutted down the http secure-server expecting it to disappear from the table, but nothing happend. I issued the process-watchdog terminate, normal and hang commands, and it remains the same.

Even worse. I can't check the running or startup config because it says "Unable to read configuration. ry againg later". I can do a "more config.text" succesfully.

I've searched on the inernet and can't find anything about HTTP CP, neither about being unable to read the running or startup.

By the other way, the catalyst is forwarding packets as usual and there are enough memory free (>30MB for processor) and I can ssh to it.

I'll appreciate any help to let me get rid of this obnoxius process and to be able to read the config again. Thank you.

1 ACCEPTED SOLUTION

Accepted Solutions
Purple

Re: HTTP CP 99% cpu utilization in catalyst 2960

See if there are any hung sessions or sessions that should not be there with the show users command . Terminate any sessions that should not be there otherwise switch reboot may be your only option . Unless you happen to use the gui interface never leave the http function active in the config.

2 REPLIES
Purple

Re: HTTP CP 99% cpu utilization in catalyst 2960

See if there are any hung sessions or sessions that should not be there with the show users command . Terminate any sessions that should not be there otherwise switch reboot may be your only option . Unless you happen to use the gui interface never leave the http function active in the config.

New Member

Re: HTTP CP 99% cpu utilization in catalyst 2960

well, I had to reload. It was impossible to delete that http session.

Thank you anyway.

1069
Views
0
Helpful
2
Replies