Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

Hub-n-Spoke multicast issue !

Hi,

Regarding multicast:- if i have a hub and spoke scenario in which hub is the RP & Mapping agent, and when I ping from one spoke router to another spoke router , I got one reply and then timeout . I tried to figure out by debugs and what I understand is :- when I start sending the traffic , after one packet the traffic flow tries to be converted from Shared tree to SPT for which the receiving router sends prune to the RP ( which is hub ) because it looks another shortest path to the source router via the same DLCI which is actually the same path via hub. What I did to resolve this , I set spt-threshold infinity on the receiving router. It should solve the problem but I again faced the same problem! Can u please clarify! Did I understand the problem correctly & what is the solution of this problem ( except creating a tunnel ) ?

5 REPLIES
Hall of Fame Super Bronze

Re: Hub-n-Spoke multicast issue !

If you are running sparse mode, you need to enable ip nbma-mode on the hub.

If you are running dense mode, you need a GRE tunnel.

HTH,

__

Edison.

Community Member

Re: Hub-n-Spoke multicast issue !

ip pim nbma-mode is already there on hub!

Re: Hub-n-Spoke multicast issue !

Atif, this is an interesting challenge.

I would interested to see the interface configs on the three routers, especially on the receiver. Is the receiver ip igmp join-group on the FR interface, or is it doing multicast-routing with the join-group on another interface? If the join-group is on the FR interface, it may just be a question of no ip route-cache cef on that interface. (If so, I'll explain later.)

Also, after the first ping, what does the OIL look like for the (S,G) entry on the hub? Does it still have the outgoing DLCI, and what are the flags on that?

Kevin Dorrell

Luxembourg

Community Member

Re: Hub-n-Spoke multicast issue !

Wel! i have build the same configuration on Dynamips and it works when i configure " ip pim spt-threshold infinity" on client spoke router. But when i build the same configuration on my rack it is not working! tommorrow i will build the same configuration on rack and will post here! Thanks for replying Kevin!

Best regards!

Community Member

Re: Hub-n-Spoke multicast issue !

Sorry for delay ! Please see the attachment !

159
Views
0
Helpful
5
Replies
CreatePlease to create content