Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

I've a routing problem (RT: del 0.0.0.0)

Hi all,

I have a strange problem, at least for me :), i have a Cisco 1801 ((C180X-BROADBAND-M), Version 12.4(15)T5) with two wan interfaces, an ADSL and a ethernet.

interface FastEthernet0

description Enlace ETH

ip address dhcp client-id FastEthernet0

ip nat outside

ip virtual-reassembly

duplex auto

speed auto

!

interface ATM0

no ip address

no atm ilmi-keepalive

dsl operating-mode auto

!

interface ATM0.1 point-to-point

pvc 8/32

encapsulation aal5snap

pppoe-client dial-pool-number 1

!

!

interface Dialer1

description ADSL IP DINAMICA

ip address negotiated

ip mtu 1492

ip nat outside

ip virtual-reassembly

encapsulation ppp

dialer pool 1

dialer-group 1

ppp authentication pap callin

ppp pap sent-username xxx password xxx

!

My default gateway is via static route throught wan ethernet.

ip route 0.0.0.0 0.0.0.0 FastEthernet0 x.x.x.x track 100

and the backup is ADSL,

ip route 0.0.0.0 0.0.0.0 Dialer1 200

I have an object track to manage the backup

track 100 rtr 1 reachability

delay down 15

ip sla 1

! ip de google

icmp-echo 66.102.9.99 source-interface FastEthernet0

timeout 3000

threshold 5

frequency 3

ip sla schedule 1 life forever start-time now

Other routes,

ip route 66.x.x.99 255.255.255.255 FastEthernet0 x.x.x.x

ip route 66.x.x.99 255.255.255.255 Null0 200

ip route 1.1.1.1 255.255.255.255 Dialer1

ip route 2.2.2.2 255.255.255.255 Dialer1

ip route 3.3.3.3 255.255.255.255 Dialer1

Now, my problem.

A couple of minutes later of set default gateway, this route disappear and router set its default gateway to Dialer1 (ADSL).

The debug of ip routing i attached because characters limitations

the change of route is at *Oct 29 08:24:57.437

Some ideas?

Thanks in advance

6 REPLIES
Hall of Fame Super Silver

Re: I've a routing problem (RT: del 0.0.0.0)

David

The debug that you posted is only debug of ip routing and it does not give a full picture of what is going on. My guess is that at 08:24:57.437 your track reported that 66.102.9.99 was no longer reachable via the next hop through FastEthernet0 which results in withdrawal of the default route through that interface. Can you get a debug output that combines ip routing and of the track activity?

HTH

Rick

New Member

Re: I've a routing problem (RT: del 0.0.0.0)

Hi Rick, thank you for your answer.

I forgot before speak about track.

The track debug is on and 66.102.9.99 is avaiable always.

The active debugs are,

sh debugging

Track debugging is on

IP routing:

IP routing debugging is on

IP-STATIC:

IP static routing destination debugging is on, for 0.0.0.0 0.0.0.0

IP static routing detail debugging is on

IP static routing time spent debugging is on

IP static routing summary debugging is on

and show track command show that reachability is up

Track 100

Response Time Reporter 1 reachability

Reachability is Up

9 changes, last change 00:22:53

Delay down 15 secs

Latest operation return code: Over threshold

Latest RTT (millisecs) 71

Tracked by:

STATIC-IP-ROUTING 0

Cisco Employee

Re: I've a routing problem (RT: del 0.0.0.0)

Hi David,

What's the present status. Which route is being installed as the IP SLA is reporting the tracking correctly and object is up.

Please paste the " show logs " from the router.

-amit singh

New Member

Re: I've a routing problem (RT: del 0.0.0.0)

In this moment.

#sh track

Track 100

Response Time Reporter 1 reachability

Reachability is Up

9 changes, last change 00:42:58

Delay down 15 secs

Latest operation return code: Over threshold

Latest RTT (millisecs) 72

Tracked by:

STATIC-IP-ROUTING 0

S* 0.0.0.0/0 is directly connected, Dialer1

#sh ip ro 0.0.0.0

Routing entry for 0.0.0.0/0, supernet

Known via "static", distance 200, metric 0 (connected), candidate default path

Routing Descriptor Blocks:

* directly connected, via Dialer1

Route metric is 0, traffic share count is 1

#sh run | i ip route

ip route 0.0.0.0 0.0.0.0 FastEthernet0 x.x.x.x track 100

ip route 0.0.0.0 0.0.0.0 Dialer1 200

other output ommited.

New Member

Re: I've a routing problem (RT: del 0.0.0.0)

Hello..

Why do you have two interfaces ,Fe0 & dial0 as ' ip nat outside '. Just curious!!

New Member

Re: I've a routing problem (RT: del 0.0.0.0)

Hello,

Because that two are wan interfaces and i need to overload in both.

222
Views
0
Helpful
6
Replies
CreatePlease to create content