Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

%ILPOWER-3-CONTROLLER_PORT_ERR: Controller port error

Hi,

I am seeing this error message contineously in one of our 3750 switches. None of the IP phones are getting powered in that switch. Please suggest whether this leads to any hardware / software issues.

%ILPOWER-3-CONTROLLER_PORT_ERR: Controller port error, Interface Gi2/0/16: Power given, but power controller doesn't report Power good

Thanks in adv,

Guru

12 REPLIES
New Member

Re: %ILPOWER-3-CONTROLLER_PORT_ERR: Controller port error

Hi Guru,

I don't recognise this exact message ("Power good"...) but normally it means that the switch has detected a POE device and has powered up the port however the link has still not come up. Are you certain the switch and phones are compatible?

Cheers

Hall of Fame Super Gold

Re: %ILPOWER-3-CONTROLLER_PORT_ERR: Controller port error

What is your switch IOS version?

New Member

Re: %ILPOWER-3-CONTROLLER_PORT_ERR: Controller port error

I have also faced the same issue.

My ios version is c3750e-universal-mz.122-35.SE5.bin

Plz let me know if you find nay solution

New Member

Re: %ILPOWER-3-CONTROLLER_PORT_ERR: Controller port error

Hi

After removing the switch from stack and rebooting the switch the problem got resolved.

Any idea as i have to give root cause to customer.

Thanks

Rupam

Re: %ILPOWER-3-CONTROLLER_PORT_ERR: Controller port error

Some of the earlier POE devices had a maximum number of ports that could be powered. If you plug in too many devices, you won't get power on all the ports.

You can also check by giving the following command:

Switch#sh power inline

Secondly It could be a bug and getting the same syslog message for the Type 1 token ring patch port.

CSCed09484

When a type 1 Token Ring patch cable is connected to a PoE port, these syslog messages appear every 10 seconds:

-00:01:06: %ILPOWER-3-CONTROLLER_PORT_ERR: Controller port error,

here is no workaround. However, when a valid link partner is connected to the PoE port, it operates normally and without user intervention.

Just FYI

Regards,

Anser

New Member

Re: %ILPOWER-3-CONTROLLER_PORT_ERR: Controller port error

I had the same problemon a 3550-24PW switch which was solved by using the following command on all the fastethernet ports

Switch_Admin(config-if)#power inline delay shutdown 20 initial 100

All phones work now using PoE

Good luck

New Member

%ILPOWER-3-CONTROLLER_PORT_ERR: Controller port error

smartns04, thanks for that command. It helped me resolve a similar issue that I faced with my 3550 switch. But certainly not what the original poster encountered on the 3750.

New Member

%ILPOWER-3-CONTROLLER_PORT_ERR: Controller port error

Hi smartns04,

Thanks Man!! It really worked for me!! After the CUCM upgrade half of my IP Phones were not coming up because of this error. Your command helped me.

Regards,

Fawaz

Re: %ILPOWER-3-CONTROLLER_PORT_ERR: Controller port error

Hi Guru

Kindly refer to the document https://supportforums.cisco.com/docs/DOC-27050 for the workaround.

Looks like you might hitting the bug CSCsw18530

Also there had been previous discussion related to this, issue https://supportforums.cisco.com/thread/157276

Kindly rate the answers,you find it helpful.

Regards

Sivagami.N

New Member

%ILPOWER-3-CONTROLLER_PORT_ERR: Controller port error

Same problems on C3560-48PS, running 12.2(55)SE6.

No possibillity to configure mentioned configuration on the interface.

We've than exchanged the switch, but problem still occured on the same port.

So might be the end-device be the problem? (Alcatel ipTouch)

New Member

I fixed this issue today.

I fixed this issue today.  The physical Cat5e cable was damaged.  I had to use a different cable run back to the switch and that fixed the issue.  I put a printer on the damaged cable run and lowered the speed of the port to 10mbps until we can get new cabling installed.

New Member

If they are GigabitEthernet

If they are GigabitEthernet ports you can initiate the command 

'test cable-diagnostics tdr interface GigabitEthernet (port)'

and then initiate

'show cable-diagnostics tdr interface GigabitEthernet (port)'

 

this will show you if there's a fault in the cable and in what pairs.

43085
Views
37
Helpful
12
Replies