Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

im dying to solve the asa issue with internet site to site !

hi all ,

i have topology as below :

(192.168.2.0/24)LAN1------ASA1--=====internet=======ASA2-----------lan2(192.168.0.0/24)

note that ASA2 has another site to site vpn and has remote access vpn.

ive setup site to site vpn between ASA1 & ASA2 , note that LAN1 can reach LAN2 and its fine

but ,

LAN1 cant use internet by ASA2 ??

my goal now is , i want LAN1 (192.168.2.0) to use ASA2 when it need internet .

i will pasted config of two asas:

Result of the command: "show run"

: Saved
:
ASA Version 8.4(4)1 
!
hostname ciscoasa
enable password r5pjmbuPbmjfkxyd encrypted
passwd 2KFQnbNIdI.2KYOU encrypted
names
!
interface Ethernet0/0
 switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
interface Vlan1
 nameif inside
 security-level 100
 ip address 192.168.2.1 255.255.255.0 
!
interface Vlan2
 nameif outside
 security-level 0
 ip address 116.254.100.230 255.255.255.252 
!
ftp mode passive
clock timezone JAVT 7
dns domain-lookup inside
same-security-traffic permit inter-interface
same-security-traffic permit intra-interface
object network obj_any
 subnet 0.0.0.0 0.0.0.0
object network Cikupa-Subnet
 subnet 192.168.2.0 255.255.255.0
 description Cikupa Subnet
object network Matraman-Firewall
 host 116.254.102.65
 description Cikupa Firewall
object service port8080
 service tcp source eq 8080 
 description port8080
object network NETWORK_OBJ_192.168.2.0_24
 subnet 192.168.2.0 255.255.255.0
object network any1
 subnet 0.0.0.0 0.0.0.0
object network 8.8.8.8
 subnet 8.8.8.0 255.255.255.0
object network drx
 subnet 192.168.2.0 255.255.255.0
 description drx
object network In
 subnet 192.168.2.0 255.255.255.0
 description In
object network Ano
 subnet 0.0.0.0 0.0.0.0
 description Ano
object network 192.168.2.20
 host 192.168.2.20
object network me
 host 192.168.2.20
access-list global_access extended permit icmp any any 
access-list inside_access_in extended permit ip any any 
access-list outside_cryptomap extended permit ip object In object Ano 
access-list outside_access_in extended permit ip any any 
pager lines 24
logging enable
logging asdm informational
mtu inside 1500
mtu outside 1500
icmp unreachable rate-limit 1 burst-size 1
no asdm history enable
arp timeout 14400
access-group inside_access_in in interface inside
access-group outside_access_in in interface outside
access-group global_access global
route outside 0.0.0.0 0.0.0.0 116.254.100.229 1
route outside 176.58.0.0 255.255.0.0 116.254.102.65 1
timeout xlate 3:00:00
timeout pat-xlate 0:00:30
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
timeout floating-conn 0:00:00
dynamic-access-policy-record DfltAccessPolicy
user-identity default-domain LOCAL
http server enable
http 192.168.2.0 255.255.255.0 inside
http 0.0.0.0 0.0.0.0 outside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart warmstart
sysopt connection preserve-vpn-flows
crypto ipsec ikev1 transform-set ESP-AES-128-SHA esp-aes esp-sha-hmac 
crypto ipsec ikev1 transform-set ESP-AES-128-MD5 esp-aes esp-md5-hmac 
crypto ipsec ikev1 transform-set ESP-AES-192-SHA esp-aes-192 esp-sha-hmac 
crypto ipsec ikev1 transform-set ESP-AES-192-MD5 esp-aes-192 esp-md5-hmac 
crypto ipsec ikev1 transform-set ESP-AES-256-SHA esp-aes-256 esp-sha-hmac 
crypto ipsec ikev1 transform-set ESP-AES-256-MD5 esp-aes-256 esp-md5-hmac 
crypto ipsec ikev1 transform-set ESP-3DES-SHA esp-3des esp-sha-hmac 
crypto ipsec ikev1 transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac 
crypto ipsec ikev1 transform-set ESP-DES-SHA esp-des esp-sha-hmac 
crypto ipsec ikev1 transform-set ESP-DES-MD5 esp-des esp-md5-hmac 
crypto ipsec ikev1 transform-set VPN_Cikupa_Trans esp-aes esp-sha-hmac 
crypto ipsec security-association replay disable
crypto map outside_map 1 match address outside_cryptomap
crypto map outside_map 1 set pfs 
crypto map outside_map 1 set peer 116.254.102.65 
crypto map outside_map 1 set ikev1 transform-set ESP-AES-128-SHA ESP-AES-128-MD5 ESP-AES-192-SHA ESP-AES-192-MD5 ESP-AES-256-SHA ESP-AES-256-MD5 ESP-3DES-SHA ESP-

3DES-MD5 ESP-DES-SHA ESP-DES-MD5
crypto map outside_map 1 set reverse-route
crypto map outside_map interface outside
crypto ikev2 enable outside
crypto ikev1 enable outside
crypto ikev1 policy 10
 authentication crack
 encryption aes-256
 hash sha
 group 2
 lifetime 86400
crypto ikev1 policy 20
 authentication rsa-sig
 encryption aes-256
 hash sha
 group 2
 lifetime 86400
crypto ikev1 policy 30
 authentication pre-share
 encryption aes-256
 hash sha
 group 2
 lifetime 86400
crypto ikev1 policy 40
 authentication crack
 encryption aes-192
 hash sha
 group 2
 lifetime 86400
crypto ikev1 policy 50
 authentication rsa-sig
 encryption aes-192
 hash sha
 group 2
 lifetime 86400
crypto ikev1 policy 60
 authentication pre-share
 encryption aes-192
 hash sha
 group 2
 lifetime 86400
crypto ikev1 policy 70
 authentication crack
 encryption aes
 hash sha
 group 2
 lifetime 86400
crypto ikev1 policy 80
 authentication rsa-sig
 encryption aes
 hash sha
 group 2
 lifetime 86400
crypto ikev1 policy 90
 authentication pre-share
 encryption aes
 hash sha
 group 2
 lifetime 86400
crypto ikev1 policy 100
 authentication crack
 encryption 3des
 hash sha
 group 2
 lifetime 86400
crypto ikev1 policy 110
 authentication rsa-sig
 encryption 3des
 hash sha
 group 2
 lifetime 86400
crypto ikev1 policy 120
 authentication pre-share
 encryption 3des
 hash sha
 group 2
 lifetime 86400
crypto ikev1 policy 130
 authentication crack
 encryption des
 hash sha
 group 2
 lifetime 86400
crypto ikev1 policy 140
 authentication rsa-sig
 encryption des
 hash sha
 group 2
 lifetime 86400
crypto ikev1 policy 150
 authentication pre-share
 encryption des
 hash sha
 group 2
 lifetime 86400
telnet 192.168.2.0 255.255.255.0 inside
telnet 0.0.0.0 0.0.0.0 outside
telnet timeout 5
ssh timeout 5
ssh key-exchange group dh-group1-sha1
console timeout 0

dhcpd dns 8.8.8.8
!
dhcpd address 192.168.2.100-192.168.2.254 inside
dhcpd dns 8.8.8.8 8.8.8.4 interface inside
dhcpd enable inside
!
threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
webvpn
group-policy DfltGrpPolicy attributes
 vpn-tunnel-protocol ikev1 l2tp-ipsec ssl-clientless
group-policy GroupPolicy_116.254.102.65 internal
group-policy GroupPolicy_116.254.102.65 attributes
 vpn-tunnel-protocol ikev1 
tunnel-group DefaultL2LGroup ipsec-attributes
 ikev1 pre-shared-key *****
 ikev2 local-authentication pre-shared-key *****
tunnel-group 116.254.102.65 type ipsec-l2l
tunnel-group 116.254.102.65 general-attributes
 default-group-policy GroupPolicy_116.254.102.65
tunnel-group 116.254.102.65 ipsec-attributes
 ikev1 pre-shared-key *****
!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
 parameters
  message-length maximum client auto
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect dns preset_dns_map 
  inspect ftp 
  inspect h323 h225 
  inspect h323 ras 
  inspect rsh 
  inspect rtsp 
  inspect esmtp 
  inspect sqlnet 
  inspect skinny  
  inspect sunrpc 
  inspect xdmcp 
  inspect sip  
  inspect netbios 
  inspect tftp 
  inspect ip-options 
  inspect icmp 
!
service-policy global_policy global
prompt hostname context 
no call-home reporting anonymous
Cryptochecksum:ae19ab43e7e68ed4283beab2d1179bf4
: end


CISCO :
hi all ,
i have topology as below :

(192.168.2.0/24)LAN1------ASA1--=====internet=======ASA2-----------lan2(192.168.0.0/24)


note that ASA2 has another site to site vpn and has remote access vpn.

ive setup site to site vpn between ASA1 & ASA2 , note that LAN1 can reach LAN2 and its fine

but ,

LAN1 cant use internet by ASA2 ??!!! 

my goal now is , i want LAN1 (192.168.2.0) to use ASA2 when it need internet .


i will pasted config of two asas:

ASA1 config:
========================================
Result of the command: "show run"
 
 
: Saved
:
ASA Version 8.4(4)1 
!
hostname ciscoasa
enable password dfdsfdsdsbmjfkxyd encrypted
passwd dsdsdsvIdI.2KYOU encrypted
names
!
interface Ethernet0/0
 switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
interface Vlan1
 nameif inside
 security-level 100
 ip address 192.168.2.1 255.255.255.0 
!
interface Vlan2
 nameif outside
 security-level 0
 ip address x.x.100.230 255.255.255.252 
!
ftp mode passive
clock timezone JAVT 7
dns domain-lookup inside
same-security-traffic permit inter-interface
same-security-traffic permit intra-interface
object network obj_any
 subnet 0.0.0.0 0.0.0.0
object network Cikupa-Subnet
 subnet 192.168.2.0 255.255.255.0
 description Cikupa Subnet
object network Matraman-Firewall
 host x.x.102.65
 description Cikupa Firewall
object service port8080
 service tcp source eq 8080 
 description port8080
object network NETWORK_OBJ_192.168.2.0_24
 subnet 192.168.2.0 255.255.255.0
object network any1
 subnet 0.0.0.0 0.0.0.0
object network 8.8.8.8
 subnet 8.8.8.0 255.255.255.0
object network drx
 subnet 192.168.2.0 255.255.255.0
 description drx
object network In
 subnet 192.168.2.0 255.255.255.0
 description In
object network Ano
 subnet 0.0.0.0 0.0.0.0
 description Ano
object network 192.168.2.20
 host 192.168.2.20
object network me
 host 192.168.2.20
access-list global_access extended permit icmp any any 
access-list inside_access_in extended permit ip any any 
access-list outside_cryptomap extended permit ip object In object Ano 
access-list outside_access_in extended permit ip any any 
pager lines 24
logging enable
logging asdm informational
mtu inside 1500
mtu outside 1500
icmp unreachable rate-limit 1 burst-size 1
no asdm history enable
arp timeout 14400
access-group inside_access_in in interface inside
access-group outside_access_in in interface outside
access-group global_access global
route outside 0.0.0.0 0.0.0.0 x.x.100.229 1
route outside 176.58.0.0 255.255.0.0 x.x.102.65 1
timeout xlate 3:00:00
timeout pat-xlate 0:00:30
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
timeout floating-conn 0:00:00
dynamic-access-policy-record DfltAccessPolicy
user-identity default-domain LOCAL
http server enable
http 192.168.2.0 255.255.255.0 inside
http 0.0.0.0 0.0.0.0 outside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart warmstart
sysopt connection preserve-vpn-flows
crypto ipsec ikev1 transform-set ESP-AES-128-SHA esp-aes esp-sha-hmac 
crypto ipsec ikev1 transform-set ESP-AES-128-MD5 esp-aes esp-md5-hmac 
crypto ipsec ikev1 transform-set ESP-AES-192-SHA esp-aes-192 esp-sha-hmac 
crypto ipsec ikev1 transform-set ESP-AES-192-MD5 esp-aes-192 esp-md5-hmac 
crypto ipsec ikev1 transform-set ESP-AES-256-SHA esp-aes-256 esp-sha-hmac 
crypto ipsec ikev1 transform-set ESP-AES-256-MD5 esp-aes-256 esp-md5-hmac 
crypto ipsec ikev1 transform-set ESP-3DES-SHA esp-3des esp-sha-hmac 
crypto ipsec ikev1 transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac 
crypto ipsec ikev1 transform-set ESP-DES-SHA esp-des esp-sha-hmac 
crypto ipsec ikev1 transform-set ESP-DES-MD5 esp-des esp-md5-hmac 
crypto ipsec ikev1 transform-set VPN_Cikupa_Trans esp-aes esp-sha-hmac 
crypto ipsec security-association replay disable
crypto map outside_map 1 match address outside_cryptomap
crypto map outside_map 1 set pfs 
crypto map outside_map 1 set peerx.x.102.65 
crypto map outside_map 1 set ikev1 transform-set ESP-AES-128-SHA ESP-AES-128-MD5 ESP-AES-192-SHA ESP-AES-192-MD5 ESP-AES-256-SHA ESP-AES-256-MD5 ESP-3DES-SHA ESP-
 
 
3DES-MD5 ESP-DES-SHA ESP-DES-MD5
crypto map outside_map 1 set reverse-route
crypto map outside_map interface outside
crypto ikev2 enable outside
crypto ikev1 enable outside
crypto ikev1 policy 10
 authentication crack
 encryption aes-256
 hash sha
 group 2
 lifetime 86400
crypto ikev1 policy 20
 authentication rsa-sig
 encryption aes-256
 hash sha
 group 2
 lifetime 86400
crypto ikev1 policy 30
 authentication pre-share
 encryption aes-256
 hash sha
 group 2
 lifetime 86400
crypto ikev1 policy 40
 authentication crack
 encryption aes-192
 hash sha
 group 2
 lifetime 86400
crypto ikev1 policy 50
 authentication rsa-sig
 encryption aes-192
 hash sha
 group 2
 lifetime 86400
crypto ikev1 policy 60
 authentication pre-share
 encryption aes-192
 hash sha
 group 2
 lifetime 86400
crypto ikev1 policy 70
 authentication crack
 encryption aes
 hash sha
 group 2
 lifetime 86400
crypto ikev1 policy 80
 authentication rsa-sig
 encryption aes
 hash sha
 group 2
 lifetime 86400
crypto ikev1 policy 90
 authentication pre-share
 encryption aes
 hash sha
 group 2
 lifetime 86400
crypto ikev1 policy 100
 authentication crack
 encryption 3des
 hash sha
 group 2
 lifetime 86400
crypto ikev1 policy 110
 authentication rsa-sig
 encryption 3des
 hash sha
 group 2
 lifetime 86400
crypto ikev1 policy 120
 authentication pre-share
 encryption 3des
 hash sha
 group 2
 lifetime 86400
crypto ikev1 policy 130
 authentication crack
 encryption des
 hash sha
 group 2
 lifetime 86400
crypto ikev1 policy 140
 authentication rsa-sig
 encryption des
 hash sha
 group 2
 lifetime 86400
crypto ikev1 policy 150
 authentication pre-share
 encryption des
 hash sha
 group 2
 lifetime 86400
telnet 192.168.2.0 255.255.255.0 inside
telnet 0.0.0.0 0.0.0.0 outside
telnet timeout 5
ssh timeout 5
ssh key-exchange group dh-group1-sha1
console timeout 0
 
 
dhcpd dns 8.8.8.8
!
dhcpd address 192.168.2.100-192.168.2.254 inside
dhcpd dns 8.8.8.8 8.8.8.4 interface inside
dhcpd enable inside
!
threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
webvpn
group-policy DfltGrpPolicy attributes
 vpn-tunnel-protocol ikev1 l2tp-ipsec ssl-clientless
group-policy GroupPolicy_x.x.102.65 internal
group-policy GroupPolicy_x.x.102.65 attributes
 vpn-tunnel-protocol ikev1 
tunnel-group DefaultL2LGroup ipsec-attributes
 ikev1 pre-shared-key *****
 ikev2 local-authentication pre-shared-key *****
tunnel-group x.x.102.65 type ipsec-l2l
tunnel-group x.x.102.65 general-attributes
 default-group-policy GroupPolicy_x.x.102.65
tunnel-group x.x.102.65 ipsec-attributes
 ikev1 pre-shared-key *****
!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
 parameters
  message-length maximum client auto
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect dns preset_dns_map 
  inspect ftp 
  inspect h323 h225 
  inspect h323 ras 
  inspect rsh 
  inspect rtsp 
  inspect esmtp 
  inspect sqlnet 
  inspect skinny  
  inspect sunrpc 
  inspect xdmcp 
  inspect sip  
  inspect netbios 
  inspect tftp 
  inspect ip-options 
  inspect icmp 
!
service-policy global_policy global
prompt hostname context 
no call-home reporting anonymous
Cryptochecksum:ae19ab43e7e68ed4283beab2d1179bf4
: end
==========================================================

 


Now ON ASA2 , i have
=================================
Result of the command: "show run"
 
 
: Saved
:
ASA Version 8.4(4)1 
!
hostname ciscoasa
enable passwordd sdsdsmjfkxyd encrypted
passwd sdsdQnbNIdI.2KYOU encrypted
names
!
interface Ethernet0/0
 switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
interface Vlan1
 nameif inside
 security-level 100
 ip address 192.168.0.1 255.255.255.0 
!
interface Vlan2
 nameif outside
 security-level 10
 ip address x.x.102.65 255.255.255.248 
!
ftp mode passive
clock timezone JAVT 7
dns domain-lookup inside
same-security-traffic permit inter-interface
same-security-traffic permit intra-interface
object network obj_any
 subnet 0.0.0.0 0.0.0.0
object network NETWORK_OBJ_192.168.1.0_24
 subnet 192.168.1.0 255.255.255.0
object network Cikupa
 subnet 192.168.3.0 255.255.255.0
object network Matraman-Subnet
 subnet 192.168.0.0 255.255.255.0
object network Cikupa-Subnet
 subnet 192.168.2.0 255.255.255.0
object network obj-vpnpool
 subnet 192.168.1.0 255.255.255.0
object network obj-remote
 subnet 192.168.2.0 255.255.255.0
object network ANY-0.0.0.0
 subnet 192.168.2.0 255.255.255.0
object network obj-branch
 subnet 192.168.2.0 255.255.255.0
object network Cikupa-Firewall
 host 10.20.10.6
 description Cikupa Firewall
object service GmailIMAP
 service tcp destination eq 993 
 description Gmail IMAP
object service GmailSMTP
 service tcp destination eq 465 
 description Gmail SMTP
object service GmailPOP3
 service tcp source range 1 65535 destination eq 995 
 description POP3 Gmail
object service CCTV
 service tcp source range 1 65535 destination eq 8080 
 description Port CCTV Cikupa
object service RemoteDesktop
 service tcp destination eq 3389 
 description Remote Desktop Protocol
object network ASDM
 host 192.168.0.1
object service HTTP
 service tcp destination eq www 
object service HTTPProxy
 service tcp destination eq 8443 
object service AzureWingateProxy
 service tcp destination eq 8088 
object network AzureProxy-Deleteme
 host 192.168.6.44
object network Paul-Deleteme
 host 192.168.0.165
object service Zabbix
 service tcp destination eq 10051 
 description Zabbix 10051
object network SAP_Integration_server
 host 192.168.0.102
object network ProXL
 subnet 112.215.0.0 255.255.0.0
object network NETWORK_OBJ_192.168.0.0_24
 subnet 192.168.0.0 255.255.255.0
object network NETWORK_OBJ_192.168.2.0_24
 subnet 192.168.2.0 255.255.255.0
object network neetttt
 host 192.168.0.102
object network xyz
 subnet 192.168.2.0 255.255.255.0
object network rdp
 host 192.168.0.102
 description rdp
object network 555
 host 192.168.0.102
 description 555
z
object service hhhh
 service tcp destination eq 3389 
object-group network AzureNetwork
 network-object 192.168.6.0 255.255.255.0
object-group network BetaOnpremise
 network-object 192.168.0.0 255.255.255.0
object-group network DM_INLINE_NETWORK_1
 network-object hos tz.z.z.35
 network-object host z.z.z.36
object-group service DM_INLINE_SERVICE_1
 service-object object GmailIMAP 
 service-object object GmailSMTP 
 service-object tcp destination eq www 
 service-object tcp destination eq https 
 service-object object GmailPOP3 
 service-object object RemoteDesktop 
 service-object tcp destination eq ftp 
 service-object tcp destination eq ftp-data 
 service-object object AzureWingateProxy 
object-group protocol TCPUDP
 protocol-object udp
 protocol-object tcp
object-group service POP3Gmail tcp
 description Untuk Download email
 port-object eq 995
object-group network xyzem1
 network-object object NETWORK_OBJ_192.168.0.0_24
 network-object object ProXL
access-list AzureAccessList extended permit ip object-group BetaOnpremise object-group AzureNetwork 
access-list betapramesti_splitTunnelAcl standard permit 192.168.0.0 255.255.255.0 
access-list global_access extended permit ip any any log errors 
access-list global_access extended permit object HTTPProxy object ProXL object SAP_Integration_server inactive 
access-list inside_access_in extended permit object-group DM_INLINE_SERVICE_1 any any log errors inactive 
access-list inside_access_in extended permit object-group TCPUDP any object-group DM_INLINE_NETWORK_1 eq domain log disable inactive 
access-list inside_access_in extended permit tcp any host 137.116.130.46 log inactive 
access-list inside_access_in extended permit tcp any object Cikupa-Subnet log debugging inactive 
access-list inside_access_in extended permit ip any any log 
access-list outside_access_in extended permit ip any any 
access-list outside_access_in extended permit ip anyx.x.102.64 255.255.255.248 
access-list outside_cryptomap extended permit ip object-group xyzem1 object Cikupa-Subnet 
pager lines 24
logging enable
logging asdm informational
mtu inside 1500
mtu outside 1500
ip local pool Beta_VPN_Uusers 192.168.1.100-192.168.1.254 mask 255.255.255.0
no failover
icmp unreachable rate-limit 1 burst-size 1
no asdm history enable
arp timeout 14400
nat (inside,outside) source static NETWORK_OBJ_192.168.0.0_24 NETWORK_OBJ_192.168.0.0_24 destination static Cikupa-Subnet Cikupa-Subnet no-proxy-arp route-lookup
nat (inside,any) source static NETWORK_OBJ_192.168.0.0_24 NETWORK_OBJ_192.168.0.0_24 destination static obj-vpnpool obj-vpnpool no-proxy-arp route-lookup
nat (outside,inside) source static NETWORK_OBJ_192.168.2.0_24 NETWORK_OBJ_192.168.2.0_24 destination static NETWORK_OBJ_192.168.0.0_24 NETWORK_OBJ_192.168.0.0_24 no-proxy-arp route-lookup
nat (inside,outside) source static BetaOnpremise BetaOnpremise destination static AzureNetwork AzureNetwork no-proxy-arp route-lookup
nat (inside,outside) source static rdp interface service hhhh hhhh inactive
nat (inside,outside) source static Matraman-Subnet Matraman-Subnet destination static Cikupa Cikupa no-proxy-arp route-lookup
nat (inside,outside) source dynamic NETWORK_OBJ_192.168.0.0_24 interface
nat (outside,outside) source dynamic NETWORK_OBJ_192.168.0.0_24 interface
nat (inside,outside) source static Paul-Deleteme ASDM destination static obj_any AzureProxy-Deleteme service HTTP HTTPProxy inactive
nat (inside,outside) source static obj-remote obj-remote destination static obj-vpnpool obj-vpnpool no-proxy-arp route-lookup inactive
nat (outside,outside) source static obj-vpnpool obj-vpnpool destination static obj-remote obj-remote inactive
nat (inside,outside) source static BetaOnpremise BetaOnpremise destination static NETWORK_OBJ_192.168.1.0_24 NETWORK_OBJ_192.168.1.0_24 inactive
nat (inside,outside) source static Matraman-Subnet Matraman-Subnet destination static Cikupa-Subnet Cikupa-Subnet no-proxy-arp route-lookup inactive
nat (inside,outside) source static Matraman-Subnet Matraman-Subnet destination static NETWORK_OBJ_192.168.1.0_24 NETWORK_OBJ_192.168.1.0_24 no-proxy-arp route-lookup inactive
nat (inside,outside) source static BetaOnpremise ASDM destination static AzureNetwork AzureNetwork service HTTP AzureWingateProxy inactive
access-group inside_access_in in interface inside
access-group outside_access_in in interface outside
access-group global_access global
route outside 0.0.0.0 0.0.0.0 x.x.102.70 1
timeout xlate 3:00:00
timeout pat-xlate 0:00:30
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
timeout floating-conn 0:00:00
dynamic-access-policy-record DfltAccessPolicy
user-identity default-domain LOCAL
aaa authentication ssh console LOCAL 
http server enable
http 192.168.0.0 255.255.255.0 inside
http 192.168.1.0 255.255.255.0 inside
http 0.0.0.0 0.0.0.0 outside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart warmstart
sysopt connection tcpmss 1350
sysopt connection preserve-vpn-flows
crypto ipsec ikev1 transform-set Azure_IPSecTransformSet esp-aes esp-sha-hmac 
crypto ipsec ikev1 transform-set ESP-AES-256-MD5 esp-aes-256 esp-md5-hmac 
crypto ipsec ikev1 transform-set ESP-DES-SHA esp-des esp-sha-hmac 
crypto ipsec ikev1 transform-set ESP-3DES-SHA esp-3des esp-sha-hmac 
crypto ipsec ikev1 transform-set ESP-DES-MD5 esp-des esp-md5-hmac 
crypto ipsec ikev1 transform-set ESP-AES-192-MD5 esp-aes-192 esp-md5-hmac 
crypto ipsec ikev1 transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac 
crypto ipsec ikev1 transform-set ESP-AES-256-SHA esp-aes-256 esp-sha-hmac 
crypto ipsec ikev1 transform-set ESP-AES-128-SHA esp-aes esp-sha-hmac 
crypto ipsec ikev1 transform-set ESP-AES-192-SHA esp-aes-192 esp-sha-hmac 
crypto ipsec ikev1 transform-set ESP-AES-128-MD5 esp-aes esp-md5-hmac 
crypto ipsec ikev1 transform-set TRANS_ESP_3DES_SHA esp-3des esp-sha-hmac 
crypto ipsec ikev1 transform-set TRANS_ESP_3DES_SHA mode transport
crypto ipsec ikev1 transform-set VPN_Cikupa_Tran esp-aes esp-sha-hmac 
crypto ipsec ikev2 ipsec-proposal DES
 protocol esp encryption des
 protocol esp integrity sha-1 md5
crypto ipsec ikev2 ipsec-proposal 3DES
 protocol esp encryption 3des
 protocol esp integrity sha-1 md5
crypto ipsec ikev2 ipsec-proposal AES
 protocol esp encryption aes
 protocol esp integrity sha-1 md5
crypto ipsec ikev2 ipsec-proposal AES192
 protocol esp encryption aes-192
 protocol esp integrity sha-1 md5
crypto ipsec ikev2 ipsec-proposal AES256
 protocol esp encryption aes-256
 protocol esp integrity sha-1 md5
crypto ipsec security-association lifetime seconds 3600
crypto ipsec security-association lifetime kilobytes 102400000
crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set pfs group1
crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set ikev1 transform-set ESP-AES-128-SHA ESP-AES-128-MD5 ESP-AES-192-SHA ESP-AES-192-MD5 ESP-AES-256-SHA ESP-AES-256-MD5 ESP-3DES-SHA ESP-3DES-MD5 ESP-DES-SHA ESP-DES-MD5 TRANS_ESP_3DES_SHA
crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set security-association lifetime seconds 28800
crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set security-association lifetime kilobytes 4608000
crypto map Azure_IPSecCryptoMap 1 match address AzureAccessList
crypto map Azure_IPSecCryptoMap 1 set peer 168.63.250.31 
crypto map Azure_IPSecCryptoMap 1 set ikev1 transform-set Azure_IPSecTransformSet
crypto map Azure_IPSecCryptoMap 1 set ikev2 ipsec-proposal DES 3DES AES AES192 AES256
crypto map Azure_IPSecCryptoMap 1 set reverse-route
crypto map Azure_IPSecCryptoMap 2 match address outside_cryptomap
crypto map Azure_IPSecCryptoMap 2 set pfs 
crypto map Azure_IPSecCryptoMap 2 set peer x.x.100.230 
crypto map Azure_IPSecCryptoMap 2 set ikev1 transform-set ESP-AES-128-SHA ESP-AES-128-MD5 ESP-AES-192-SHA ESP-AES-192-MD5 ESP-AES-256-SHA ESP-AES-256-MD5 ESP-3DES-SHA ESP-3DES-MD5 ESP-DES-SHA ESP-DES-MD5
crypto map Azure_IPSecCryptoMap 65535 ipsec-isakmp dynamic SYSTEM_DEFAULT_CRYPTO_MAP
crypto map Azure_IPSecCryptoMap interface outside
crypto ca trustpoint _SmartCallHome_ServerCA
 crl configure
crypto ca certificate chain _SmartCallHome_ServerCA
 certificate ca 6ecc7aa5a7032009b8cebcf4e952d491
    308205ec 308204d4 a0030201 0202106e cc7aa5a7 032009b8 cebcf4e9 52d49130 
    0d06092a 864886f7 0d010105 05003081 ca310b30 09060355 04061302 55533117 
    30150603 55040a13 0e566572 69536967 6e2c2049 6e632e31 1f301d06 0355040b 
    13165665 72695369 676e2054 72757374 204e6574 776f726b 313a3038 06035504 
    0b133128 63292032 30303620 56657269 5369676e 2c20496e 632e202d 20466f72 
    20617574 686f7269 7a656420 75736520 6f6e6c79 31453043 06035504 03133c56 
    65726953 69676e20 436c6173 73203320 5075626c 69632050 72696d61 72792043 
    65727469 66696361 74696f6e 20417574 686f7269 7479202d 20473530 1e170d31 
    30303230 38303030 3030305a 170d3230 30323037 32333539 35395a30 81b5310b 
    30090603 55040613 02555331 17301506 0355040a 130e5665 72695369 676e2c20 
    496e632e 311f301d 06035504 0b131656 65726953 69676e20 54727573 74204e65 
    74776f72 6b313b30 39060355 040b1332 5465726d 73206f66 20757365 20617420 
    68747470 733a2f2f 7777772e 76657269 7369676e 2e636f6d 2f727061 20286329 
    3130312f 302d0603 55040313 26566572 69536967 6e20436c 61737320 33205365 
    63757265 20536572 76657220 4341202d 20473330 82012230 0d06092a 864886f7 
    0d010101 05000382 010f0030 82010a02 82010100 b187841f c20c45f5 bcab2597 
    a7ada23e 9cbaf6c1 39b88bca c2ac56c6 e5bb658e 444f4dce 6fed094a d4af4e10 
    9c688b2e 957b899b 13cae234 34c1f35b f3497b62 83488174 d188786c 0253f9bc 
    7f432657 5833833b 330a17b0 d04e9124 ad867d64 12dc744a 34a11d0a ea961d0b 
    15fca34b 3bce6388 d0f82d0c 948610ca b69a3dca eb379c00 48358629 5078e845 
    63cd1941 4ff595ec 7b98d4c4 71b350be 28b38fa0 b9539cf5 ca2c23a9 fd1406e8 
    18b49ae8 3c6e81fd e4cd3536 b351d369 ec12ba56 6e6f9b57 c58b14e7 0ec79ced 
    4a546ac9 4dc5bf11 b1ae1c67 81cb4455 33997f24 9b3f5345 7f861af3 3cfa6d7f 
    81f5b84a d3f58537 1cb5a6d0 09e4187b 384efa0f 02030100 01a38201 df308201 
    db303406 082b0601 05050701 01042830 26302406 082b0601 05050730 01861868 
    7474703a 2f2f6f63 73702e76 65726973 69676e2e 636f6d30 12060355 1d130101 
    ff040830 060101ff 02010030 70060355 1d200469 30673065 060b6086 480186f8 
    45010717 03305630 2806082b 06010505 07020116 1c687474 70733a2f 2f777777 
    2e766572 69736967 6e2e636f 6d2f6370 73302a06 082b0601 05050702 02301e1a 
    1c687474 70733a2f 2f777777 2e766572 69736967 6e2e636f 6d2f7270 61303406 
    03551d1f 042d302b 3029a027 a0258623 68747470 3a2f2f63 726c2e76 65726973 
    69676e2e 636f6d2f 70636133 2d67352e 63726c30 0e060355 1d0f0101 ff040403 
    02010630 6d06082b 06010505 07010c04 61305fa1 5da05b30 59305730 55160969 
    6d616765 2f676966 3021301f 30070605 2b0e0302 1a04148f e5d31a86 ac8d8e6b 
    c3cf806a d448182c 7b192e30 25162368 7474703a 2f2f6c6f 676f2e76 65726973 
    69676e2e 636f6d2f 76736c6f 676f2e67 69663028 0603551d 11042130 1fa41d30 
    1b311930 17060355 04031310 56657269 5369676e 4d504b49 2d322d36 301d0603 
    551d0e04 1604140d 445c1653 44c1827e 1d20ab25 f40163d8 be79a530 1f060355 
    1d230418 30168014 7fd365a7 c2ddecbb f03009f3 4339fa02 af333133 300d0609 
    2a864886 f70d0101 05050003 82010100 0c8324ef ddc30cd9 589cfe36 b6eb8a80 
    4bd1a3f7 9df3cc53 ef829ea3 a1e697c1 589d756c e01d1b4c fad1c12d 05c0ea6e 
    b2227055 d9203340 3307c265 83fa8f43 379bea0e 9a6c70ee f69c803b d937f47a 
    6decd018 7d494aca 99c71928 a2bed877 24f78526 866d8705 404167d1 273aeddc 
    481d22cd 0b0b8bbc f4b17bfd b499a8e9 762ae11a 2d876e74 d388dd1e 22c6df16 
    b62b8214 0a945cf2 50ecafce ff62370d ad65d306 4153ed02 14c8b558 28a1ace0 
    5becb37f 954afb03 c8ad26db e6667812 4ad99f42 fbe198e6 42839b8f 8f6724e8 
    6119b5dd cdb50b26 058ec36e c4c875b8 46cfe218 065ea9ae a8819a47 16de0c28 
    6c2527b9 deb78458 c61f381e a4c4cb66
  quit
crypto ikev2 policy 1
 encryption aes-256
 integrity sha
 group 5 2
 prf sha
 lifetime seconds 86400
crypto ikev2 policy 10
 encryption aes-192
 integrity sha
 group 5 2
 prf sha
 lifetime seconds 86400
crypto ikev2 policy 20
 encryption aes
 integrity sha
 group 5 2
 prf sha
 lifetime seconds 86400
crypto ikev2 policy 30
 encryption 3des
 integrity sha
 group 5 2
 prf sha
 lifetime seconds 86400
crypto ikev2 policy 40
 encryption des
 integrity sha
 group 5 2
 prf sha
 lifetime seconds 86400
crypto ikev2 enable outside
crypto ikev1 enable outside
crypto ikev1 policy 10
 authentication pre-share
 encryption aes-256
 hash sha
 group 2
 lifetime 86400
telnet 192.168.0.0 255.255.255.0 inside
telnet 0.0.0.0 0.0.0.0 outside
telnet timeout 5
ssh 176.58.64.0 255.255.240.0 outside
ssh timeout 5
ssh key-exchange group dh-group1-sha1
console timeout 0
management-access inside
 
 
dhcpd dns 8.8.8.8 8.8.4.4
!
dhcpd address 192.168.0.120-192.168.0.254 inside
dhcpd dns 192.168.0.100 8.8.8.8 interface inside
dhcpd enable inside
!
threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
webvpn
group-policy DefaultRAGroup internal
group-policy DefaultRAGroup attributes
 vpn-tunnel-protocol l2tp-ipsec 
 intercept-dhcp enable
group-policy GroupPolicy_10.20.10.6 internal
group-policy GroupPolicy_10.20.10.6 attributes
 vpn-tunnel-protocol ikev1 
group-policy GroupPolicyx.x.100.230 internal
group-policy GroupPolicy_x.x.100.230 attributes
 vpn-tunnel-protocol ikev1 
group-policy surabaya internal
group-policy surabaya attributes
 vpn-tunnel-protocol ikev1 
group-policy betapramesti internal
group-policy betapramesti attributes
 dns-server value 8.8.8.8
 vpn-tunnel-protocol ikev1 
 split-tunnel-policy tunnelspecified
 split-tunnel-network-list value betapramesti_splitTunnelAcl
 default-domain none
username paul password gF4iq5XaiBmpB1qZ encrypted privilege 0
username paul attributes
 vpn-group-policy betapramesti
username drvirus password sdsdvsdGoxTo9arjn encrypted privilege 15
username betasby password sdsdds1tElugh encrypted privilege 0
username betasby attributes
 vpn-group-policy surabaya
username anto password sdsdcsddq11Et encrypted privilege 0
username anto attributes
 vpn-group-policy betapramesti
tunnel-group DefaultRAGroup general-attributes
 address-pool (inside) Beta_VPN_Uusers
 address-pool Beta_VPN_Uusers
 default-group-policy DefaultRAGroup
tunnel-group DefaultRAGroup ipsec-attributes
 ikev1 pre-shared-key *****
tunnel-group DefaultRAGroup ppp-attributes
 no authentication chap
 authentication ms-chap-v2
tunnel-group q.q..250.31 type ipsec-l2l
tunnel-group q.q.250.31 ipsec-attributes
 ikev1 pre-shared-key *****
tunnel-group betapramesti type remote-access
tunnel-group betapramesti general-attributes
 address-pool Beta_VPN_Uusers
 default-group-policy betapramesti
tunnel-group betapramesti ipsec-attributes
 ikev1 pre-shared-key *****
tunnel-group surabaya type remote-access
tunnel-group surabaya general-attributes
 address-pool Beta_VPN_Uusers
 default-group-policy surabaya
tunnel-group surabaya ipsec-attributes
 ikev1 pre-shared-key *****
tunnel-group 10.20.10.6 type ipsec-l2l
tunnel-group 10.20.10.6 general-attributes
 default-group-policy GroupPolicy_10.20.10.6
tunnel-group 10.20.10.6 ipsec-attributes
 ikev1 pre-shared-key *****
tunnel-group x.x.100.230 type ipsec-l2l
tunnel-group x.x.100.230 general-attributes
 default-group-policy GroupPolicy_x.x.100.230
tunnel-group x.x.100.230 ipsec-attributes
 ikev1 pre-shared-key *****
!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
 parameters
  message-length maximum client auto
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect dns preset_dns_map 
  inspect ftp 
  inspect h323 h225 
  inspect h323 ras 
  inspect rsh 
  inspect rtsp 
  inspect esmtp 
  inspect sqlnet 
  inspect skinny  
  inspect sunrpc 
  inspect xdmcp 
  inspect sip  
  inspect netbios 
  inspect tftp 
  inspect ip-options 
  inspect icmp 
!
service-policy global_policy global
prompt hostname context 
call-home reporting anonymous
Cryptochecksum:16debcf852f21a53e396efbe14c41d78
: end
=============================================================

 


ANY HELP ?????

vpn between two lans is ok , but i think that that lan1 dont geo from the tunnel when it request other thing lan2 !!


WT I NEED TO DO ?

 

Everyone's tags (1)
3 REPLIES
Hall of Fame Super Gold

Duplicate posts.  :P Go here:

Duplicate posts.  :P

 

Go here.

New Member

hi  ,it has been done by

hi  ,

it has been done by mikstake ,ive dleeted the old one and stayed with this current post

 

any help ?

 

regards

Silver

ASA1access-list outside

ASA1

access-list outside_cryptomap extended permit ip object In any

ASA2

access-list outside_cryptomap extended permit ip any object Cikupa-Subnet 

 

 

118
Views
0
Helpful
3
Replies